Fix buglet exposed by gcc-11 -Warray-parameter
Temporarily disable -Wstringop-overflow due to false positive in gcc-11
This commit is contained in:
parent
ab20189ebb
commit
383268517c
@ -53,3 +53,30 @@ index a62e570..504b874 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
static bool tpm12_check(void)
|
static bool tpm12_check(void)
|
||||||
|
diff --git a/tboot/include/rijndael.h b/tboot/include/rijndael.h
|
||||||
|
index 2974602..8dbcc7c 100644
|
||||||
|
--- a/tboot/include/rijndael.h
|
||||||
|
+++ b/tboot/include/rijndael.h
|
||||||
|
@@ -52,7 +52,7 @@ void rijndael_encrypt(rijndael_ctx *, const u_char *, u_char *);
|
||||||
|
|
||||||
|
int rijndaelKeySetupEnc(unsigned int [], const unsigned char [], int);
|
||||||
|
int rijndaelKeySetupDec(unsigned int [], const unsigned char [], int);
|
||||||
|
-void rijndaelEncrypt(const unsigned int [], int, const unsigned char [],
|
||||||
|
- unsigned char []);
|
||||||
|
+void rijndaelEncrypt(const unsigned int [], int, const unsigned char [16],
|
||||||
|
+ unsigned char [16]);
|
||||||
|
|
||||||
|
#endif /* __RIJNDAEL_H */
|
||||||
|
diff --git a/Config.mk b/Config.mk
|
||||||
|
index 6d2fe14..8234edd 100644
|
||||||
|
--- a/Config.mk
|
||||||
|
+++ b/Config.mk
|
||||||
|
@@ -74,6 +74,8 @@ TARGET_ARCH ?= $(shell uname -m | sed -e s/i.86/x86_32/ -e s/i86pc/x86_32/)
|
||||||
|
CFLAGS += $(CFLAGS_WARN) -fno-strict-aliasing -std=gnu99
|
||||||
|
# due to bug in gcc v4.2,3,?
|
||||||
|
CFLAGS += $(call cc-option,$(CC),-Wno-array-bounds,)
|
||||||
|
+# Due to a bug in gcc-11
|
||||||
|
+CFLAGS += $(call cc-option,$(CC),-Wno-stringop-overflow,)
|
||||||
|
|
||||||
|
|
||||||
|
ifeq ($(debug),y)
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Performs a verified launch using Intel TXT
|
Summary: Performs a verified launch using Intel TXT
|
||||||
Name: tboot
|
Name: tboot
|
||||||
Version: 1.9.11
|
Version: 1.9.11
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -66,6 +66,10 @@ make debug=y DISTDIR=$RPM_BUILD_ROOT install
|
|||||||
/boot/tboot-syms
|
/boot/tboot-syms
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 29 2020 Jeff Law <law@redhat.com> - 1:1.9.11-4
|
||||||
|
- Fix buglet exposed by gcc-11 -Warray-parameter
|
||||||
|
- Temporarily disable -Wstringop-overflow due to false positive in gcc-11
|
||||||
|
|
||||||
* Wed Jul 29 2020 Jeff Law <law@redhat.com> - 1:1.9.11-3
|
* Wed Jul 29 2020 Jeff Law <law@redhat.com> - 1:1.9.11-3
|
||||||
- Explicitly allow uninitialized variables in a few places that do it
|
- Explicitly allow uninitialized variables in a few places that do it
|
||||||
- on purpose
|
- on purpose
|
||||||
|
Loading…
Reference in New Issue
Block a user