Rebase to 2017, new upstream version numbering scheme.
This commit is contained in:
parent
812c094b08
commit
f2403ded94
2
sources
2
sources
@ -1 +1 @@
|
||||
d2c573131c8f4315d19f1778ab396d06 tbb44_20160526oss_src.tgz
|
||||
e2f43966abe123d44864df3d291fffd9 tbb2017_20160722oss_src.tgz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up tbb44_20160413oss/build/linux.gcc.inc~ tbb44_20160413oss/build/linux.gcc.inc
|
||||
--- tbb44_20160413oss/build/linux.gcc.inc~ 2016-04-14 08:47:01.000000000 -0600
|
||||
+++ tbb44_20160413oss/build/linux.gcc.inc 2016-05-06 08:25:44.477787435 -0600
|
||||
@@ -50,10 +50,10 @@ ifneq (,$(shell gcc -dumpversion | egrep
|
||||
diff -up tbb2017_20160722oss/build/linux.gcc.inc~ tbb2017_20160722oss/build/linux.gcc.inc
|
||||
--- tbb2017_20160722oss/build/linux.gcc.inc.orig 2016-08-17 06:57:29.000000000 -0600
|
||||
+++ tbb2017_20160722oss/build/linux.gcc.inc 2016-09-08 15:02:27.054318551 -0600
|
||||
@@ -68,10 +68,10 @@ ifneq (,$(shell gcc -dumpversion | egrep
|
||||
endif
|
||||
|
||||
ifeq ($(cfg), release)
|
||||
@ -14,9 +14,9 @@ diff -up tbb44_20160413oss/build/linux.gcc.inc~ tbb44_20160413oss/build/linux.gc
|
||||
endif
|
||||
|
||||
TBB_ASM.OBJ=
|
||||
diff -up tbb44_20160413oss/build/Makefile.tbbmalloc~ tbb44_20160413oss/build/Makefile.tbbmalloc
|
||||
--- tbb44_20160413oss/build/Makefile.tbbmalloc~ 2016-04-14 08:47:01.000000000 -0600
|
||||
+++ tbb44_20160413oss/build/Makefile.tbbmalloc 2016-05-06 08:25:44.504785259 -0600
|
||||
diff -up tbb2017_20160722oss/build/Makefile.tbbmalloc~ tbb2017_20160722oss/build/Makefile.tbbmalloc
|
||||
--- tbb2017_20160722oss/build/Makefile.tbbmalloc.orig 2016-08-17 06:57:29.000000000 -0600
|
||||
+++ tbb2017_20160722oss/build/Makefile.tbbmalloc 2016-09-08 15:02:27.060318066 -0600
|
||||
@@ -51,7 +51,7 @@ ORIG_LINK_MALLOC.LIB:=$(LINK_MALLOC.LIB)
|
||||
MALLOC_CPLUS.OBJ = backend.$(OBJ) large_objects.$(OBJ) backref.$(OBJ) tbbmalloc.$(OBJ)
|
||||
MALLOC.OBJ := $(MALLOC_CPLUS.OBJ) $(MALLOC_ASM.OBJ) itt_notify_malloc.$(OBJ) frontend.$(OBJ)
|
||||
@ -27,4 +27,4 @@ diff -up tbb44_20160413oss/build/Makefile.tbbmalloc~ tbb44_20160413oss/build/Mak
|
||||
|
||||
# Suppress superfluous warnings for TBBMalloc compilation
|
||||
|
||||
Diff finished. Fri May 6 08:25:55 2016
|
||||
Diff finished. Thu Sep 8 15:02:28 2016
|
||||
|
39
tbb.spec
39
tbb.spec
@ -1,11 +1,4 @@
|
||||
%global releasedate 20160526
|
||||
%global major 4
|
||||
%global minor 4
|
||||
%global update 5
|
||||
%global dotver %{major}.%{minor}
|
||||
%global sourcebasename tbb%{major}%{minor}_%{releasedate}oss
|
||||
|
||||
%global sourcefilename %{sourcebasename}_src.tgz
|
||||
%global releasedate 20160722
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||
%global with_python3 1
|
||||
@ -13,14 +6,16 @@
|
||||
|
||||
Name: tbb
|
||||
Summary: The Threading Building Blocks library abstracts low-level threading details
|
||||
Version: %{dotver}
|
||||
Release: 8.%{releasedate}%{?dist}
|
||||
License: GPLv2 with exceptions
|
||||
Version: 2017
|
||||
Release: 1.%{releasedate}%{?dist}
|
||||
License: ASL 2.0
|
||||
Group: Development/Tools
|
||||
URL: http://threadingbuildingblocks.org/
|
||||
|
||||
Source0: http://threadingbuildingblocks.org/sites/default/files/software_releases/source/%{sourcebasename}_src.tgz
|
||||
# These two are downstream sources.
|
||||
%global sourcever %{version}_%{releasedate}oss
|
||||
|
||||
Source0: https://www.threadingbuildingblocks.org/sites/default/files/software_releases/source/%{name}%{sourcever}_src.tgz
|
||||
# These three are downstream sources.
|
||||
Source6: tbb.pc
|
||||
Source7: tbbmalloc.pc
|
||||
Source8: tbbmalloc_proxy.pc
|
||||
@ -99,7 +94,7 @@ Python 3 TBB module.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{sourcebasename}
|
||||
%setup -q -n %{name}%{sourcever}
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
@ -116,18 +111,16 @@ cp -a python python3
|
||||
# Build an SSE2-enabled version so the mfence instruction can be used
|
||||
cp -a build build.orig
|
||||
make %{?_smp_mflags} tbb_build_prefix=obj stdver=c++14 \
|
||||
CXXFLAGS="$RPM_OPT_FLAGS -march=pentium4 -msse2 -fno-delete-null-pointer-checks" \
|
||||
LDFLAGS="$RPM_LD_FLAGS"
|
||||
CXXFLAGS="$RPM_OPT_FLAGS -march=pentium4 -msse2" LDFLAGS="$RPM_LD_FLAGS"
|
||||
mv build build.sse2
|
||||
mv build.orig build
|
||||
%endif
|
||||
|
||||
make %{?_smp_mflags} tbb_build_prefix=obj stdver=c++14 \
|
||||
CXXFLAGS="$RPM_OPT_FLAGS -fno-delete-null-pointer-checks" \
|
||||
LDFLAGS="$RPM_LD_FLAGS"
|
||||
CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS"
|
||||
for file in %{SOURCE6} %{SOURCE7} %{SOURCE8}; do
|
||||
base=$(basename ${file})
|
||||
sed 's/_FEDORA_VERSION/%{major}.%{minor}.%{update}/' ${file} > ${base}
|
||||
sed 's/_FEDORA_VERSION/%{version}/' ${file} > ${base}
|
||||
touch -r ${file} ${base}
|
||||
done
|
||||
|
||||
@ -147,8 +140,7 @@ popd
|
||||
|
||||
%check
|
||||
%ifarch ppc64le
|
||||
make test tbb_build_prefix=obj stdver=c++14 \
|
||||
CXXFLAGS="$RPM_OPT_FLAGS -fno-delete-null-pointer-checks"
|
||||
make test tbb_build_prefix=obj stdver=c++14 CXXFLAGS="$RPM_OPT_FLAGS"
|
||||
%endif
|
||||
|
||||
%install
|
||||
@ -200,7 +192,7 @@ popd
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%doc COPYING doc/Release_Notes.txt
|
||||
%doc LICENSE doc/Release_Notes.txt
|
||||
%{_libdir}/*.so.2
|
||||
%ifarch %{ix86}
|
||||
%{_libdir}/sse2/*.so.2
|
||||
@ -230,6 +222,9 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Sep 22 2016 Jerry James <loganjerry@gmail.com> - 2017-1.20160722
|
||||
- Rebase to 2017, new upstream version numbering scheme
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4-8.20160526
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user