Rebase to 4.3u2
This commit is contained in:
parent
64604f71ab
commit
e64341f332
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ tbb*/
|
|||||||
*.rpm
|
*.rpm
|
||||||
/tbb41_20130314oss_src.tgz
|
/tbb41_20130314oss_src.tgz
|
||||||
.*.log
|
.*.log
|
||||||
|
/tbb43_20141204oss_src.tgz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
ed4af7ccfa122f16cf9920b241633a3a tbb41_20130314oss_src.tgz
|
e903dd92d9433701f097fa7ca29a3c1f tbb43_20141204oss_src.tgz
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
diff -up tbb41_20130314oss/build/Makefile.tbbmalloc\~ tbb41_20130314oss/build/Makefile.tbbmalloc
|
|
||||||
--- tbb41_20130314oss/build/Makefile.tbbmalloc~ 2013-12-03 11:58:27.304411388 +0100
|
|
||||||
+++ tbb41_20130314oss/build/Makefile.tbbmalloc 2013-12-03 11:59:03.568650698 +0100
|
|
||||||
@@ -51,7 +51,7 @@ include $(tbb_root)/build/common_rules.i
|
|
||||||
MALLOC_CPLUS.OBJ = backend.$(OBJ) large_objects.$(OBJ) backref.$(OBJ) tbbmalloc.$(OBJ)
|
|
||||||
MALLOC.OBJ := $(MALLOC_CPLUS.OBJ) $(MALLOC_ASM.OBJ) itt_notify_malloc.$(OBJ) frontend.$(OBJ)
|
|
||||||
PROXY.OBJ := proxy.$(OBJ) tbb_function_replacement.$(OBJ)
|
|
||||||
-M_CPLUS_FLAGS := $(subst $(WARNING_KEY),,$(M_CPLUS_FLAGS)) $(DEFINE_KEY)__TBBMALLOC_BUILD=1
|
|
||||||
+M_CPLUS_FLAGS := -fno-strict-aliasing $(M_CPLUS_FLAGS) $(DEFINE_KEY)__TBBMALLOC_BUILD=1
|
|
||||||
M_INCLUDES = $(INCLUDES) $(INCLUDE_KEY)$(MALLOC_ROOT) $(INCLUDE_KEY)$(MALLOC_SOURCE_ROOT)
|
|
||||||
|
|
||||||
# Suppress superfluous warnings for TBBmalloc compilation
|
|
||||||
|
|
||||||
Diff finished. Tue Dec 3 11:59:07 2013
|
|
14
tbb-4.3-dont-snip-Wall.patch
Normal file
14
tbb-4.3-dont-snip-Wall.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up tbb43_20141204oss/build/Makefile.tbbmalloc\~ tbb43_20141204oss/build/Makefile.tbbmalloc
|
||||||
|
--- tbb43_20141204oss/build/Makefile.tbbmalloc~ 2014-12-12 12:56:34.000000000 +0100
|
||||||
|
+++ tbb43_20141204oss/build/Makefile.tbbmalloc 2015-01-19 09:52:44.419120714 +0100
|
||||||
|
@@ -51,7 +51,7 @@ ORIG_LINK_MALLOC.LIB:=$(LINK_MALLOC.LIB)
|
||||||
|
MALLOC_CPLUS.OBJ = backend.$(OBJ) large_objects.$(OBJ) backref.$(OBJ) tbbmalloc.$(OBJ)
|
||||||
|
MALLOC.OBJ := $(MALLOC_CPLUS.OBJ) $(MALLOC_ASM.OBJ) itt_notify_malloc.$(OBJ) frontend.$(OBJ)
|
||||||
|
PROXY.OBJ := proxy.$(OBJ) tbb_function_replacement.$(OBJ)
|
||||||
|
-M_CPLUS_FLAGS := $(subst $(WARNING_KEY),,$(M_CPLUS_FLAGS)) $(DEFINE_KEY)__TBBMALLOC_BUILD=1
|
||||||
|
+M_CPLUS_FLAGS := -fno-strict-aliasing $(DEFINE_KEY)__TBBMALLOC_BUILD=1
|
||||||
|
M_INCLUDES := $(INCLUDES) $(INCLUDE_KEY)$(MALLOC_ROOT) $(INCLUDE_KEY)$(MALLOC_SOURCE_ROOT)
|
||||||
|
|
||||||
|
# Suppress superfluous warnings for TBBMalloc compilation
|
||||||
|
|
||||||
|
Diff finished. Mon Jan 19 09:52:48 2015
|
17
tbb.spec
17
tbb.spec
@ -1,7 +1,7 @@
|
|||||||
%define releasedate 20130314
|
%define releasedate 20141204
|
||||||
%define major 4
|
%define major 4
|
||||||
%define minor 1
|
%define minor 3
|
||||||
%define update 3
|
%define update 2
|
||||||
%define dotver %{major}.%{minor}
|
%define dotver %{major}.%{minor}
|
||||||
%define sourcebasename tbb%{major}%{minor}_%{releasedate}oss
|
%define sourcebasename tbb%{major}%{minor}_%{releasedate}oss
|
||||||
|
|
||||||
@ -10,12 +10,12 @@
|
|||||||
Name: tbb
|
Name: tbb
|
||||||
Summary: The Threading Building Blocks library abstracts low-level threading details
|
Summary: The Threading Building Blocks library abstracts low-level threading details
|
||||||
Version: %{dotver}
|
Version: %{dotver}
|
||||||
Release: 9.%{releasedate}%{?dist}
|
Release: 1.%{releasedate}%{?dist}
|
||||||
License: GPLv2 with exceptions
|
License: GPLv2 with exceptions
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://threadingbuildingblocks.org/
|
URL: http://threadingbuildingblocks.org/
|
||||||
|
|
||||||
Source0: http://threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb41_20130314oss_src.tgz
|
Source0: http://threadingbuildingblocks.org/sites/default/files/software_releases/source/%{sourcebasename}_src.tgz
|
||||||
# These two are downstream sources.
|
# These two are downstream sources.
|
||||||
Source6: tbb.pc
|
Source6: tbb.pc
|
||||||
Source7: tbbmalloc.pc
|
Source7: tbbmalloc.pc
|
||||||
@ -33,10 +33,9 @@ Patch2: tbb-4.0-mfence.patch
|
|||||||
# Don't snip -Wall from C++ flags. Add -fno-strict-aliasing, as that
|
# Don't snip -Wall from C++ flags. Add -fno-strict-aliasing, as that
|
||||||
# uncovers some static-aliasing warnings.
|
# uncovers some static-aliasing warnings.
|
||||||
# Related: https://bugzilla.redhat.com/show_bug.cgi?id=1037347
|
# Related: https://bugzilla.redhat.com/show_bug.cgi?id=1037347
|
||||||
Patch3: tbb-4.1-dont-snip-Wall.patch
|
Patch3: tbb-4.3-dont-snip-Wall.patch
|
||||||
|
|
||||||
BuildRequires: libstdc++-devel
|
BuildRequires: libstdc++-devel
|
||||||
ExclusiveArch: %{ix86} x86_64 ia64 ppc ppc64 %{arm} aarch64 ppc64le
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Threading Building Blocks (TBB) is a C++ runtime library that
|
Threading Building Blocks (TBB) is a C++ runtime library that
|
||||||
@ -128,6 +127,10 @@ done
|
|||||||
%doc doc/html
|
%doc doc/html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 19 2015 Petr Machata <pmachata@redhat.com> - 4.3-1.20141204
|
||||||
|
- Rebase to 4.3u2
|
||||||
|
- Drop ExclusiveArch
|
||||||
|
|
||||||
* Thu Sep 25 2014 Karsten Hopp <karsten@redhat.com> 4.1-9.20130314
|
* Thu Sep 25 2014 Karsten Hopp <karsten@redhat.com> 4.1-9.20130314
|
||||||
- enable ppc64le and run 'make test' on that new arch
|
- enable ppc64le and run 'make test' on that new arch
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user