Rebase to 2018 update 5. Run check script on all architectures.
This commit is contained in:
parent
42cb19b7d4
commit
d7d6be2c8f
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (2018_U4.tar.gz) = 1903bf68f428f99e1d309f4d094c579f23504967c42a95d033fa7e9eeb15bd9da239a6670cb5ad13a08c29509dbffe4eec9117db109a86a1444f947865bb9d89
|
SHA512 (2018_U5.tar.gz) = 3e8d20276ccb1b50099f96b6cf968e3d0ada53caea1fa836ecb8652f1dca236fbbbf2c783e64ea2f761f7f21725064d19b72d176e35e4dc29706b8a30965153b
|
||||||
|
38
tbb-2018U5-dont-snip-Wall.patch
Normal file
38
tbb-2018U5-dont-snip-Wall.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
diff -up tbb-2018_U5/build/common_rules.inc\~ tbb-2018_U5/build/common_rules.inc
|
||||||
|
--- tbb-2018_U5/build/common_rules.inc~ 2018-06-19 10:04:20.000000000 -0600
|
||||||
|
+++ tbb-2018_U5/build/common_rules.inc 2018-07-03 11:18:03.540252098 -0600
|
||||||
|
@@ -136,7 +136,7 @@ LINK_FILES+=$(TEST_LIBS)
|
||||||
|
|
||||||
|
# Customizations
|
||||||
|
$(KNOWN_WARNINGS): %.$(OBJ): %.cpp
|
||||||
|
- $(CPLUS) $(COMPILE_ONLY) $(subst $(WARNING_KEY),,$(CPLUS_FLAGS)) $(CXX_ONLY_FLAGS) $(CXX_WARN_SUPPRESS) $(INCLUDES) $<
|
||||||
|
+ $(CPLUS) $(COMPILE_ONLY) $(CPLUS_FLAGS) $(CXX_ONLY_FLAGS) $(CXX_WARN_SUPPRESS) $(INCLUDES) $<
|
||||||
|
|
||||||
|
tbb_misc.$(OBJ): version_string.ver
|
||||||
|
tbb_misc.$(OBJ): INCLUDES+=$(INCLUDE_KEY).
|
||||||
|
diff -up tbb-2018_U5/build/Makefile.tbbmalloc\~ tbb-2018_U5/build/Makefile.tbbmalloc
|
||||||
|
--- tbb-2018_U5/build/Makefile.tbbmalloc~ 2018-07-03 11:16:37.945377902 -0600
|
||||||
|
+++ tbb-2018_U5/build/Makefile.tbbmalloc 2018-07-03 11:16:58.872102659 -0600
|
||||||
|
@@ -51,7 +51,7 @@ ORIG_LINK_MALLOC.LIB:=$(LINK_MALLOC.LIB)
|
||||||
|
MALLOC_CPLUS.OBJ = backend.$(OBJ) large_objects.$(OBJ) backref.$(OBJ) tbbmalloc.$(OBJ)
|
||||||
|
MALLOC.OBJ := $(MALLOC_CPLUS.OBJ) $(MALLOC_ASM.OBJ) itt_notify_malloc.$(OBJ) frontend.$(OBJ)
|
||||||
|
PROXY.OBJ := proxy.$(OBJ) tbb_function_replacement.$(OBJ)
|
||||||
|
-M_CPLUS_FLAGS := $(subst $(WARNING_KEY),,$(M_CPLUS_FLAGS)) $(CXXFLAGS) $(DEFINE_KEY)__TBBMALLOC_BUILD=1
|
||||||
|
+M_CPLUS_FLAGS := $(CXXFLAGS) -fno-strict-aliasing $(DEFINE_KEY)__TBBMALLOC_BUILD=1
|
||||||
|
M_INCLUDES := $(INCLUDES) $(INCLUDE_KEY)$(MALLOC_ROOT) $(INCLUDE_KEY)$(MALLOC_SOURCE_ROOT)
|
||||||
|
|
||||||
|
# Suppress superfluous warnings for TBBMalloc compilation
|
||||||
|
diff -dup tbb-2018_U5/build/Makefile.test\~ tbb-2018_U5/build/Makefile.test
|
||||||
|
--- tbb-2018_U5/build/Makefile.test~ 2018-06-19 10:04:20.000000000 -0600
|
||||||
|
+++ tbb-2018_U5/build/Makefile.test 2018-07-03 11:18:53.651592978 -0600
|
||||||
|
@@ -272,7 +272,7 @@ test_tbb_plain: $(TEST_PREREQUISITE) $(T
|
||||||
|
|
||||||
|
|
||||||
|
# For deprecated files, we don't mind warnings etc., thus compilation rules are most relaxed
|
||||||
|
-CPLUS_FLAGS_DEPRECATED = $(DEFINE_KEY)__TBB_TEST_DEPRECATED=1 $(subst $(WARNING_KEY),,$(CPLUS_FLAGS)) $(WARNING_SUPPRESS) $(INCLUDE_KEY)$(tbb_root)/src/test
|
||||||
|
+CPLUS_FLAGS_DEPRECATED = $(DEFINE_KEY)__TBB_TEST_DEPRECATED=1 $(CPLUS_FLAGS) $(WARNING_SUPPRESS) $(INCLUDE_KEY)$(tbb_root)/src/test
|
||||||
|
TEST_TBB_OLD.OBJ = test_concurrent_vector_v2.$(OBJ) test_concurrent_queue_v2.$(OBJ) test_mutex_v2.$(OBJ) test_task_scheduler_observer_v3.$(OBJ)
|
||||||
|
|
||||||
|
$(TEST_TBB_OLD.OBJ): CPLUS_FLAGS := $(CPLUS_FLAGS_DEPRECATED)
|
||||||
|
|
||||||
|
Diff finished. Tue Jul 3 11:19:32 2018
|
@ -1,14 +0,0 @@
|
|||||||
diff -up tbb44_20151115oss/build/Makefile.tbbmalloc\~ tbb44_20151115oss/build/Makefile.tbbmalloc
|
|
||||||
--- tbb44_20151115oss/build/Makefile.tbbmalloc~ 2016-01-14 20:20:49.514774850 -0700
|
|
||||||
+++ tbb44_20151115oss/build/Makefile.tbbmalloc 2016-01-14 20:36:32.126342096 -0700
|
|
||||||
@@ -51,7 +51,7 @@ ORIG_LINK_MALLOC.LIB:=$(LINK_MALLOC.LIB)
|
|
||||||
MALLOC_CPLUS.OBJ = backend.$(OBJ) large_objects.$(OBJ) backref.$(OBJ) tbbmalloc.$(OBJ)
|
|
||||||
MALLOC.OBJ := $(MALLOC_CPLUS.OBJ) $(MALLOC_ASM.OBJ) itt_notify_malloc.$(OBJ) frontend.$(OBJ)
|
|
||||||
PROXY.OBJ := proxy.$(OBJ) tbb_function_replacement.$(OBJ)
|
|
||||||
-M_CPLUS_FLAGS := $(subst $(WARNING_KEY),,$(M_CPLUS_FLAGS)) $(CXXFLAGS) $(DEFINE_KEY)__TBBMALLOC_BUILD=1
|
|
||||||
+M_CPLUS_FLAGS := $(CXXFLAGS) -fno-strict-aliasing $(DEFINE_KEY)__TBBMALLOC_BUILD=1
|
|
||||||
M_INCLUDES := $(INCLUDES) $(INCLUDE_KEY)$(MALLOC_ROOT) $(INCLUDE_KEY)$(MALLOC_SOURCE_ROOT)
|
|
||||||
|
|
||||||
# Suppress superfluous warnings for TBBMalloc compilation
|
|
||||||
|
|
||||||
Diff finished. Thu Jan 14 20:37:02 2016
|
|
12
tbb.spec
12
tbb.spec
@ -1,5 +1,5 @@
|
|||||||
%global upver 2018
|
%global upver 2018
|
||||||
%global uprel 4
|
%global uprel 5
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||||
%global with_python3 1
|
%global with_python3 1
|
||||||
@ -8,7 +8,7 @@
|
|||||||
Name: tbb
|
Name: tbb
|
||||||
Summary: The Threading Building Blocks library abstracts low-level threading details
|
Summary: The Threading Building Blocks library abstracts low-level threading details
|
||||||
Version: %{upver}%{?uprel:.%{uprel}}
|
Version: %{upver}%{?uprel:.%{uprel}}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://threadingbuildingblocks.org/
|
URL: http://threadingbuildingblocks.org/
|
||||||
@ -32,7 +32,7 @@ Patch2: tbb-4.0-mfence.patch
|
|||||||
# Don't snip -Wall from C++ flags. Add -fno-strict-aliasing, as that
|
# Don't snip -Wall from C++ flags. Add -fno-strict-aliasing, as that
|
||||||
# uncovers some static-aliasing warnings.
|
# uncovers some static-aliasing warnings.
|
||||||
# Related: https://bugzilla.redhat.com/show_bug.cgi?id=1037347
|
# Related: https://bugzilla.redhat.com/show_bug.cgi?id=1037347
|
||||||
Patch3: tbb-4.3-dont-snip-Wall.patch
|
Patch3: tbb-2018U5-dont-snip-Wall.patch
|
||||||
|
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
@ -165,9 +165,7 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
%ifarch ppc64le
|
|
||||||
make test tbb_build_prefix=obj stdver=c++14 CXXFLAGS="$RPM_OPT_FLAGS"
|
make test tbb_build_prefix=obj stdver=c++14 CXXFLAGS="$RPM_OPT_FLAGS"
|
||||||
%endif
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_libdir}
|
mkdir -p $RPM_BUILD_ROOT/%{_libdir}
|
||||||
@ -266,6 +264,10 @@ rm $RPM_BUILD_ROOT%{_libdir}/cmake/%{name}/README.rst
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 3 2018 Jerry James <loganjerry@gmail.com> - 2018.5-1
|
||||||
|
- Rebase to 2018 update 5
|
||||||
|
- Run check script on all architectures
|
||||||
|
|
||||||
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2018.4-2
|
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2018.4-2
|
||||||
- Rebuilt for Python 3.7
|
- Rebuilt for Python 3.7
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user