Rebase to 2017 update 5.
Also: - Change version scheme again to match upstream's change. - New source URL on github. - Drop upstreamed patch to fix detection of s390x as 64-bit arch.
This commit is contained in:
parent
70685b2258
commit
8d0d043325
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ tbb*/
|
|||||||
*.rpm
|
*.rpm
|
||||||
.*.log
|
.*.log
|
||||||
/tbb*.tgz
|
/tbb*.tgz
|
||||||
|
/*.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
bd71c82574927ce5507abcbcd3be2c1c tbb2017_20161128oss_src.tgz
|
SHA512 (2017_U5.tar.gz) = d07eeca53138432a4ac20145169907f5271e234bedfb53e0eabbed2b6fafaecdc0a2ad7bdbead205993f822e7c415233cce9afd7575d366c17a117d5cc971a65
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
diff -up tbb2017_20161128oss/build/linux.inc.s390x tbb2017_20161128oss/build/linux.inc
|
|
||||||
--- tbb2017_20161128oss/build/linux.inc.s390x 2016-11-29 15:24:54.000000000 +0100
|
|
||||||
+++ tbb2017_20161128oss/build/linux.inc 2017-01-02 10:28:44.000000000 +0100
|
|
||||||
@@ -99,7 +99,10 @@ SONAME_SUFFIX =$(shell grep TBB_COMPATIB
|
|
||||||
ifeq ($(arch),ia64)
|
|
||||||
def_prefix = lin64ipf
|
|
||||||
endif
|
|
||||||
-ifeq ($(arch),sparc s390x)
|
|
||||||
+ifeq ($(arch),sparc)
|
|
||||||
+ def_prefix = lin64
|
|
||||||
+endif
|
|
||||||
+ifeq ($(arch),s390x)
|
|
||||||
def_prefix = lin64
|
|
||||||
endif
|
|
||||||
ifeq ($(arch),armv7)
|
|
28
tbb.spec
28
tbb.spec
@ -1,4 +1,5 @@
|
|||||||
%global releasedate 20161128
|
%global upver 2017
|
||||||
|
%global uprel 5
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||||
%global with_python3 1
|
%global with_python3 1
|
||||||
@ -6,15 +7,13 @@
|
|||||||
|
|
||||||
Name: tbb
|
Name: tbb
|
||||||
Summary: The Threading Building Blocks library abstracts low-level threading details
|
Summary: The Threading Building Blocks library abstracts low-level threading details
|
||||||
Version: 2017
|
Version: %{upver}.%{uprel}
|
||||||
Release: 8.%{releasedate}%{?dist}
|
Release: 1%{?dist}
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://threadingbuildingblocks.org/
|
URL: http://threadingbuildingblocks.org/
|
||||||
|
|
||||||
%global sourcever %{version}_%{releasedate}oss
|
Source0: https://github.com/01org/tbb/archive/%{upver}_U%{uprel}.tar.gz
|
||||||
|
|
||||||
Source0: https://www.threadingbuildingblocks.org/sites/default/files/software_releases/source/%{name}%{sourcever}_src.tgz
|
|
||||||
# These three are downstream sources.
|
# These three are downstream sources.
|
||||||
Source6: tbb.pc
|
Source6: tbb.pc
|
||||||
Source7: tbbmalloc.pc
|
Source7: tbbmalloc.pc
|
||||||
@ -35,12 +34,6 @@ Patch2: tbb-4.0-mfence.patch
|
|||||||
# Related: https://bugzilla.redhat.com/show_bug.cgi?id=1037347
|
# Related: https://bugzilla.redhat.com/show_bug.cgi?id=1037347
|
||||||
Patch3: tbb-4.3-dont-snip-Wall.patch
|
Patch3: tbb-4.3-dont-snip-Wall.patch
|
||||||
|
|
||||||
# Fix detection of s390x as 64-bit arch, it affects the version script used
|
|
||||||
# for symbols in the public library
|
|
||||||
# Related: https://bugzilla.redhat.com/show_bug.cgi?id=1379632
|
|
||||||
# Upstream report: https://github.com/01org/tbb/issues/9
|
|
||||||
Patch4: tbb-2017-64bit.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
BuildRequires: swig
|
BuildRequires: swig
|
||||||
@ -100,14 +93,13 @@ Python 3 TBB module.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}%{sourcever}
|
%setup -q -n %{name}-%{upver}_U%{uprel}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
|
||||||
|
|
||||||
# For repeatable builds, don't query the hostname or architecture
|
# For repeatable builds, don't query the hostname or architecture
|
||||||
sed -i 's/`hostname -s`" ("`uname -m`/fedorabuild" ("%{_arch}/' \
|
sed -i 's/"`hostname -s`" ("`uname -m`"/fedorabuild (%{_arch}/' \
|
||||||
build/version_info_linux.sh
|
build/version_info_linux.sh
|
||||||
|
|
||||||
# Prepare to build the python module for both python 2 and python 3
|
# Prepare to build the python module for both python 2 and python 3
|
||||||
@ -229,6 +221,12 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 17 2017 Jerry James <loganjerry@gmail.com> - 2017.5-1%{?dist}
|
||||||
|
- Rebase to 2017 update 5
|
||||||
|
- Change version scheme again to match upstream's change
|
||||||
|
- New source URL on github
|
||||||
|
- Drop upstreamed patch to fix detection of s390x as 64-bit arch
|
||||||
|
|
||||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2017-8.20161128
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2017-8.20161128
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user