parent
aaea778f3b
commit
83f75f35f8
@ -1,4 +1,4 @@
|
||||
tbb21_20080605oss_src.tgz
|
||||
Getting_Started.pdf
|
||||
Reference_Manual.pdf
|
||||
tbb22_20090809oss_src.tgz
|
||||
Tutorial.pdf
|
||||
Reference.pdf
|
||||
Getting_Started.pdf
|
||||
|
8
sources
8
sources
@ -1,4 +1,4 @@
|
||||
6accb7e86dff355cd8cfbc9de1225c8d tbb21_20080605oss_src.tgz
|
||||
270b7c6bf8962e1a84296e709150f152 Getting_Started.pdf
|
||||
a63542fb8f9335f5e1c22c5b7a95d23b Reference_Manual.pdf
|
||||
dfd58635ecd01f68c2c13f46760afa26 Tutorial.pdf
|
||||
c621053887c7ee86932da43e2deb3bff tbb22_20090809oss_src.tgz
|
||||
8fee2897156b387de17a84ef0df75603 Tutorial.pdf
|
||||
2c0f0bb046ae96ba57ef620fce42af56 Reference.pdf
|
||||
5ca846dbddf77557b6a0702f31365a31 Getting_Started.pdf
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff -urp tbb20_20070927oss_src/build/linux.gcc.inc tbb20_20070927oss_src.pm/build/linux.gcc.inc
|
||||
--- tbb20_20070927oss_src/build/linux.gcc.inc 2007-09-28 22:13:21.000000000 +0200
|
||||
+++ tbb20_20070927oss_src.pm/build/linux.gcc.inc 2007-12-19 16:56:13.000000000 +0100
|
||||
@@ -45,10 +45,10 @@ LIBS = -lpthread -lrt -ldl
|
||||
C_FLAGS = $(CPLUS_FLAGS) -x c
|
||||
|
||||
ifeq ($(cfg), release)
|
||||
- CPLUS_FLAGS = -DDO_ITT_NOTIFY -O2 -DUSE_PTHREAD
|
||||
+ CPLUS_FLAGS = $(CXXFLAGS) -DDO_ITT_NOTIFY -DUSE_PTHREAD
|
||||
endif
|
||||
ifeq ($(cfg), debug)
|
||||
- CPLUS_FLAGS = -DTBB_DO_ASSERT -DDO_ITT_NOTIFY -g -O0 -DUSE_PTHREAD
|
||||
+ CPLUS_FLAGS = $(CXXFLAGS) -DTBB_DO_ASSERT -DDO_ITT_NOTIFY -DUSE_PTHREAD -g -O0
|
||||
endif
|
||||
|
||||
ASM=
|
15
tbb-2.2-20090809-cxxflags.patch
Normal file
15
tbb-2.2-20090809-cxxflags.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- tbb22_20090809oss_src/build/linux.gcc.inc 2007-09-28 22:13:21.000000000 +0200
|
||||
+++ tbb22_20090809oss_src.pm/build/linux.gcc.inc 2007-12-19 16:56:13.000000000 +0100
|
||||
@@ -45,10 +45,10 @@ LIBS = -lpthread -lrt -ldl
|
||||
C_FLAGS = $(CPLUS_FLAGS)
|
||||
|
||||
ifeq ($(cfg), release)
|
||||
- CPLUS_FLAGS = -DDO_ITT_NOTIFY -O2 -DUSE_PTHREAD
|
||||
+ CPLUS_FLAGS = $(CXXFLAGS) -DDO_ITT_NOTIFY -O2 -DUSE_PTHREAD
|
||||
endif
|
||||
ifeq ($(cfg), debug)
|
||||
- CPLUS_FLAGS = -DTBB_USE_DEBUG -DDO_ITT_NOTIFY -g -O0 -DUSE_PTHREAD
|
||||
+ CPLUS_FLAGS = $(CXXFLAGS) -DTBB_USE_DEBUG -DDO_ITT_NOTIFY -g -O0 -DUSE_PTHREAD
|
||||
endif
|
||||
|
||||
ASM=
|
41
tbb.spec
41
tbb.spec
@ -1,26 +1,31 @@
|
||||
%define releasedate 20080605
|
||||
%define releasedate 20090809
|
||||
%define major 2
|
||||
%define minor 1
|
||||
%define minor 2
|
||||
%define sourcebasename tbb%{major}%{minor}_%{releasedate}oss
|
||||
%define sourcefilename %{sourcebasename}_src.tgz
|
||||
|
||||
%define source_2 Getting_Started.pdf
|
||||
%define source_3 Reference.pdf
|
||||
%define source_4 Tutorial.pdf
|
||||
|
||||
Summary: The Threading Building Blocks library abstracts low-level threading details
|
||||
Name: tbb
|
||||
Version: %{major}.%{minor}
|
||||
Release: 3.%{releasedate}%{?dist}
|
||||
Release: 1.%{releasedate}%{?dist}
|
||||
License: GPLv2 with exceptions
|
||||
Group: Development/Tools
|
||||
URL: http://threadingbuildingblocks.org/
|
||||
Source: http://threadingbuildingblocks.org/uploads/77/84/2.0/%{sourcefilename}
|
||||
# RPM can't handle spaces in specs, so rename official files. Get rid
|
||||
# of "(Open Source)" suffix while at it.
|
||||
# http://www.threadingbuildingblocks.org/uploads/81/91/Latest Open Source Documentation/Getting Started (Open Source).pdf
|
||||
Source2: Getting_Started.pdf
|
||||
# http://www.threadingbuildingblocks.org/uploads/81/91/Latest Open Source Documentation/Reference Manual (Open Source).pdf
|
||||
Source3: Reference_Manual.pdf
|
||||
# http://www.threadingbuildingblocks.org/uploads/81/91/Latest Open Source Documentation/Tutorial (Open Source).pdf
|
||||
Source4: Tutorial.pdf
|
||||
Patch1: tbb-2.0-20070927-cxxflags.patch
|
||||
Source: http://threadingbuildingblocks.org/uploads/77/142/2.2/%{sourcefilename}
|
||||
# RPM can't handle spaces in specs, so don't include full URL. Each
|
||||
# of the following sources was downloaded from:
|
||||
# http://www.threadingbuildingblocks.org/uploads/81/91/Latest Open Source Documentation/
|
||||
# Unfortunately, because they regularly replace the "Latest"
|
||||
# documentation with what's actually Latest at that point, these
|
||||
# sources may no longer be available at that link.
|
||||
Source2: %{source_2}
|
||||
Source3: %{source_3}
|
||||
Source4: %{source_4}
|
||||
Patch1: tbb-2.2-20090809-cxxflags.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libstdc++-devel
|
||||
# We need "arch" and "hostname" binaries:
|
||||
@ -105,11 +110,15 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%files doc
|
||||
%defattr(-,root,root,-)
|
||||
%doc Getting_Started.pdf
|
||||
%doc Reference_Manual.pdf
|
||||
%doc Tutorial.pdf
|
||||
%doc %{source_2}
|
||||
%doc %{source_3}
|
||||
%doc %{source_4}
|
||||
|
||||
%changelog
|
||||
* Tue Nov 3 2009 Petr Machata <pmachata@redhat.com> - 2.2-1.20090809
|
||||
- New upstream 2.2
|
||||
- Resolves: #521571
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1-3.20080605
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user