Rebase to 2019 update 6.
Add -attributes patch to silence gcc warnings.
This commit is contained in:
parent
9ec50bf2d0
commit
4e38dfca59
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tbb-2019_U5.tar.gz) = 227b12e3864fbb922ddbc99700bf94d7d8897d62e2056bf3beb608efacf3ca785dd416b94ad65b421b6c9fc11caff688147b5fbe400c51e98678cee5dc04f274
|
||||
SHA512 (tbb-2019_U6.tar.gz) = 6513d30a498f507cb3e9a06746e430a8bc829de0d204b15d7a79f79c5e7565e59bb0b459c8ca4946293ecb25e2ce11d25cfc7f311e91c7e67342eceb31000d07
|
||||
|
31
tbb-2019-attributes.patch
Normal file
31
tbb-2019-attributes.patch
Normal file
@ -0,0 +1,31 @@
|
||||
diff -up tbb-2019_U6/src/tbbmalloc/proxy.cpp.orig tbb-2019_U6/src/tbbmalloc/proxy.cpp
|
||||
--- tbb-2019_U6/src/tbbmalloc/proxy.cpp.orig 2019-04-18 05:14:08.000000000 -0600
|
||||
+++ tbb-2019_U6/src/tbbmalloc/proxy.cpp 2019-05-08 09:27:27.394676858 -0600
|
||||
@@ -146,7 +146,7 @@ static inline void initPageSize()
|
||||
1) detection that the proxy library is loaded
|
||||
2) check that dlsym("malloc") found something different from our replacement malloc
|
||||
*/
|
||||
-extern "C" void *__TBB_malloc_proxy(size_t) __attribute__ ((alias ("malloc")));
|
||||
+extern "C" void *__TBB_malloc_proxy(size_t) __attribute__ ((alias ("malloc"),alloc_size(1),leaf,malloc,nothrow));
|
||||
|
||||
static void *orig_msize;
|
||||
|
||||
@@ -293,11 +293,11 @@ void *aligned_alloc(size_t alignment, si
|
||||
// in conjunction with standard malloc/free, so we must ovberload them.
|
||||
// Bionic doesn't have them. Not removing from the linker scripts,
|
||||
// as absent entry points are ignored by the linker.
|
||||
-void *__libc_malloc(size_t size) __attribute__ ((alias ("malloc")));
|
||||
-void *__libc_calloc(size_t num, size_t size) __attribute__ ((alias ("calloc")));
|
||||
-void *__libc_memalign(size_t alignment, size_t size) __attribute__ ((alias ("memalign")));
|
||||
-void *__libc_pvalloc(size_t size) __attribute__ ((alias ("pvalloc")));
|
||||
-void *__libc_valloc(size_t size) __attribute__ ((alias ("valloc")));
|
||||
+void *__libc_malloc(size_t size) __attribute__ ((alias ("malloc"),alloc_size(1),leaf,malloc,nothrow));
|
||||
+void *__libc_calloc(size_t num, size_t size) __attribute__ ((alias ("calloc"),alloc_size(1,2),leaf,malloc,nothrow));
|
||||
+void *__libc_memalign(size_t alignment, size_t size) __attribute__ ((alias ("memalign"),alloc_size(2),malloc,nothrow));
|
||||
+void *__libc_pvalloc(size_t size) __attribute__ ((alias ("pvalloc"),alloc_size(1),malloc,nothrow));
|
||||
+void *__libc_valloc(size_t size) __attribute__ ((alias ("valloc"),alloc_size(1),malloc,nothrow));
|
||||
|
||||
// call original __libc_* to support naive replacement of free via __libc_free etc
|
||||
void __libc_free(void *ptr)
|
||||
|
||||
Diff finished. Wed May 8 09:27:28 2019
|
@ -1,7 +1,7 @@
|
||||
diff -up tbb-2019_U1/build/common_rules.inc.orig tbb-2019_U1/build/common_rules.inc
|
||||
--- tbb-2019_U1/build/common_rules.inc.orig 2018-10-04 03:38:29.000000000 -0600
|
||||
+++ tbb-2019_U1/build/common_rules.inc 2018-10-05 09:12:02.123194170 -0600
|
||||
@@ -130,7 +130,7 @@ LINK_FILES+=$(TEST_LIBS)
|
||||
diff -up tbb-2019_U6/build/common_rules.inc.orig tbb-2019_U6/build/common_rules.inc
|
||||
--- tbb-2019_U6/build/common_rules.inc.orig 2019-04-18 05:14:08.000000000 -0600
|
||||
+++ tbb-2019_U6/build/common_rules.inc 2019-05-08 08:30:03.434532204 -0600
|
||||
@@ -126,7 +126,7 @@ LINK_FILES+=$(TEST_LIBS)
|
||||
|
||||
# Customizations
|
||||
$(KNOWN_WARNINGS): %.$(OBJ): %.cpp
|
||||
@ -10,10 +10,10 @@ diff -up tbb-2019_U1/build/common_rules.inc.orig tbb-2019_U1/build/common_rules.
|
||||
|
||||
tbb_misc.$(OBJ): version_string.ver
|
||||
tbb_misc.$(OBJ): INCLUDES+=$(INCLUDE_KEY).
|
||||
diff -up tbb-2019_U1/build/Makefile.tbbmalloc.orig tbb-2019_U1/build/Makefile.tbbmalloc
|
||||
--- tbb-2019_U1/build/Makefile.tbbmalloc.orig 2018-10-04 03:38:29.000000000 -0600
|
||||
+++ tbb-2019_U1/build/Makefile.tbbmalloc 2018-10-05 09:12:52.330321722 -0600
|
||||
@@ -51,11 +51,11 @@ ORIG_LINK_MALLOC.LIB:=$(LINK_MALLOC.LIB)
|
||||
diff -up tbb-2019_U6/build/Makefile.tbbmalloc.orig tbb-2019_U6/build/Makefile.tbbmalloc
|
||||
--- tbb-2019_U6/build/Makefile.tbbmalloc.orig 2019-04-18 05:14:08.000000000 -0600
|
||||
+++ tbb-2019_U6/build/Makefile.tbbmalloc 2019-05-08 08:30:03.447531968 -0600
|
||||
@@ -47,11 +47,11 @@ ORIG_LINK_MALLOC.LIB:=$(LINK_MALLOC.LIB)
|
||||
MALLOC_CPLUS.OBJ = backend.$(OBJ) large_objects.$(OBJ) backref.$(OBJ) tbbmalloc.$(OBJ)
|
||||
MALLOC.OBJ := $(MALLOC_CPLUS.OBJ) $(MALLOC_ASM.OBJ) itt_notify_malloc.$(OBJ) frontend.$(OBJ)
|
||||
PROXY.OBJ := proxy.$(OBJ) tbb_function_replacement.$(OBJ)
|
||||
@ -27,10 +27,10 @@ diff -up tbb-2019_U1/build/Makefile.tbbmalloc.orig tbb-2019_U1/build/Makefile.tb
|
||||
# Suppress superfluous warnings for TBBMalloc proxy compilation
|
||||
$(PROXY.OBJ): CPLUS_FLAGS += $(WARNING_SUPPRESS)
|
||||
|
||||
diff -up tbb-2019_U1/build/Makefile.test.orig tbb-2019_U1/build/Makefile.test
|
||||
--- tbb-2019_U1/build/Makefile.test.orig 2018-10-04 03:38:29.000000000 -0600
|
||||
+++ tbb-2019_U1/build/Makefile.test 2018-10-05 09:13:19.385851579 -0600
|
||||
@@ -272,7 +272,7 @@ test_tbb_plain: $(TEST_PREREQUISITE) $(T
|
||||
diff -up tbb-2019_U6/build/Makefile.test.orig tbb-2019_U6/build/Makefile.test
|
||||
--- tbb-2019_U6/build/Makefile.test.orig 2019-05-08 08:30:03.448531949 -0600
|
||||
+++ tbb-2019_U6/build/Makefile.test 2019-05-08 08:31:48.190498336 -0600
|
||||
@@ -266,7 +266,7 @@ test_tbb_plain: $(TEST_PREREQUISITE) $(T
|
||||
|
||||
|
||||
# For deprecated files, we don't mind warnings etc., thus compilation rules are most relaxed
|
||||
@ -40,4 +40,4 @@ diff -up tbb-2019_U1/build/Makefile.test.orig tbb-2019_U1/build/Makefile.test
|
||||
|
||||
$(TEST_TBB_OLD.OBJ): CPLUS_FLAGS := $(CPLUS_FLAGS_DEPRECATED)
|
||||
|
||||
Diff finished. Fri Oct 5 09:13:20 2018
|
||||
Diff finished. Wed May 8 08:31:49 2019
|
||||
|
9
tbb.spec
9
tbb.spec
@ -1,5 +1,5 @@
|
||||
%global upver 2019
|
||||
%global uprel 5
|
||||
%global uprel 6
|
||||
%global upfullver %{upver}%{?uprel:_U%{uprel}}
|
||||
|
||||
Name: tbb
|
||||
@ -20,6 +20,9 @@ Source8: tbbmalloc_proxy.pc
|
||||
# Related: https://bugzilla.redhat.com/show_bug.cgi?id=1037347
|
||||
Patch0: tbb-2019-dont-snip-Wall.patch
|
||||
|
||||
# Make attributes of aliases match those on the aliased function.
|
||||
Patch1: tbb-2019-attributes.patch
|
||||
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: python3-devel
|
||||
@ -184,6 +187,10 @@ rm $RPM_BUILD_ROOT%{_libdir}/cmake/%{name}/README.rst
|
||||
%{python3_sitearch}/__pycache__/TBB*
|
||||
|
||||
%changelog
|
||||
* Thu May 9 2019 Jerry James <loganjerry@gmail.com> - 2019.6-1
|
||||
- Rebase to 2019 update 6
|
||||
- Add -attributes patch to silence gcc warnings
|
||||
|
||||
* Mon Mar 25 2019 Jerry James <loganjerry@gmail.com> - 2019.5-1
|
||||
- Rebase to 2019 update 5
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user