Fix build failure with GCC13 (bz 2161412)
This commit is contained in:
parent
f1ddf5e782
commit
481736a2e1
25
tbb-2020-task-namespace.patch
Normal file
25
tbb-2020-task-namespace.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 04d68b41f55804bdaa7ce5f76b0fa4637f1cdadb Mon Sep 17 00:00:00 2001
|
||||
From: Thomas W Rodgers <rodgert@twrodgers.com>
|
||||
Date: Mon, 16 Jan 2023 17:20:37 -0800
|
||||
Subject: [PATCH] Fix FTBS with newer GCC
|
||||
|
||||
---
|
||||
include/tbb/task.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/include/tbb/task.h b/include/tbb/task.h
|
||||
index 5e137c6..3d167c5 100644
|
||||
--- a/include/tbb/task.h
|
||||
+++ b/include/tbb/task.h
|
||||
@@ -249,7 +249,7 @@ namespace internal {
|
||||
#if __TBB_TASK_PRIORITY
|
||||
//! Pointer to the next offloaded lower priority task.
|
||||
/** Used to maintain a list of offloaded tasks inside the scheduler. **/
|
||||
- task* next_offloaded;
|
||||
+ tbb::task* next_offloaded;
|
||||
#endif
|
||||
|
||||
#if __TBB_PREVIEW_RESUMABLE_TASKS
|
||||
--
|
||||
2.39.0
|
||||
|
8
tbb.spec
8
tbb.spec
@ -1,7 +1,7 @@
|
||||
Name: tbb
|
||||
Summary: The Threading Building Blocks library abstracts low-level threading details
|
||||
Version: 2020.3
|
||||
Release: 13%{?dist}
|
||||
Release: 14%{?dist}
|
||||
License: ASL 2.0
|
||||
URL: http://threadingbuildingblocks.org/
|
||||
|
||||
@ -31,6 +31,9 @@ Patch3: tbb-2019-test-task-scheduler-init.patch
|
||||
# exported symbols
|
||||
Patch4: tbb-mark-empty_task-execute-with-gnu-used.patch
|
||||
|
||||
# Fix "error: declaration of 'tbb::task& tbb::internal::task_prefix::task()' changes meaning of 'task' [-fpermissive]"
|
||||
Patch5: tbb-2020-task-namespace.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: gcc-c++
|
||||
@ -206,6 +209,9 @@ cmake \
|
||||
%{python3_sitearch}/__pycache__/TBB*
|
||||
|
||||
%changelog
|
||||
* Mon Jan 16 2023 Thomas Rodgers <trodgers@redhat.com> - 2020.3-14
|
||||
- Fix build failure with GCC13 (bz 2161412)
|
||||
|
||||
* Wed Jan 11 2023 Thomas Rodgers <trodgers@redhat.com> - 2020.3-13
|
||||
- Fix build failure with Python 3.12.0 (bz 2154975)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user