Updated upstream tarball. Link with $RPM_LD_FLAGS.
This commit is contained in:
parent
20ed6fb2cf
commit
414e0a2f4b
15
.gitignore
vendored
15
.gitignore
vendored
@ -1,15 +1,8 @@
|
||||
tbb22_20090809oss_src.tgz
|
||||
Tutorial.pdf
|
||||
Reference.pdf
|
||||
Getting_Started.pdf
|
||||
/tbb30_20110419oss_src.tgz
|
||||
/Tutorial.pdf
|
||||
/Reference.pdf
|
||||
/Getting_Started.pdf
|
||||
/Design_Patterns.pdf
|
||||
tbb*/
|
||||
/tbb40_20110809oss_src.tgz
|
||||
/tbb40_20120408oss_src.tgz
|
||||
*.rpm
|
||||
/tbb41_20130314oss_src.tgz
|
||||
.*.log
|
||||
/tbb43_20141204oss_src.tgz
|
||||
/tbb44_20151115oss_src.tgz
|
||||
/tbb44_20160128oss_src.tgz
|
||||
/tbb*.tgz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
9d8a4cdf43496f1b3f7c473a5248e5cc tbb44_20160128oss_src.tgz
|
||||
1908b8901730fa1049f0c45d8d0e6d7d tbb44_20160316oss_src.tgz
|
||||
|
@ -1,8 +0,0 @@
|
||||
diff -up tbb44_20160128oss/src/tbb/tools_api/ittnotify_static.c~ tbb44_20160128oss/src/tbb/tools_api/ittnotify_static.c
|
||||
--- tbb44_20160128oss/src/tbb/tools_api/ittnotify_static.c~ 2016-01-28 11:30:11.000000000 -0700
|
||||
+++ tbb44_20160128oss/src/tbb/tools_api/ittnotify_static.c 2016-02-20 11:24:34.103412460 -0700
|
||||
@@ -1038,3 +1038,4 @@ ITT_EXTERN_C __itt_error_handler_t* _N_(
|
||||
#pragma warning(pop)
|
||||
#endif /* ITT_PLATFORM==ITT_PLATFORM_WIN */
|
||||
|
||||
+#undef min
|
17
tbb.spec
17
tbb.spec
@ -1,4 +1,4 @@
|
||||
%global releasedate 20160128
|
||||
%global releasedate 20160316
|
||||
%global major 4
|
||||
%global minor 4
|
||||
%global update 3
|
||||
@ -10,7 +10,7 @@
|
||||
Name: tbb
|
||||
Summary: The Threading Building Blocks library abstracts low-level threading details
|
||||
Version: %{dotver}
|
||||
Release: 3.%{releasedate}%{?dist}
|
||||
Release: 4.%{releasedate}%{?dist}
|
||||
License: GPLv2 with exceptions
|
||||
Group: Development/Tools
|
||||
URL: http://threadingbuildingblocks.org/
|
||||
@ -36,9 +36,6 @@ Patch2: tbb-4.0-mfence.patch
|
||||
# Related: https://bugzilla.redhat.com/show_bug.cgi?id=1037347
|
||||
Patch3: tbb-4.3-dont-snip-Wall.patch
|
||||
|
||||
# Upstream: 20 Feb 2016. Fix a min macro that clashes with std::min.
|
||||
Patch4: tbb-4.4-min.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
|
||||
%description
|
||||
@ -78,7 +75,6 @@ C++ library.
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
# For repeatable builds, don't query the hostname or architecture
|
||||
sed -i 's/`hostname -s`" ("`uname -m`/fedorabuild" ("%{_arch}/' \
|
||||
@ -89,12 +85,13 @@ sed -i 's/`hostname -s`" ("`uname -m`/fedorabuild" ("%{_arch}/' \
|
||||
# Build an SSE2-enabled version so the mfence instruction can be used
|
||||
cp -a build build.orig
|
||||
make %{?_smp_mflags} CXXFLAGS="$RPM_OPT_FLAGS -march=pentium4 -msse2" \
|
||||
tbb_build_prefix=obj cpp0x=1
|
||||
LDFLAGS="$RPM_LD_FLAGS" tbb_build_prefix=obj cpp0x=1
|
||||
mv build build.sse2
|
||||
mv build.orig build
|
||||
%endif
|
||||
|
||||
make %{?_smp_mflags} CXXFLAGS="$RPM_OPT_FLAGS" tbb_build_prefix=obj cpp0x=1
|
||||
make %{?_smp_mflags} CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" \
|
||||
tbb_build_prefix=obj cpp0x=1
|
||||
for file in %{SOURCE6} %{SOURCE7} %{SOURCE8}; do
|
||||
base=$(basename ${file})
|
||||
sed 's/_FEDORA_VERSION/%{major}.%{minor}.%{update}/' ${file} > ${base}
|
||||
@ -159,6 +156,10 @@ done
|
||||
%doc doc/html
|
||||
|
||||
%changelog
|
||||
* Fri Mar 18 2016 Jerry James <loganjerry@gmail.com> - 4.4-4.20160316
|
||||
- Updated upstream tarball
|
||||
- Link with RPM_LD_FLAGS
|
||||
|
||||
* Sat Feb 20 2016 Jerry James <loganjerry@gmail.com> - 4.4-3.20160128
|
||||
- Rebase to 4.4u3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user