Rebase to 4.4u4.
This commit is contained in:
parent
45c5c472f4
commit
29a05f65c9
2
sources
2
sources
@ -1 +1 @@
|
|||||||
1908b8901730fa1049f0c45d8d0e6d7d tbb44_20160316oss_src.tgz
|
95999ccff3470f6565c516e67fb37019 tbb44_20160413oss_src.tgz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -up tbb44_20151115oss/build/linux.gcc.inc\~ tbb44_20151115oss/build/linux.gcc.inc
|
diff -up tbb44_20160413oss/build/linux.gcc.inc~ tbb44_20160413oss/build/linux.gcc.inc
|
||||||
--- tbb44_20151115oss/build/linux.gcc.inc~ 2015-11-25 03:48:43.000000000 -0700
|
--- tbb44_20160413oss/build/linux.gcc.inc~ 2016-04-14 08:47:01.000000000 -0600
|
||||||
+++ tbb44_20151115oss/build/linux.gcc.inc 2016-01-14 20:02:13.829449849 -0700
|
+++ tbb44_20160413oss/build/linux.gcc.inc 2016-05-06 08:25:44.477787435 -0600
|
||||||
@@ -54,10 +54,10 @@ ifneq (,$(shell gcc -dumpversion | egrep
|
@@ -50,10 +50,10 @@ ifneq (,$(shell gcc -dumpversion | egrep
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifeq ($(cfg), release)
|
ifeq ($(cfg), release)
|
||||||
@ -13,10 +13,10 @@ diff -up tbb44_20151115oss/build/linux.gcc.inc\~ tbb44_20151115oss/build/linux.g
|
|||||||
+ CPLUS_FLAGS = $(CXXFLAGS) -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
|
+ CPLUS_FLAGS = $(CXXFLAGS) -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifneq (00,$(lambdas)$(cpp0x))
|
TBB_ASM.OBJ=
|
||||||
diff -up tbb44_20151115oss/build/Makefile.tbbmalloc\~ tbb44_20151115oss/build/Makefile.tbbmalloc
|
diff -up tbb44_20160413oss/build/Makefile.tbbmalloc~ tbb44_20160413oss/build/Makefile.tbbmalloc
|
||||||
--- tbb44_20151115oss/build/Makefile.tbbmalloc~ 2015-11-25 03:48:44.000000000 -0700
|
--- tbb44_20160413oss/build/Makefile.tbbmalloc~ 2016-04-14 08:47:01.000000000 -0600
|
||||||
+++ tbb44_20151115oss/build/Makefile.tbbmalloc 2016-01-14 20:20:49.514774850 -0700
|
+++ tbb44_20160413oss/build/Makefile.tbbmalloc 2016-05-06 08:25:44.504785259 -0600
|
||||||
@@ -51,7 +51,7 @@ ORIG_LINK_MALLOC.LIB:=$(LINK_MALLOC.LIB)
|
@@ -51,7 +51,7 @@ ORIG_LINK_MALLOC.LIB:=$(LINK_MALLOC.LIB)
|
||||||
MALLOC_CPLUS.OBJ = backend.$(OBJ) large_objects.$(OBJ) backref.$(OBJ) tbbmalloc.$(OBJ)
|
MALLOC_CPLUS.OBJ = backend.$(OBJ) large_objects.$(OBJ) backref.$(OBJ) tbbmalloc.$(OBJ)
|
||||||
MALLOC.OBJ := $(MALLOC_CPLUS.OBJ) $(MALLOC_ASM.OBJ) itt_notify_malloc.$(OBJ) frontend.$(OBJ)
|
MALLOC.OBJ := $(MALLOC_CPLUS.OBJ) $(MALLOC_ASM.OBJ) itt_notify_malloc.$(OBJ) frontend.$(OBJ)
|
||||||
@ -27,4 +27,4 @@ diff -up tbb44_20151115oss/build/Makefile.tbbmalloc\~ tbb44_20151115oss/build/Ma
|
|||||||
|
|
||||||
# Suppress superfluous warnings for TBBMalloc compilation
|
# Suppress superfluous warnings for TBBMalloc compilation
|
||||||
|
|
||||||
Diff finished. Thu Jan 14 20:22:27 2016
|
Diff finished. Fri May 6 08:25:55 2016
|
||||||
|
9
tbb.spec
9
tbb.spec
@ -1,7 +1,7 @@
|
|||||||
%global releasedate 20160316
|
%global releasedate 20160413
|
||||||
%global major 4
|
%global major 4
|
||||||
%global minor 4
|
%global minor 4
|
||||||
%global update 3
|
%global update 4
|
||||||
%global dotver %{major}.%{minor}
|
%global dotver %{major}.%{minor}
|
||||||
%global sourcebasename tbb%{major}%{minor}_%{releasedate}oss
|
%global sourcebasename tbb%{major}%{minor}_%{releasedate}oss
|
||||||
|
|
||||||
@ -10,7 +10,7 @@
|
|||||||
Name: tbb
|
Name: tbb
|
||||||
Summary: The Threading Building Blocks library abstracts low-level threading details
|
Summary: The Threading Building Blocks library abstracts low-level threading details
|
||||||
Version: %{dotver}
|
Version: %{dotver}
|
||||||
Release: 5.%{releasedate}%{?dist}
|
Release: 6.%{releasedate}%{?dist}
|
||||||
License: GPLv2 with exceptions
|
License: GPLv2 with exceptions
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://threadingbuildingblocks.org/
|
URL: http://threadingbuildingblocks.org/
|
||||||
@ -159,6 +159,9 @@ done
|
|||||||
%doc doc/html
|
%doc doc/html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 6 2016 Jerry James <loganjerry@gmail.com> - 4.4-6.20160413
|
||||||
|
- Rebase to 4.4u4
|
||||||
|
|
||||||
* Mon Apr 4 2016 Jerry James <loganjerry@gmail.com> - 4.4-5.20160316
|
* Mon Apr 4 2016 Jerry James <loganjerry@gmail.com> - 4.4-5.20160316
|
||||||
- Add -fno-delete-null-pointer-checks to fix optimized code
|
- Add -fno-delete-null-pointer-checks to fix optimized code
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user