Rebase to version 2020.2.

This commit is contained in:
Jerry James 2020-03-31 07:43:41 -06:00
parent 259518be53
commit 1395d71065
4 changed files with 39 additions and 13 deletions

View File

@ -1 +1 @@
SHA512 (tbb-2020.1.tar.gz) = 4bcde2084c7bfee372d9473876659af59bd273f8e56ebe7fcaef41e51e18dcf8070ca2ab019caddabe6ef5c1c08c0da2f4362567b090872a5d461c9b9b6a73a7
SHA512 (tbb-2020.2.tar.gz) = b9a5d0e814ebd2e69690585bcfb5a545c06f030e193154bef161ac59066044109f8a0305a9ba535c447739da3380c351067db19c38de4bf96ec742b044f39885

View File

@ -1,7 +1,7 @@
diff -up tbb-2019_U6/build/common_rules.inc.orig tbb-2019_U6/build/common_rules.inc
--- tbb-2019_U6/build/common_rules.inc.orig 2019-04-18 05:14:08.000000000 -0600
+++ tbb-2019_U6/build/common_rules.inc 2019-05-08 08:30:03.434532204 -0600
@@ -126,7 +126,7 @@ LINK_FILES+=$(TEST_LIBS)
@@ -130,7 +130,7 @@ LINK_FILES+=$(TEST_LIBS)
# Customizations
$(KNOWN_WARNINGS): %.$(OBJ): %.cpp
@ -30,7 +30,7 @@ diff -up tbb-2019_U6/build/Makefile.tbbmalloc.orig tbb-2019_U6/build/Makefile.tb
diff -up tbb-2019_U6/build/Makefile.test.orig tbb-2019_U6/build/Makefile.test
--- tbb-2019_U6/build/Makefile.test.orig 2019-05-08 08:30:03.448531949 -0600
+++ tbb-2019_U6/build/Makefile.test 2019-05-08 08:31:48.190498336 -0600
@@ -266,7 +266,7 @@ test_tbb_plain: $(TEST_PREREQUISITE) $(T
@@ -275,7 +275,7 @@ test_tbb_plain: $(TEST_PREREQUISITE) $(T
# For deprecated files, we don't mind warnings etc., thus compilation rules are most relaxed

View File

@ -1,24 +1,47 @@
diff -up tbb-2019_U7/src/tbbmalloc/proxy.cpp.orig tbb-2019_U7/src/tbbmalloc/proxy.cpp
--- tbb-2019_U7/src/tbbmalloc/proxy.cpp.orig 2019-05-23 04:35:29.000000000 -0600
+++ tbb-2019_U7/src/tbbmalloc/proxy.cpp 2019-05-23 18:25:22.360659477 -0600
@@ -146,7 +146,7 @@ static inline void initPageSize()
diff -up oneTBB-2020.2/src/tbbmalloc/proxy.cpp.orig oneTBB-2020.2/src/tbbmalloc/proxy.cpp
--- oneTBB-2020.2/src/tbbmalloc/proxy.cpp.orig 2020-03-31 06:40:13.752296189 -0600
+++ oneTBB-2020.2/src/tbbmalloc/proxy.cpp 2020-03-31 06:42:52.611900760 -0600
@@ -146,15 +146,7 @@ static inline void initPageSize()
1) detection that the proxy library is loaded
2) check that dlsym("malloc") found something different from our replacement malloc
*/
-// Starting from GCC 9, the -Wmissing-attributes warning was extended for alias below
-#if __GNUC__ == 9
- #pragma GCC diagnostic push
- #pragma GCC diagnostic ignored "-Wmissing-attributes"
-#endif
-extern "C" void *__TBB_malloc_proxy(size_t) __attribute__ ((alias ("malloc")));
-#if __GNUC__ == 9
- #pragma GCC diagnostic pop
-#endif
+extern "C" void *__TBB_malloc_proxy(size_t) __attribute__ ((alias ("malloc"), copy (malloc)));
static void *orig_msize;
@@ -293,11 +293,11 @@ void *aligned_alloc(size_t alignment, si
@@ -296,25 +288,17 @@ struct mallinfo mallinfo() __THROW
size_t dlmalloc_usable_size(const void *ptr) __attribute__ ((alias ("malloc_usable_size")));
#else // __ANDROID__
// C11 function, supported starting GLIBC 2.16
-void *aligned_alloc(size_t alignment, size_t size) __attribute__ ((alias ("memalign")));
+void *aligned_alloc(size_t alignment, size_t size) __attribute__ ((alias ("memalign"), copy (memalign)));
// Those non-standard functions are exported by GLIBC, and might be used
// in conjunction with standard malloc/free, so we must ovberload them.
// Bionic doesn't have them. Not removing from the linker scripts,
// as absent entry points are ignored by the linker.
-// Starting from GCC 9, the -Wmissing-attributes warning was extended for aliases below
-#if __GNUC__ == 9
- #pragma GCC diagnostic push
- #pragma GCC diagnostic ignored "-Wmissing-attributes"
-#endif
-void *__libc_malloc(size_t size) __attribute__ ((alias ("malloc")));
-void *__libc_calloc(size_t num, size_t size) __attribute__ ((alias ("calloc")));
-void *__libc_memalign(size_t alignment, size_t size) __attribute__ ((alias ("memalign")));
-void *__libc_pvalloc(size_t size) __attribute__ ((alias ("pvalloc")));
-void *__libc_valloc(size_t size) __attribute__ ((alias ("valloc")));
-#if __GNUC__ == 9
- #pragma GCC diagnostic pop
-#endif
+void *__libc_malloc(size_t size) __attribute__ ((alias ("malloc"), copy (malloc)));
+void *__libc_calloc(size_t num, size_t size) __attribute__ ((alias ("calloc"), copy (calloc)));
+void *__libc_memalign(size_t alignment, size_t size) __attribute__ ((alias ("memalign"), copy (memalign)));
@ -28,4 +51,4 @@ diff -up tbb-2019_U7/src/tbbmalloc/proxy.cpp.orig tbb-2019_U7/src/tbbmalloc/prox
// call original __libc_* to support naive replacement of free via __libc_free etc
void __libc_free(void *ptr)
Diff finished. Wed May 23 18:26:03 2019
Diff finished. Tue Mar 31 06:43:27 2020

View File

@ -1,7 +1,7 @@
Name: tbb
Summary: The Threading Building Blocks library abstracts low-level threading details
Version: 2020.1
Release: 2%{?dist}
Version: 2020.2
Release: 1%{?dist}
License: ASL 2.0
URL: http://threadingbuildingblocks.org/
@ -17,7 +17,7 @@ Source8: tbbmalloc_proxy.pc
Patch0: tbb-2019-dont-snip-Wall.patch
# Make attributes of aliases match those on the aliased function.
Patch1: tbb-2019-attributes.patch
Patch1: tbb-2020-attributes.patch
# Fix test-thread-monitor, which had multiple bugs that could (and did, on
# ppc64le) result in a hang.
@ -76,7 +76,7 @@ Python 3 TBB module.
%prep
%autosetup -p1
%autosetup -p1 -n oneTBB-%{version}
# For repeatable builds, don't query the hostname or architecture
sed -i 's/"`hostname -s`" ("`uname -m`"/fedorabuild (%{_arch}/' \
@ -195,6 +195,9 @@ rm $RPM_BUILD_ROOT%{_libdir}/cmake/%{name}/README.rst
%{python3_sitearch}/__pycache__/TBB*
%changelog
* Tue Mar 31 2020 Jerry James <loganjerry@gmail.com> - 2020.2-1
- Rebase to version 2020.2
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2020.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild