import targetcli-2.1.52-1.el8
This commit is contained in:
parent
cdfb71d3d0
commit
a5f0cde792
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/targetcli-fb-2.1.51.tar.gz
|
SOURCES/targetcli-fb-2.1.52.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
3e6f8caa6fc7a2591a97fd8b5c37554c71c1dd52 SOURCES/targetcli-fb-2.1.51.tar.gz
|
0b09499167b2be66fee72aafd6dd4fde2453f8df SOURCES/targetcli-fb-2.1.52.tar.gz
|
||||||
|
@ -1,26 +1,13 @@
|
|||||||
From e1fece46f5f47ef0636132216b9d293e86153193 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Maurizio Lombardi <mlombard@redhat.com>
|
|
||||||
Date: Thu, 21 Nov 2019 09:58:55 +0100
|
|
||||||
Subject: [PATCH] setup.py: add the socket and service files to the data_files
|
|
||||||
section
|
|
||||||
|
|
||||||
Signed-off-by: Maurizio Lombardi <mlombard@redhat.com>
|
|
||||||
---
|
|
||||||
setup.py | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/setup.py b/setup.py
|
diff --git a/setup.py b/setup.py
|
||||||
index 8dff55e..13152f9 100755
|
index 4518165..2ebfc04 100755
|
||||||
--- a/setup.py
|
--- a/setup.py
|
||||||
+++ b/setup.py
|
+++ b/setup.py
|
||||||
@@ -34,6 +34,7 @@ setup(
|
@@ -34,7 +34,7 @@ setup(
|
||||||
'scripts/targetcli',
|
'scripts/targetcli',
|
||||||
'daemon/targetclid'
|
'daemon/targetclid'
|
||||||
],
|
],
|
||||||
|
- data_files = [('/lib/systemd/system', ['systemd/targetclid.socket', 'systemd/targetclid.service'])],
|
||||||
+ data_files = [('/usr/lib/systemd/system', ['systemd/targetclid.socket', 'systemd/targetclid.service'])],
|
+ data_files = [('/usr/lib/systemd/system', ['systemd/targetclid.socket', 'systemd/targetclid.service'])],
|
||||||
classifiers = [
|
classifiers = [
|
||||||
"Programming Language :: Python",
|
"Programming Language :: Python",
|
||||||
"Programming Language :: Python :: 3",
|
"Programming Language :: Python :: 3",
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
||||||
|
@ -4,10 +4,10 @@ Name: targetcli
|
|||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Summary: An administration shell for storage targets
|
Summary: An administration shell for storage targets
|
||||||
Version: 2.1.51
|
Version: 2.1.52
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: https://fedorahosted.org/targetcli-fb/
|
URL: https://github.com/open-iscsi/%{oname}
|
||||||
Source: https://fedorahosted.org/released/targetcli-fb/%{oname}-%{version}.tar.gz
|
Source: %{url}/archive/v%{version}/%{oname}-%{version}.tar.gz
|
||||||
Patch0: 0001-setup.py-add-the-socket-and-service-files-to-the-dat.patch
|
Patch0: 0001-setup.py-add-the-socket-and-service-files-to-the-dat.patch
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: python3-devel, python3-setuptools
|
BuildRequires: python3-devel, python3-setuptools
|
||||||
@ -33,6 +33,7 @@ gzip --stdout targetclid.8 > targetclid.8.gz
|
|||||||
mkdir -p %{buildroot}%{_unitdir}
|
mkdir -p %{buildroot}%{_unitdir}
|
||||||
%{__python3} setup.py install --skip-build --root %{buildroot}
|
%{__python3} setup.py install --skip-build --root %{buildroot}
|
||||||
mkdir -p %{buildroot}%{_sysconfdir}/target/backup
|
mkdir -p %{buildroot}%{_sysconfdir}/target/backup
|
||||||
|
mkdir -p %{buildroot}%{_sysconfdir}/target/pr
|
||||||
mkdir -p %{buildroot}%{_mandir}/man8/
|
mkdir -p %{buildroot}%{_mandir}/man8/
|
||||||
install -m 644 targetcli.8.gz %{buildroot}%{_mandir}/man8/
|
install -m 644 targetcli.8.gz %{buildroot}%{_mandir}/man8/
|
||||||
install -m 644 targetclid.8.gz %{buildroot}%{_mandir}/man8/
|
install -m 644 targetclid.8.gz %{buildroot}%{_mandir}/man8/
|
||||||
@ -43,6 +44,7 @@ install -m 644 targetclid.8.gz %{buildroot}%{_mandir}/man8/
|
|||||||
%{_bindir}/targetclid
|
%{_bindir}/targetclid
|
||||||
%dir %{_sysconfdir}/target
|
%dir %{_sysconfdir}/target
|
||||||
%dir %{_sysconfdir}/target/backup
|
%dir %{_sysconfdir}/target/backup
|
||||||
|
%dir %{_sysconfdir}/target/pr
|
||||||
%doc COPYING README.md
|
%doc COPYING README.md
|
||||||
%{_mandir}/man8/targetcli.8.gz
|
%{_mandir}/man8/targetcli.8.gz
|
||||||
%{_mandir}/man8/targetclid.8.gz
|
%{_mandir}/man8/targetclid.8.gz
|
||||||
@ -50,6 +52,12 @@ install -m 644 targetclid.8.gz %{buildroot}%{_mandir}/man8/
|
|||||||
%{_usr}/lib/systemd/system/targetclid.socket
|
%{_usr}/lib/systemd/system/targetclid.socket
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 11 2020 Maurizio Lombardi <mlombard@redhat.com> - 2.1.52-1
|
||||||
|
- Update to new upstream version
|
||||||
|
|
||||||
|
* Fri Dec 06 2019 Maurizio Lombardi <mlombard@redhat.com> - 2.1.51-2
|
||||||
|
- Create the target/pr directory when installing the package
|
||||||
|
|
||||||
* Mon Nov 18 2019 Maurizio Lombardi <mlombard@redhat.com> - 2.1.51-1
|
* Mon Nov 18 2019 Maurizio Lombardi <mlombard@redhat.com> - 2.1.51-1
|
||||||
- Update to new upstream release
|
- Update to new upstream release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user