import CS targetcli-2.1.57-2.el9
This commit is contained in:
parent
6e682e4f00
commit
7f11732c31
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/targetcli-fb-2.1.53.tar.gz
|
||||
SOURCES/targetcli-fb-2.1.57.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
cb06b7dc70606e63974df107d418c2344dcc7d7b SOURCES/targetcli-fb-2.1.53.tar.gz
|
||||
a1e13273f92bfeeef28b4491c6dc8d786a44c44c SOURCES/targetcli-fb-2.1.57.tar.gz
|
||||
|
31
SOURCES/0001-Fix-mapping-the-new-LUN-to-the-node-ACL.patch
Normal file
31
SOURCES/0001-Fix-mapping-the-new-LUN-to-the-node-ACL.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 02831aca57444862b9546d2d8a02e59d6ec4aaf1 Mon Sep 17 00:00:00 2001
|
||||
From: Maurizio Lombardi <mlombard@redhat.com>
|
||||
Date: Tue, 30 Jan 2024 13:03:08 +0100
|
||||
Subject: [PATCH] Fix mapping the new LUN to the node ACL
|
||||
|
||||
Signed-off-by: Maurizio Lombardi <mlombard@redhat.com>
|
||||
---
|
||||
targetcli/ui_target.py | 7 +++----
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/targetcli/ui_target.py b/targetcli/ui_target.py
|
||||
index 2c46765f9d1a..65df61f96185 100644
|
||||
--- a/targetcli/ui_target.py
|
||||
+++ b/targetcli/ui_target.py
|
||||
@@ -1151,10 +1151,9 @@ class UILUNs(UINode):
|
||||
possible_mlun += 1
|
||||
mapped_lun = possible_mlun
|
||||
|
||||
- else:
|
||||
- mlun = MappedLUN(acl, mapped_lun, lun_object, write_protect=False)
|
||||
- self.shell.log.info("Created LUN %d->%d mapping in node ACL %s"
|
||||
- % (mlun.tpg_lun.lun, mlun.mapped_lun, acl.node_wwn))
|
||||
+ mlun = MappedLUN(acl, mapped_lun, lun_object, write_protect=False)
|
||||
+ self.shell.log.info("Created LUN %d->%d mapping in node ACL %s"
|
||||
+ % (mlun.tpg_lun.lun, mlun.mapped_lun, acl.node_wwn))
|
||||
self.parent.refresh()
|
||||
|
||||
return self.new_node(ui_lun)
|
||||
--
|
||||
2.39.3
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 88da522778fc6a7b256cda7f960912b439290538 Mon Sep 17 00:00:00 2001
|
||||
From: Matt Coleman <matt@datto.com>
|
||||
Date: Fri, 19 Jun 2020 19:06:24 -0400
|
||||
Subject: [PATCH] Do not install systemd files in setup.py
|
||||
|
||||
setuptools should not perform OS-specific actions such as installing systemd units.
|
||||
OS-specific actions should be handled by the package manager.
|
||||
---
|
||||
setup.py | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 4518165..8dff55e 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -34,7 +34,6 @@ setup(
|
||||
'scripts/targetcli',
|
||||
'daemon/targetclid'
|
||||
],
|
||||
- data_files = [('/lib/systemd/system', ['systemd/targetclid.socket', 'systemd/targetclid.service'])],
|
||||
classifiers = [
|
||||
"Programming Language :: Python",
|
||||
"Programming Language :: Python :: 3",
|
||||
--
|
||||
2.27.0
|
||||
|
@ -3,18 +3,17 @@
|
||||
Name: targetcli
|
||||
License: ASL 2.0
|
||||
Summary: An administration shell for storage targets
|
||||
Version: 2.1.53
|
||||
Release: 7%{?dist}
|
||||
Version: 2.1.57
|
||||
Release: 2%{?dist}
|
||||
URL: https://github.com/open-iscsi/%{oname}
|
||||
Source: %{url}/archive/v%{version}/%{oname}-%{version}.tar.gz
|
||||
# Proposed upstream
|
||||
## From: https://github.com/open-iscsi/targetcli-fb/pull/176
|
||||
Patch1: Do-not-install-systemd-files-in-setup.py.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: python3-devel, python3-setuptools, systemd-rpm-macros
|
||||
Requires: python3-rtslib, target-restore, python3-configshell, python3-six, python3-dbus
|
||||
Requires: python3-gobject-base
|
||||
|
||||
Patch0: 0001-Fix-mapping-the-new-LUN-to-the-node-ACL.patch
|
||||
|
||||
%description
|
||||
An administration shell for configuring iSCSI, FCoE, and other
|
||||
@ -24,7 +23,7 @@ users will also need to install and use fcoe-utils.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{oname}-%{version}
|
||||
%patch1 -p1
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%py3_build
|
||||
@ -49,6 +48,12 @@ install -m 644 systemd/* %{buildroot}%{_unitdir}/
|
||||
%dir %{_sysconfdir}/target/backup
|
||||
|
||||
%changelog
|
||||
* Tue Jan 30 2024 Maurizio Lombardi <mlombard@redhat.com> - 2.1.57-2
|
||||
- Fix a regression in LUN creation and ACL mapping Jira: RHEL-23294
|
||||
|
||||
* Mon Oct 30 2023 Maurizio Lombardi <mlombard@redhat.com> - 2.1.57-1
|
||||
- Update to the latest version
|
||||
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 2.1.53-7
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
Loading…
Reference in New Issue
Block a user