import targetcli-2.1.53-1.el8
This commit is contained in:
parent
b527ff180b
commit
3c0e56e493
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/targetcli-fb-2.1.51.tar.gz
|
||||
SOURCES/targetcli-fb-2.1.53.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
3e6f8caa6fc7a2591a97fd8b5c37554c71c1dd52 SOURCES/targetcli-fb-2.1.51.tar.gz
|
||||
cb06b7dc70606e63974df107d418c2344dcc7d7b SOURCES/targetcli-fb-2.1.53.tar.gz
|
||||
|
@ -1,26 +1,13 @@
|
||||
From e1fece46f5f47ef0636132216b9d293e86153193 Mon Sep 17 00:00:00 2001
|
||||
From: Maurizio Lombardi <mlombard@redhat.com>
|
||||
Date: Thu, 21 Nov 2019 09:58:55 +0100
|
||||
Subject: [PATCH] setup.py: add the socket and service files to the data_files
|
||||
section
|
||||
|
||||
Signed-off-by: Maurizio Lombardi <mlombard@redhat.com>
|
||||
---
|
||||
setup.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 8dff55e..13152f9 100755
|
||||
index 4518165..2ebfc04 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -34,6 +34,7 @@ setup(
|
||||
@@ -34,7 +34,7 @@ setup(
|
||||
'scripts/targetcli',
|
||||
'daemon/targetclid'
|
||||
],
|
||||
- data_files = [('/lib/systemd/system', ['systemd/targetclid.socket', 'systemd/targetclid.service'])],
|
||||
+ data_files = [('/usr/lib/systemd/system', ['systemd/targetclid.socket', 'systemd/targetclid.service'])],
|
||||
classifiers = [
|
||||
"Programming Language :: Python",
|
||||
"Programming Language :: Python :: 3",
|
||||
--
|
||||
2.21.0
|
||||
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 6e4f39357a90a914d11bac21cc2d2b52c07c213d Mon Sep 17 00:00:00 2001
|
||||
From: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
|
||||
Date: Thu, 26 Mar 2020 17:18:47 +0530
|
||||
Subject: [PATCH] targetclid.sock: change SocketMode to 0600
|
||||
|
||||
SocketMode=
|
||||
If listening on a file system socket or FIFO, this option specifies the
|
||||
file system access mode used when creating the file node. Takes an
|
||||
access mode in octal notation. Defaults to 0666.
|
||||
|
||||
Thanks Alex Murray[@alexmurray], for reporting.
|
||||
|
||||
Fixes: #162
|
||||
Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
|
||||
---
|
||||
systemd/targetclid.socket | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/systemd/targetclid.socket b/systemd/targetclid.socket
|
||||
index 4730fce..ba29ebb 100644
|
||||
--- a/systemd/targetclid.socket
|
||||
+++ b/systemd/targetclid.socket
|
||||
@@ -4,6 +4,7 @@ Documentation=man:targetclid(8)
|
||||
|
||||
[Socket]
|
||||
ListenStream=/var/run/targetclid.sock
|
||||
+SocketMode=0600
|
||||
|
||||
[Install]
|
||||
WantedBy=sockets.target
|
||||
--
|
||||
2.21.0
|
||||
|
@ -4,12 +4,11 @@ Name: targetcli
|
||||
License: ASL 2.0
|
||||
Group: System Environment/Libraries
|
||||
Summary: An administration shell for storage targets
|
||||
Version: 2.1.51
|
||||
Release: 4%{?dist}
|
||||
URL: https://fedorahosted.org/targetcli-fb/
|
||||
Source: https://fedorahosted.org/released/targetcli-fb/%{oname}-%{version}.tar.gz
|
||||
Version: 2.1.53
|
||||
Release: 1%{?dist}
|
||||
URL: https://github.com/open-iscsi/%{oname}
|
||||
Source: %{url}/archive/v%{version}/%{oname}-%{version}.tar.gz
|
||||
Patch0: 0001-setup.py-add-the-socket-and-service-files-to-the-dat.patch
|
||||
Patch1: 0002-targetclid.sock-change-SocketMode-to-0600.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: python3-devel, python3-setuptools
|
||||
Requires: python3-rtslib, target-restore, python3-configshell, python3-six, python3-dbus, python3-gobject-base
|
||||
@ -24,7 +23,6 @@ users will also need to install and use fcoe-utils.
|
||||
%prep
|
||||
%setup -q -n %{oname}-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%{__python3} setup.py build
|
||||
@ -54,11 +52,11 @@ install -m 644 targetclid.8.gz %{buildroot}%{_mandir}/man8/
|
||||
%{_usr}/lib/systemd/system/targetclid.socket
|
||||
|
||||
%changelog
|
||||
* Tue Apr 14 2020 Maurizio Lombardi <mlombard@redhat.com> - 2.1.51-4
|
||||
- Increase the release version
|
||||
* Thu Jun 25 2020 Maurizio Lombardi <mlombard@redhat.com> - 2.1.53-1
|
||||
- Update to new upstream version
|
||||
|
||||
* Wed Apr 01 2020 Maurizio Lombardi <mlombard@redhat.com> - 2.1.51-3
|
||||
- targetclid.sock allows unprivileged user to execute commands
|
||||
* Mon May 11 2020 Maurizio Lombardi <mlombard@redhat.com> - 2.1.52-1
|
||||
- Update to new upstream version
|
||||
|
||||
* Fri Dec 06 2019 Maurizio Lombardi <mlombard@redhat.com> - 2.1.51-2
|
||||
- Create the target/pr directory when installing the package
|
||||
|
Loading…
Reference in New Issue
Block a user