import targetcli-2.1.51-1.el8
This commit is contained in:
parent
e33601d82d
commit
111082ad92
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/targetcli-fb-2.1.fb49.tar.gz
|
||||
SOURCES/targetcli-fb-2.1.51.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
f55bb874f9644991a042ee83f25c14d44a86d2db SOURCES/targetcli-fb-2.1.fb49.tar.gz
|
||||
3e6f8caa6fc7a2591a97fd8b5c37554c71c1dd52 SOURCES/targetcli-fb-2.1.51.tar.gz
|
||||
|
@ -0,0 +1,26 @@
|
||||
From e1fece46f5f47ef0636132216b9d293e86153193 Mon Sep 17 00:00:00 2001
|
||||
From: Maurizio Lombardi <mlombard@redhat.com>
|
||||
Date: Thu, 21 Nov 2019 09:58:55 +0100
|
||||
Subject: [PATCH] setup.py: add the socket and service files to the data_files
|
||||
section
|
||||
|
||||
Signed-off-by: Maurizio Lombardi <mlombard@redhat.com>
|
||||
---
|
||||
setup.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 8dff55e..13152f9 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -34,6 +34,7 @@ setup(
|
||||
'scripts/targetcli',
|
||||
'daemon/targetclid'
|
||||
],
|
||||
+ data_files = [('/usr/lib/systemd/system', ['systemd/targetclid.socket', 'systemd/targetclid.service'])],
|
||||
classifiers = [
|
||||
"Programming Language :: Python",
|
||||
"Programming Language :: Python :: 3",
|
||||
--
|
||||
2.21.0
|
||||
|
@ -4,13 +4,14 @@ Name: targetcli
|
||||
License: ASL 2.0
|
||||
Group: System Environment/Libraries
|
||||
Summary: An administration shell for storage targets
|
||||
Version: 2.1.fb49
|
||||
Version: 2.1.51
|
||||
Release: 1%{?dist}
|
||||
URL: https://fedorahosted.org/targetcli-fb/
|
||||
Source: https://fedorahosted.org/released/targetcli-fb/%{oname}-%{version}.tar.gz
|
||||
Patch0: 0001-setup.py-add-the-socket-and-service-files-to-the-dat.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: python3-devel, python3-setuptools
|
||||
Requires: python3-rtslib, target-restore, python3-configshell, python3-six, python3-dbus, python3-gobject
|
||||
Requires: python3-rtslib, target-restore, python3-configshell, python3-six, python3-dbus, python3-gobject-base
|
||||
|
||||
|
||||
%description
|
||||
@ -21,26 +22,37 @@ users will also need to install and use fcoe-utils.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{oname}-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%{__python3} setup.py build
|
||||
gzip --stdout targetcli.8 > targetcli.8.gz
|
||||
gzip --stdout targetclid.8 > targetclid.8.gz
|
||||
|
||||
%install
|
||||
mkdir -p %{buildroot}%{_unitdir}
|
||||
%{__python3} setup.py install --skip-build --root %{buildroot}
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/target/backup
|
||||
mkdir -p %{buildroot}%{_mandir}/man8/
|
||||
install -m 644 targetcli.8.gz %{buildroot}%{_mandir}/man8/
|
||||
install -m 644 targetclid.8.gz %{buildroot}%{_mandir}/man8/
|
||||
|
||||
%files
|
||||
%{python3_sitelib}/*
|
||||
%{_bindir}/targetcli
|
||||
%{_bindir}/targetclid
|
||||
%dir %{_sysconfdir}/target
|
||||
%dir %{_sysconfdir}/target/backup
|
||||
%doc COPYING README.md
|
||||
%{_mandir}/man8/targetcli.8.gz
|
||||
%{_mandir}/man8/targetclid.8.gz
|
||||
%{_usr}/lib/systemd/system/targetclid.service
|
||||
%{_usr}/lib/systemd/system/targetclid.socket
|
||||
|
||||
%changelog
|
||||
* Mon Nov 18 2019 Maurizio Lombardi <mlombard@redhat.com> - 2.1.51-1
|
||||
- Update to new upstream release
|
||||
|
||||
* Thu Sep 06 2018 Maurizio Lombardi <mlombard@redhat.com> - 2.1.fb49-1
|
||||
- Update to new upstream release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user