Auto sync2gitlab import of tang-7-6.el8.src.rpm
This commit is contained in:
parent
81731420d9
commit
e50c62128f
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
/tang-7.tar.bz2
|
1743
0001-Move-key-generation-to-tang.patch
Normal file
1743
0001-Move-key-generation-to-tang.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,38 @@
|
|||||||
|
From ea43ca02cf52d0455c6949683692a95e38ccdf70 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Sergio Correia <scorreia@redhat.com>
|
||||||
|
Date: Fri, 4 Dec 2020 09:05:19 -0300
|
||||||
|
Subject: [PATCH 2/2] Exit with success unless the issue was with with tangd
|
||||||
|
itself
|
||||||
|
|
||||||
|
When an HTTP parser error happens, tangd is currently exiting with an
|
||||||
|
error status, which may cause trouble in some scenarios [1].
|
||||||
|
|
||||||
|
However, we don't exit with an error in situations where we try requests
|
||||||
|
that do not exist, for instance. It makes sense to only exit with an
|
||||||
|
error when the error was with tangd itself, e.g.: when we are unable to
|
||||||
|
read the directory with the keys, not when the actual HTTP operation
|
||||||
|
does not succeed for some reason.
|
||||||
|
|
||||||
|
Upstream: https://github.com/latchset/tang/pull/55
|
||||||
|
|
||||||
|
[1] https://bugzilla.redhat.com/show_bug.cgi?id=1828558
|
||||||
|
---
|
||||||
|
src/tangd.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/tangd.c b/src/tangd.c
|
||||||
|
index b569f38..d40201f 100644
|
||||||
|
--- a/src/tangd.c
|
||||||
|
+++ b/src/tangd.c
|
||||||
|
@@ -225,7 +225,7 @@ main(int argc, char *argv[])
|
||||||
|
if (parser.http_errno != 0) {
|
||||||
|
fprintf(stderr, "HTTP Parsing Error: %s\n",
|
||||||
|
http_errno_description(parser.http_errno));
|
||||||
|
- return EXIT_FAILURE;
|
||||||
|
+ return EXIT_SUCCESS;
|
||||||
|
}
|
||||||
|
|
||||||
|
memmove(req, &req[r], rcvd - r);
|
||||||
|
--
|
||||||
|
2.27.0
|
||||||
|
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
|||||||
|
SHA512 (tang-7.tar.bz2) = dd4187fa6962523ac2a745ef05a27cdf7e5264c595942e63d406d67a1c595e87bd7e74091cb2e16362f369480cdf8e3b4bfe1fee13b9cb73d5308f42c52f138a
|
152
tang.spec
Normal file
152
tang.spec
Normal file
@ -0,0 +1,152 @@
|
|||||||
|
Name: tang
|
||||||
|
Version: 7
|
||||||
|
Release: 6%{?dist}
|
||||||
|
Summary: Network Presence Binding Daemon
|
||||||
|
|
||||||
|
License: GPLv3+
|
||||||
|
URL: https://github.com/latchset/%{name}
|
||||||
|
Source0: https://github.com/latchset/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.bz2
|
||||||
|
Patch1: 0001-Move-key-generation-to-tang.patch
|
||||||
|
Patch2: 0002-Exit-with-success-unless-the-issue-was-with-with-tan.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRequires: jose >= 8
|
||||||
|
BuildRequires: libjose-devel >= 8
|
||||||
|
BuildRequires: libjose-zlib-devel >= 8
|
||||||
|
BuildRequires: libjose-openssl-devel >= 8
|
||||||
|
|
||||||
|
BuildRequires: http-parser-devel >= 2.7.1-3
|
||||||
|
BuildRequires: systemd-devel
|
||||||
|
BuildRequires: pkgconfig
|
||||||
|
|
||||||
|
BuildRequires: systemd
|
||||||
|
BuildRequires: curl
|
||||||
|
|
||||||
|
BuildRequires: asciidoc
|
||||||
|
BuildRequires: coreutils
|
||||||
|
BuildRequires: grep
|
||||||
|
BuildRequires: sed
|
||||||
|
BuildRequires: git-core
|
||||||
|
|
||||||
|
%{?systemd_requires}
|
||||||
|
Requires: coreutils
|
||||||
|
Requires: jose >= 8
|
||||||
|
Requires: grep
|
||||||
|
Requires: sed
|
||||||
|
|
||||||
|
Requires(pre): shadow-utils
|
||||||
|
|
||||||
|
%description
|
||||||
|
Tang is a small daemon for binding data to the presence of a third party.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -S git
|
||||||
|
|
||||||
|
%build
|
||||||
|
autoreconf -i
|
||||||
|
%configure
|
||||||
|
make %{?_smp_mflags} V=1
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
%make_install
|
||||||
|
echo "User=%{name}" >> $RPM_BUILD_ROOT/%{_unitdir}/%{name}d@.service
|
||||||
|
%{__mkdir_p} $RPM_BUILD_ROOT/%{_localstatedir}/db/%{name}
|
||||||
|
|
||||||
|
%check
|
||||||
|
if ! make %{?_smp_mflags} check; then
|
||||||
|
cat test-suite.log
|
||||||
|
false
|
||||||
|
fi
|
||||||
|
|
||||||
|
%pre
|
||||||
|
getent group %{name} >/dev/null || groupadd -r %{name}
|
||||||
|
getent passwd %{name} >/dev/null || \
|
||||||
|
useradd -r -g %{name} -d %{_localstatedir}/cache/%{name} -s /sbin/nologin \
|
||||||
|
-c "Tang Network Presence Daemon user" %{name}
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%post
|
||||||
|
%systemd_post %{name}d.socket
|
||||||
|
|
||||||
|
%preun
|
||||||
|
%systemd_preun %{name}d.socket
|
||||||
|
|
||||||
|
%postun
|
||||||
|
%systemd_postun_with_restart %{name}d.socket
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license COPYING
|
||||||
|
%attr(0700, %{name}, %{name}) %{_localstatedir}/db/%{name}
|
||||||
|
%{_unitdir}/%{name}d@.service
|
||||||
|
%{_unitdir}/%{name}d.socket
|
||||||
|
%{_libexecdir}/%{name}d-keygen
|
||||||
|
%{_libexecdir}/%{name}d
|
||||||
|
%{_mandir}/man8/tang.8*
|
||||||
|
%{_bindir}/%{name}-show-keys
|
||||||
|
%{_mandir}/man1/tang-show-keys.1*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Jan 13 2021 Sergio Correia <scorreia@redhat.com> - 7-6
|
||||||
|
- Exit with success unless the issue was with with tangd itself
|
||||||
|
Resolves: rhbz#1828558
|
||||||
|
|
||||||
|
* Sun Dec 01 2019 Sergio Correia <scorreia@redhat.com> - 7-5
|
||||||
|
- Permissions of /var/db/tang set to 0700
|
||||||
|
- Home dir of user tang is /var/cache/tang
|
||||||
|
|
||||||
|
* Fri Nov 29 2019 Sergio Correia <scorreia@redhat.com> - 7-4
|
||||||
|
- Fix permissions of /var/db/tang
|
||||||
|
|
||||||
|
* Tue Oct 15 2019 Sergio Correia <scorreia@redhat.com> - 7-3
|
||||||
|
- Rebuild to ensure correct dist tag
|
||||||
|
|
||||||
|
* Sun Sep 29 2019 Sergio Correia <scorreia@redhat.com> - 7-2
|
||||||
|
- Move key generation to tang
|
||||||
|
- Resolves rhbz#1745177, rhbz#1679186
|
||||||
|
|
||||||
|
* Fri Aug 10 2018 Nathaniel McCallum <npmccallum@redhat.com> - 7-1
|
||||||
|
- New upstream release
|
||||||
|
- Retire tang-nagios package (now separate upstream)
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Nathaniel McCallum <npmccallum@redhat.com> - 6-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Nathaniel McCallum <npmccallum@redhat.com> - 5-2
|
||||||
|
- Fix incorrect dependencies
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Nathaniel McCallum <npmccallum@redhat.com> - 5-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Nov 14 2016 Nathaniel McCallum <npmccallum@redhat.com> - 4-2
|
||||||
|
- Fix a race condition in one of the tests
|
||||||
|
|
||||||
|
* Thu Nov 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 4-1
|
||||||
|
- New upstream release
|
||||||
|
- Add nagios subpackage
|
||||||
|
|
||||||
|
* Wed Oct 26 2016 Nathaniel McCallum <npmccallum@redhat.com> - 3-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
|
* Wed Oct 19 2016 Nathaniel McCallum <npmccallum@redhat.com> - 2-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
|
* Tue Aug 23 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1-1
|
||||||
|
- First release
|
Loading…
Reference in New Issue
Block a user