New upstream release - v13
Signed-off-by: Sergio Arroutbi <sarroutb@redhat.com>
This commit is contained in:
parent
ba71198636
commit
2fdccd3c73
2
.gitignore
vendored
2
.gitignore
vendored
@ -2,3 +2,5 @@
|
||||
/tang-8.tar.xz
|
||||
/tang-10.tar.xz
|
||||
/tang-11.tar.xz
|
||||
/tang-12.tar.xz
|
||||
/tang-13.tar.xz
|
||||
|
@ -1,36 +0,0 @@
|
||||
From dac0dd6f729ed6cbdd4c92f5a8b2f5e1c66127fb Mon Sep 17 00:00:00 2001
|
||||
From: Barry <barry@barrys-emacs.org>
|
||||
Date: Fri, 25 Nov 2022 16:36:26 +0000
|
||||
Subject: [PATCH] When json_load_file fails report the error details
|
||||
information (#103)
|
||||
|
||||
* When json_load_file fails report the error details information returned.
|
||||
|
||||
This allows for file I/O issues as well as JSON parsing issues
|
||||
to be reported.
|
||||
---
|
||||
src/keys.c | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/keys.c b/src/keys.c
|
||||
index 205bbe5..bbfc374 100644
|
||||
--- a/src/keys.c
|
||||
+++ b/src/keys.c
|
||||
@@ -369,9 +369,12 @@ load_keys(const char* jwkdir)
|
||||
continue;
|
||||
}
|
||||
filepath[sizeof(filepath) - 1] = '\0';
|
||||
- json_auto_t* json = json_load_file(filepath, 0, NULL);
|
||||
+ json_error_t error;
|
||||
+ json_auto_t* json = json_load_file(filepath, 0, &error);
|
||||
if (!json) {
|
||||
- fprintf(stderr, "Invalid JSON file (%s); skipping\n", filepath);
|
||||
+ fprintf(stderr, "Cannot load JSON file (%s); skipping\n", filepath);
|
||||
+ fprintf(stderr, "error text %s, line %d, col %d, pos %d\n",
|
||||
+ error.text, error.line, error.column, error.position);
|
||||
continue;
|
||||
}
|
||||
|
||||
--
|
||||
2.38.1
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tang-11.tar.xz) = 332ff8bca33afef17cb86a77780f34499659ee0576b36b111a0a57996836b6770d89c5f5fa5da9c6095f17c731db6ad1e261bf6d97b6daa109565e8e294e3b87
|
||||
SHA512 (tang-13.tar.xz) = 77f18c7860fa3c40240c5fab4063eee4971eab736515a8f10652f919f67737db497169a2d844ac0cff6938e7199c1745c17859e17669201701eabf92857d9237
|
||||
|
10
tang.spec
10
tang.spec
@ -1,6 +1,6 @@
|
||||
Name: tang
|
||||
Version: 11
|
||||
Release: 6%{?dist}
|
||||
Version: 13
|
||||
Release: 1%{?dist}
|
||||
Summary: Network Presence Binding Daemon
|
||||
|
||||
License: GPLv3+
|
||||
@ -8,8 +8,6 @@ URL: https://github.com/latchset/%{name}
|
||||
Source0: https://github.com/latchset/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.xz
|
||||
Source1: tang.sysusers
|
||||
|
||||
Patch: 0001-When-json_load_file-fails-report-the-error-details-i.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: meson
|
||||
BuildRequires: git-core
|
||||
@ -31,6 +29,7 @@ BuildRequires: coreutils
|
||||
BuildRequires: grep
|
||||
BuildRequires: socat
|
||||
BuildRequires: sed
|
||||
BuildRequires: iproute
|
||||
|
||||
%{?systemd_requires}
|
||||
Requires: coreutils
|
||||
@ -100,6 +99,9 @@ fi
|
||||
%{_sysusersdir}/tang.conf
|
||||
|
||||
%changelog
|
||||
* Fri Feb 10 2023 Sergio Arroutbi <sarroutb@redhat.com> - 13-1
|
||||
- New upstream release - v13
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 11-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user