taglib/taglib-1.5-1.6-mpeg-cmake.patch
Michael Schwendt f69b1b0917 - Cherry-pick bug-fix patches from 1.6 development (also replaces the old
taglib-1.5-kde#161721.patch):
169810)
107659)
Fixed overflow while calculating bitrate of FLAC files with a very high
    bitrate.
:year() now falls back to YEAR if DATE doesn't exist and
    XiphComment::year() falls back to TRACKNUM if TRACKNUMBER doesn't
    exist. (BUG:144396)
:split().
:operator[] and in String::operator+=. (BUG:169389)
176373)
167786)
188578)
168382)
172556)
Added support for PRIV ID3v2 frames.
Empty ID3v2 genres are no longer treated as numeric ID3v1 genres.
Added support for the POPM (rating/playcount) ID3v2 frame.
161721)
2009-08-22 10:44:21 +00:00

13 lines
602 B
Diff

diff -Nur taglib-1.5-orig/taglib/CMakeLists.txt taglib-1.5/taglib/CMakeLists.txt
--- taglib-1.5-orig/taglib/CMakeLists.txt 2008-02-12 05:15:20.000000000 +0100
+++ taglib-1.5/taglib/CMakeLists.txt 2009-08-22 12:18:40.000000000 +0200
@@ -62,6 +62,8 @@
mpeg/id3v2/frames/attachedpictureframe.cpp
mpeg/id3v2/frames/commentsframe.cpp
mpeg/id3v2/frames/generalencapsulatedobjectframe.cpp
+mpeg/id3v2/frames/popularimeterframe.cpp
+mpeg/id3v2/frames/privateframe.cpp
mpeg/id3v2/frames/relativevolumeframe.cpp
mpeg/id3v2/frames/textidentificationframe.cpp
mpeg/id3v2/frames/uniquefileidentifierframe.cpp