taglib-1.8
This commit is contained in:
parent
824c1ab051
commit
0732b66bd3
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/taglib-1.7.2.tar.gz
|
||||
/taglib-1.8.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
b0a9e797d3833fb933c7c3176de3d720 taglib-1.7.2.tar.gz
|
||||
dcb8bd1b756f2843e18b1fdf3aaeee15 taglib-1.8.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -Nur taglib-1.7.orig/taglib/ape/apeproperties.cpp taglib-1.7/taglib/ape/apeproperties.cpp
|
||||
--- taglib-1.7.orig/taglib/ape/apeproperties.cpp 2011-03-12 00:15:38.000000000 +1100
|
||||
+++ taglib-1.7/taglib/ape/apeproperties.cpp 2011-07-29 21:19:45.984345060 +1000
|
||||
@@ -137,7 +137,7 @@
|
||||
long ID3v2OriginalSize = 0;
|
||||
bool hasID3v2 = false;
|
||||
if(ID3v2Location >= 0) {
|
||||
- ID3v2::Tag tag(d->file, ID3v2Location, 0);
|
||||
+ ID3v2::Tag tag(d->file, ID3v2Location);
|
||||
ID3v2OriginalSize = tag.header()->completeTagSize();
|
||||
if(tag.header()->tagSize() > 0)
|
||||
hasID3v2 = true;
|
33
taglib.spec
33
taglib.spec
@ -11,25 +11,20 @@
|
||||
%global apidocdir __api-doc_fedora
|
||||
|
||||
Name: taglib
|
||||
Version: 1.7.2
|
||||
Release: 2%{?dist}
|
||||
Version: 1.8
|
||||
Release: 0.1%{?dist}
|
||||
Summary: Audio Meta-Data Library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: LGPLv2
|
||||
#URL: http://developer.kde.org/~wheeler/taglib.html
|
||||
URL: http://launchpad.net/taglib
|
||||
Source0: https://github.com/downloads/taglib/taglib/taglib-%{version}.tar.gz
|
||||
#Source0: http://launchpad.net/taglib/trunk/%{version}%{?pre}/+download/taglib-%{version}%{?pre}.tar.gz
|
||||
Source0: https://github.com/downloads/taglib/taglib/taglib-%{version}%{?pre}.tar.gz
|
||||
#Source0: taglib-%{svn}.tar.gz
|
||||
# The svn tarball is generated with the following script
|
||||
Source1: taglib-svn.sh
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
# Bugfix: crash parsing ID3v2 tag in ape file due to null
|
||||
# pointer dereference RHBZ#700727
|
||||
# https://bugs.kde.org/show_bug.cgi?id=278773
|
||||
Patch0: taglib-ape-id3v2parse.patch
|
||||
# http://bugzilla.redhat.com/343241
|
||||
# try 1, use pkg-config
|
||||
Patch1: taglib-1.5b1-multilib.patch
|
||||
@ -56,7 +51,6 @@ popular audio formats. Currently it supports both ID3v1 and ID3v2 for MP3
|
||||
files, Ogg Vorbis comments and ID3 tags and Vorbis comments in FLAC, MPC,
|
||||
Speex, WavPack, TrueAudio files, as well as APE Tags.
|
||||
|
||||
|
||||
%if %{with doc}
|
||||
%package doc
|
||||
Summary: API Documentation for %{name}
|
||||
@ -68,7 +62,6 @@ BuildArch: noarch
|
||||
This is API documentation generated from the TagLib source code.
|
||||
%endif
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Group: Development/Libraries
|
||||
@ -85,7 +78,6 @@ Files needed when building software with %{name}.
|
||||
%prep
|
||||
%setup -q -n taglib-%{version}%{?pre}
|
||||
|
||||
%patch0 -p1 -b .ape.crash
|
||||
# patch1 not applied
|
||||
## omit for now
|
||||
%patch2 -p1 -b .multilib
|
||||
@ -94,7 +86,9 @@ Files needed when building software with %{name}.
|
||||
%build
|
||||
mkdir -p %{_target_platform}
|
||||
pushd %{_target_platform}
|
||||
%{cmake} %{?buildtests} -DWITH_ASF=1 -DWITH_MP4=1 ..
|
||||
%{cmake} \
|
||||
%{?buildtests} \
|
||||
..
|
||||
popd
|
||||
|
||||
make %{?_smp_mflags} -C %{_target_platform}
|
||||
@ -107,12 +101,7 @@ make docs -C %{_target_platform}
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
|
||||
make install DESTDIR=%{buildroot} -C %{_target_platform}
|
||||
|
||||
# unpackaged files
|
||||
rm -fr examples/.deps
|
||||
rm -fr examples/Makefile* examples/CMake*
|
||||
rm -f %{buildroot}%{_libdir}/lib*.la
|
||||
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
|
||||
|
||||
%if %{with doc}
|
||||
rm -fr %{apidocdir} ; mkdir %{apidocdir}
|
||||
@ -121,7 +110,6 @@ ln -s html/index.html %{apidocdir}
|
||||
find %{apidocdir} -name '*.md5' | xargs rm -fv
|
||||
%endif
|
||||
|
||||
|
||||
%if %{with tests}
|
||||
%check
|
||||
ln -s ../../tests/data %{_target_platform}/tests/
|
||||
@ -160,8 +148,11 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
* Thu Sep 06 2012 Rex Dieter <rdieter@fedoraproject.org> 1.8-1
|
||||
- taglib-1.8
|
||||
|
||||
-* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.2-2
|
||||
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Apr 21 2012 Rex Dieter <rdieter@fedoraproject.org> 1.7.2-1
|
||||
- taglib-1.7.2
|
||||
|
Loading…
Reference in New Issue
Block a user