- rebuild
This commit is contained in:
parent
ee6fb0cb55
commit
fe18a23b7d
@ -1 +1 @@
|
||||
systemtap-0.5.13.tar.gz
|
||||
systemtap-0.5.14.tar.gz
|
||||
|
106
elfutils-configury.patch
Normal file
106
elfutils-configury.patch
Normal file
@ -0,0 +1,106 @@
|
||||
Index: Makefile.am
|
||||
===================================================================
|
||||
RCS file: /cvs/systemtap/src/Makefile.am,v
|
||||
retrieving revision 1.80
|
||||
retrieving revision 1.81
|
||||
diff -u -r1.80 -r1.81
|
||||
--- Makefile.am 2 Jul 2007 19:40:50 -0000 1.80
|
||||
+++ Makefile.am 3 Jul 2007 19:49:36 -0000 1.81
|
||||
@@ -44,16 +44,16 @@
|
||||
|
||||
.PHONY: install-elfutils
|
||||
install-elfutils:
|
||||
- mkdir -p $(pkglibdir)
|
||||
+ mkdir -p $(DESTDIR)$(pkglibdir)
|
||||
for file in lib-elfutils/*.so* lib-elfutils/${PACKAGE_NAME}/*.so*; do \
|
||||
- $(INSTALL_PROGRAM) $$file $(pkglibdir); \
|
||||
+ $(INSTALL_PROGRAM) $$file $(DESTDIR)$(pkglibdir); \
|
||||
done
|
||||
install-exec-local: install-elfutils
|
||||
endif
|
||||
|
||||
staprun_SOURCES = runtime/staprun/staprun.c runtime/staprun/mainloop.c \
|
||||
runtime/staprun/symbols.c runtime/staprun/ctl.c \
|
||||
- runtime/staprun/relay.c runtime/staprun/relay_old.c
|
||||
+ runtime/staprun/relay.c runtime/staprun/relay_old.c
|
||||
|
||||
staprun_CFLAGS = @PROCFLAGS@ $(AM_CFLAGS)
|
||||
staprun_LDADD = @PROCFLAGS@ -lpthread
|
||||
@@ -78,7 +78,7 @@
|
||||
$(CC) -shared -rdynamic $(LDFLAGS) $(CFLAGS) -fPIC -o $@ $<
|
||||
all-local: $(STAPLOG)
|
||||
install-exec-local: $(STAPLOG)
|
||||
- $(INSTALL) $(STAPLOG) $(pkglibdir)
|
||||
+ $(INSTALL) $(STAPLOG) $(DESTDIR)$(pkglibdir)
|
||||
else
|
||||
endif
|
||||
|
||||
@@ -153,10 +153,9 @@
|
||||
SUBDIRS += runtime/lket/b2a
|
||||
endif
|
||||
|
||||
-SRCDIR = $(shell cd $(srcdir); pwd)
|
||||
-
|
||||
check:
|
||||
- $(MAKE) -C testsuite check SYSTEMTAP_RUNTIME=$(SRCDIR)/runtime SYSTEMTAP_TAPSET=$(SRCDIR)/tapset LD_LIBRARY_PATH=$(PWD)/lib-elfutils:$(PWD)/lib-elfutils/systemtap SYSTEMTAP_PATH=$(PWD) RUNTESTFLAGS="$(RUNTESTFLAGS)"
|
||||
+ SRCDIR=`cd $(srcdir); pwd`; \
|
||||
+ $(MAKE) -C testsuite check SYSTEMTAP_RUNTIME=$$SRCDIR/runtime SYSTEMTAP_TAPSET=$$SRCDIR/tapset LD_LIBRARY_PATH=$(PWD)/lib-elfutils:$(PWD)/lib-elfutils/systemtap SYSTEMTAP_PATH=$(PWD) RUNTESTFLAGS="$(RUNTESTFLAGS)"
|
||||
|
||||
installcheck:
|
||||
$(MAKE) -C testsuite installcheck RUNTESTFLAGS="$(RUNTESTFLAGS)"
|
||||
Index: Makefile.in
|
||||
===================================================================
|
||||
RCS file: /cvs/systemtap/src/Makefile.in,v
|
||||
retrieving revision 1.89
|
||||
retrieving revision 1.90
|
||||
diff -u -r1.89 -r1.90
|
||||
--- Makefile.in 2 Jul 2007 19:40:50 -0000 1.89
|
||||
+++ Makefile.in 3 Jul 2007 19:49:36 -0000 1.90
|
||||
@@ -283,7 +282,7 @@
|
||||
@BUILD_ELFUTILS_TRUE@stap_DEPENDENCIES = lib-elfutils/libdw.so
|
||||
staprun_SOURCES = runtime/staprun/staprun.c runtime/staprun/mainloop.c \
|
||||
runtime/staprun/symbols.c runtime/staprun/ctl.c \
|
||||
- runtime/staprun/relay.c runtime/staprun/relay_old.c
|
||||
+ runtime/staprun/relay.c runtime/staprun/relay_old.c
|
||||
|
||||
staprun_CFLAGS = @PROCFLAGS@ $(AM_CFLAGS)
|
||||
staprun_LDADD = @PROCFLAGS@ -lpthread
|
||||
@@ -317,7 +316,6 @@
|
||||
TEST_COV_DIR = coverage
|
||||
# XXX: leaves behind man pages
|
||||
SUBDIRS = testsuite $(am__append_4)
|
||||
-SRCDIR = $(shell cd $(srcdir); pwd)
|
||||
all: $(BUILT_SOURCES) config.h
|
||||
$(MAKE) $(AM_MAKEFLAGS) all-recursive
|
||||
|
||||
@@ -1385,9 +1383,9 @@
|
||||
|
||||
@BUILD_ELFUTILS_TRUE@.PHONY: install-elfutils
|
||||
@BUILD_ELFUTILS_TRUE@install-elfutils:
|
||||
-@BUILD_ELFUTILS_TRUE@ mkdir -p $(pkglibdir)
|
||||
+@BUILD_ELFUTILS_TRUE@ mkdir -p $(DESTDIR)$(pkglibdir)
|
||||
@BUILD_ELFUTILS_TRUE@ for file in lib-elfutils/*.so* lib-elfutils/${PACKAGE_NAME}/*.so*; do \
|
||||
-@BUILD_ELFUTILS_TRUE@ $(INSTALL_PROGRAM) $$file $(pkglibdir); \
|
||||
+@BUILD_ELFUTILS_TRUE@ $(INSTALL_PROGRAM) $$file $(DESTDIR)$(pkglibdir); \
|
||||
@BUILD_ELFUTILS_TRUE@ done
|
||||
@BUILD_ELFUTILS_TRUE@install-exec-local: install-elfutils
|
||||
|
||||
@@ -1395,7 +1393,7 @@
|
||||
@BUILD_CRASHMOD_TRUE@ $(CC) -shared -rdynamic $(LDFLAGS) $(CFLAGS) -fPIC -o $@ $<
|
||||
@BUILD_CRASHMOD_TRUE@all-local: $(STAPLOG)
|
||||
@BUILD_CRASHMOD_TRUE@install-exec-local: $(STAPLOG)
|
||||
-@BUILD_CRASHMOD_TRUE@ $(INSTALL) $(STAPLOG) $(pkglibdir)
|
||||
+@BUILD_CRASHMOD_TRUE@ $(INSTALL) $(STAPLOG) $(DESTDIR)$(pkglibdir)
|
||||
|
||||
# Copy some of the testsuite sample scripts to the distdir
|
||||
# 'examples/samples' directory.
|
||||
@@ -1443,7 +1441,8 @@
|
||||
-rm -rf $(DESTDIR)$(localstatedir)/cache/$(PACKAGE)
|
||||
|
||||
check:
|
||||
- $(MAKE) -C testsuite check SYSTEMTAP_RUNTIME=$(SRCDIR)/runtime SYSTEMTAP_TAPSET=$(SRCDIR)/tapset LD_LIBRARY_PATH=$(PWD)/lib-elfutils:$(PWD)/lib-elfutils/systemtap SYSTEMTAP_PATH=$(PWD) RUNTESTFLAGS="$(RUNTESTFLAGS)"
|
||||
+ SRCDIR=`cd $(srcdir); pwd`; \
|
||||
+ $(MAKE) -C testsuite check SYSTEMTAP_RUNTIME=$$SRCDIR/runtime SYSTEMTAP_TAPSET=$$SRCDIR/tapset LD_LIBRARY_PATH=$(PWD)/lib-elfutils:$(PWD)/lib-elfutils/systemtap SYSTEMTAP_PATH=$(PWD) RUNTESTFLAGS="$(RUNTESTFLAGS)"
|
||||
|
||||
installcheck:
|
||||
$(MAKE) -C testsuite installcheck RUNTESTFLAGS="$(RUNTESTFLAGS)"
|
2
sources
2
sources
@ -1 +1 @@
|
||||
31ed20d6076736f6ffab74d5f7e4c9a3 systemtap-0.5.13.tar.gz
|
||||
18b705a7364d174f86f09ecb465f547d systemtap-0.5.14.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
# Release number for rpm build. Stays at 1 for new PACKAGE_VERSION increases.
|
||||
%define release 1
|
||||
# Version number of oldest elfutils release that works with systemtap.
|
||||
%define elfutils_version 0.125
|
||||
%define elfutils_version 0.128
|
||||
|
||||
# Set bundled_elfutils to 0 on systems that have %{elfutils_version} or newer.
|
||||
%if 0%{?fedora}
|
||||
@ -13,7 +13,7 @@
|
||||
|
||||
%if 0%{?rhel}
|
||||
%define bundled_elfutils 1
|
||||
%if "%rhel" >= "5"
|
||||
%if "%rhel" >= "6"
|
||||
%define bundled_elfutils 0
|
||||
%endif
|
||||
%endif
|
||||
@ -25,7 +25,7 @@
|
||||
%endif
|
||||
|
||||
Name: systemtap
|
||||
Version: 0.5.13
|
||||
Version: 0.5.14
|
||||
Release: %{release}%{?dist}
|
||||
Summary: Instrumentation System
|
||||
Group: Development/System
|
||||
@ -39,6 +39,7 @@ Requires: kernel >= 2.6.9-11
|
||||
BuildRequires: glib2-devel >= 2.0.0
|
||||
# make check
|
||||
BuildRequires: dejagnu
|
||||
BuildRequires: sqlite-devel
|
||||
Requires: glib2 >= 2.0.0
|
||||
# Requires: kernel-devel
|
||||
# or is that kernel-smp-devel? kernel-hugemem-devel?
|
||||
@ -46,6 +47,7 @@ Requires: gcc make
|
||||
# Suggest: kernel-debuginfo
|
||||
Requires: systemtap-runtime = %{version}-%{release}
|
||||
Requires: sudo
|
||||
Requires: sqlite
|
||||
|
||||
%if %{bundled_elfutils}
|
||||
Source1: elfutils-%{elfutils_version}.tar.gz
|
||||
@ -55,6 +57,8 @@ Patch1: elfutils-portability.patch
|
||||
BuildRequires: elfutils-devel >= %{elfutils_version}
|
||||
%endif
|
||||
|
||||
Patch2: elfutils-configury.patch
|
||||
|
||||
%description
|
||||
SystemTap is an instrumentation system for systems running Linux 2.6.
|
||||
Developers can write instrumentation to collect data on the operation
|
||||
@ -82,9 +86,15 @@ sleep 1
|
||||
find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
|
||||
sleep 1
|
||||
find . \( -name configure -o -name config.h.in \) -print | xargs touch
|
||||
|
||||
# XXX trivial patch for 0.128
|
||||
sed -i /ifndef/s/PACKAGE/PACKAGE_NAME/ libdwfl/libdwflP.h
|
||||
|
||||
cd ..
|
||||
%endif
|
||||
|
||||
%patch2 -p0
|
||||
|
||||
%build
|
||||
|
||||
%if %{bundled_elfutils}
|
||||
@ -103,7 +113,7 @@ cd ..
|
||||
%endif
|
||||
|
||||
%configure %{?elfutils_config}
|
||||
make %{?_smp_mflags} AM_CFLAGS="-D_GNU_SOURCE -fexceptions -Wall -Wextra"
|
||||
make %{?_smp_mflags}
|
||||
|
||||
# Fix paths in the example scripts
|
||||
find examples -type f -name '*.stp' -print0 | xargs -0 sed -i -r -e '1s@^#!.+stap@#!%{_bindir}/stap@'
|
||||
@ -137,7 +147,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%if %{bundled_elfutils}
|
||||
%dir %{_libdir}/%{name}
|
||||
%{_libdir}/%{name}/lib*.so*
|
||||
%{_libdir}/%{name}/*.so*
|
||||
%endif
|
||||
|
||||
%files runtime
|
||||
@ -149,6 +159,15 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%doc README AUTHORS NEWS COPYING
|
||||
|
||||
%changelog
|
||||
* Tue Jul 2 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.14-1
|
||||
- Many robustness improvements: 1117, 1134, 1305, 1307, 1570, 1806,
|
||||
2033, 2116, 2224, 2339, 2341, 2406, 2426, 2438, 2583, 3037,
|
||||
3261, 3282, 3331, 3428 3519, 3545, 3625, 3648, 3880, 3888, 3911,
|
||||
3952, 3965, 4066, 4071, 4075, 4078, 4081, 4096, 4119, 4122, 4127,
|
||||
4146, 4171, 4179, 4183, 4221, 4224, 4254, 4281, 4319, 4323, 4326,
|
||||
4329, 4332, 4337, 4415, 4432, 4444, 4445, 4458, 4467, 4470, 4471,
|
||||
4518, 4567, 4570, 4579, 4589, 4609, 4664
|
||||
|
||||
* Mon Mar 26 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.13-1
|
||||
- An emergency / preliminary refresh, mainly for compatibility
|
||||
with 2.6.21-pre kernels.
|
||||
|
Loading…
Reference in New Issue
Block a user