Fixes for gcc-4.7 based on upstream commits e14c86 and 47caa9.
This commit is contained in:
parent
89af1c0ab9
commit
fc3b63d11a
73
gcc-4.7.patch
Normal file
73
gcc-4.7.patch
Normal file
@ -0,0 +1,73 @@
|
|||||||
|
diff --git a/cache.cxx b/cache.cxx
|
||||||
|
index 5104f8d..aaba56f 100644
|
||||||
|
--- a/cache.cxx
|
||||||
|
+++ b/cache.cxx
|
||||||
|
@@ -22,6 +22,7 @@ extern "C" {
|
||||||
|
#include <sys/stat.h>
|
||||||
|
#include <fcntl.h>
|
||||||
|
#include <glob.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
}
|
||||||
|
|
||||||
|
using namespace std;
|
||||||
|
diff --git a/csclient.cxx b/csclient.cxx
|
||||||
|
index 21f945f..9f8faee 100644
|
||||||
|
--- a/csclient.cxx
|
||||||
|
+++ b/csclient.cxx
|
||||||
|
@@ -24,6 +24,7 @@
|
||||||
|
#include <algorithm>
|
||||||
|
|
||||||
|
extern "C" {
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <linux/limits.h>
|
||||||
|
#include <sys/time.h>
|
||||||
|
#include <glob.h>
|
||||||
|
diff --git a/session.cxx b/session.cxx
|
||||||
|
index b322600..2436031 100644
|
||||||
|
--- a/session.cxx
|
||||||
|
+++ b/session.cxx
|
||||||
|
@@ -30,6 +30,7 @@ extern "C" {
|
||||||
|
#include <sys/stat.h>
|
||||||
|
#include <sys/utsname.h>
|
||||||
|
#include <elfutils/libdwfl.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
}
|
||||||
|
|
||||||
|
#if HAVE_NSS
|
||||||
|
diff --git a/setupdwfl.cxx b/setupdwfl.cxx
|
||||||
|
index 71814d7..ee1dbd0 100644
|
||||||
|
--- a/setupdwfl.cxx
|
||||||
|
+++ b/setupdwfl.cxx
|
||||||
|
@@ -23,6 +23,7 @@
|
||||||
|
extern "C" {
|
||||||
|
#include <fnmatch.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
}
|
||||||
|
|
||||||
|
// XXX: also consider adding $HOME/.debug/ for perf build-id-cache
|
||||||
|
diff --git a/stap-serverd.cxx b/stap-serverd.cxx
|
||||||
|
index 8ee3b09..9e1345a 100644
|
||||||
|
--- a/stap-serverd.cxx
|
||||||
|
+++ b/stap-serverd.cxx
|
||||||
|
@@ -29,6 +29,7 @@
|
||||||
|
#include <map>
|
||||||
|
|
||||||
|
extern "C" {
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <getopt.h>
|
||||||
|
#include <wordexp.h>
|
||||||
|
#include <glob.h>
|
||||||
|
diff --git a/translate.cxx b/translate.cxx
|
||||||
|
index 543c908..9d4c137 100644
|
||||||
|
--- a/translate.cxx
|
||||||
|
+++ b/translate.cxx
|
||||||
|
@@ -5569,7 +5569,7 @@ emit_symbol_data (systemtap_session& s)
|
||||||
|
|
||||||
|
ofstream kallsyms_out ((s.tmpdir + "/" + symfile).c_str());
|
||||||
|
|
||||||
|
- unwindsym_dump_context ctx = { s, kallsyms_out, 0, ~0, s.unwindsym_modules };
|
||||||
|
+ unwindsym_dump_context ctx = { s, kallsyms_out, 0, ~0UL, s.unwindsym_modules };
|
||||||
|
|
||||||
|
// Micro optimization, mainly to speed up tiny regression tests
|
||||||
|
// using just begin probe.
|
@ -16,7 +16,7 @@
|
|||||||
|
|
||||||
Name: systemtap
|
Name: systemtap
|
||||||
Version: 1.6
|
Version: 1.6
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
# for version, see also configure.ac
|
# for version, see also configure.ac
|
||||||
Summary: Instrumentation System
|
Summary: Instrumentation System
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
@ -87,6 +87,8 @@ BuildRequires: boost-devel
|
|||||||
%endif
|
%endif
|
||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
|
|
||||||
|
Patch2: gcc-4.7.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
SystemTap is an instrumentation system for systems running Linux.
|
SystemTap is an instrumentation system for systems running Linux.
|
||||||
Developers can write instrumentation to collect data on the operation
|
Developers can write instrumentation to collect data on the operation
|
||||||
@ -185,6 +187,8 @@ find . \( -name configure -o -name config.h.in \) -print | xargs touch
|
|||||||
cd ..
|
cd ..
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
%if %{with_bundled_elfutils}
|
%if %{with_bundled_elfutils}
|
||||||
@ -506,6 +510,9 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 14 2012 Mark Wielaard <mjw@redhat.com> - 1.6-4
|
||||||
|
- Fixes for gcc-4.7 based on upstream commits e14c86 and 47caa9.
|
||||||
|
|
||||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6-3
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user