Resolves: RHEL-52491
This commit is contained in:
parent
0a5fe0416d
commit
f3305ca6bc
22
RHEL-52491.patch
Normal file
22
RHEL-52491.patch
Normal file
@ -0,0 +1,22 @@
|
||||
commit 470da664cc0afd4aac982806622dbb5d700a7904
|
||||
Author: Martin Cermak <mcermak@redhat.com>
|
||||
Date: Fri Aug 9 07:40:43 2024 +0200
|
||||
|
||||
RHEL-52491: NSS 3.101.0 compatibility
|
||||
|
||||
After NSS rebased to 3.101.0, systemtap stopped being able to grant
|
||||
trust to stap-server: https://issues.redhat.com/browse/RHEL-52491 .
|
||||
This patch fixes it.
|
||||
|
||||
diff --git a/client-nss.cxx b/client-nss.cxx
|
||||
index 55266feb7..c09f99ca9 100644
|
||||
--- a/client-nss.cxx
|
||||
+++ b/client-nss.cxx
|
||||
@@ -184,6 +184,7 @@ badCertHandler(void *arg, PRFileDesc *sslSocket)
|
||||
|
||||
break;
|
||||
|
||||
+ case SEC_ERROR_UNKNOWN_ISSUER:
|
||||
case SEC_ERROR_CA_CERT_INVALID:
|
||||
/* The server's certificate is not trusted. Should we trust it? */
|
||||
secStatus = SECFailure; /* Do not trust by default. */
|
@ -121,7 +121,7 @@ m stapdev stapdev
|
||||
Name: systemtap
|
||||
# PRERELEASE
|
||||
Version: 5.1
|
||||
Release: 8%{?release_override}%{?dist}
|
||||
Release: 9%{?release_override}%{?dist}
|
||||
# for version, see also configure.ac
|
||||
|
||||
|
||||
@ -163,6 +163,7 @@ Patch3: PR31495.patch
|
||||
Patch4: RHEL-42605.patch
|
||||
Patch5: RHEL-50107.patch
|
||||
Patch6: RHEL-43481.patch
|
||||
Patch7: RHEL-52491.patch
|
||||
|
||||
# Build*
|
||||
BuildRequires: make
|
||||
@ -595,6 +596,7 @@ or within a container.
|
||||
%patch -P4 -p1
|
||||
%patch -P5 -p1
|
||||
%patch -P6 -p1
|
||||
%patch -P7 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -1322,6 +1324,9 @@ exit 0
|
||||
|
||||
# PRERELEASE
|
||||
%changelog
|
||||
* Fri Aug 9 2024 Martin Cermak <mcermak@redhat.com> - 5.1-9
|
||||
- RHEL-52491
|
||||
|
||||
* Fri Jul 26 2024 Martin Cermak <mcermak@redhat.com> - 5.1-8
|
||||
- RHEL-43481
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user