import systemtap-4.4-11.el8_4

This commit is contained in:
CentOS Sources 2021-08-10 08:03:31 -04:00 committed by Andrew Lukoshko
parent 6e6dafb7c9
commit cc1030d5d1
2 changed files with 29 additions and 1 deletions

23
SOURCES/rhbz1966742.patch Normal file
View File

@ -0,0 +1,23 @@
commit 87221aeb66e3e3475bf6df77cc7b6338313d0946
Author: Ding Hui <dinghui@sangfor.com.cn>
Date: Fri Nov 27 13:27:34 2020 -0500
PR26958: avoid null-deref in buildid verification failure diagnostic
We can't traverse tsk-> if it's NULL.
Tested by <fche> on hand-modified "stap -kp4" stap-symbols.c file.
diff --git a/runtime/sym.c b/runtime/sym.c
index a51f08c9e..521aebe48 100644
--- a/runtime/sym.c
+++ b/runtime/sym.c
@@ -735,7 +735,7 @@ static int _stp_build_id_check (struct _stp_module *m,
// we make sure below is really a warning.
_stp_warn ("Build-id mismatch [man warning::buildid]: \"%s\" pid %ld address "
"%#lx, expected %s actual %s\n",
- m->path, (long) tsk->tgid,
+ m->path, (long) (tsk ? tsk->tgid : 0),
notes_addr, hexstring_theory, hexstring_practice);
return 1;
}

View File

@ -89,7 +89,7 @@
Name: systemtap
Version: 4.4
Release: 10%{?release_override}%{?dist}
Release: 11%{?release_override}%{?dist}
# for version, see also configure.ac
@ -132,6 +132,7 @@ Patch4: rhbz1908904.patch
Patch5: rhbz1906662.patch
Patch6: rhbz1650594.patch
Patch7: rhbz1914948.patch
Patch8: rhbz1966742.patch
# Build*
BuildRequires: gcc-c++
@ -526,6 +527,7 @@ systemtap-runtime-virthost machine to execute systemtap scripts.
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%build
@ -1245,6 +1247,9 @@ done
# PRERELEASE
%changelog
* Tue Jun 01 2021 Frank Ch. Eigler <fche@redhat.com> - 4.4-11
- rhbz1966742 intermittent panic on build-id check failure
* Fri Mar 05 2021 Frank Ch. Eigler <fche@redhat.com> - 4.4-10
- rhbz1914948 use subbufs better in transport to avoid msg loss