parent
4dfa7981ab
commit
a7a4005ad4
29
rhbz2027683.patch
Normal file
29
rhbz2027683.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
commit 39b5233271b997811632871e1b6620a89b384fe8
|
||||||
|
Author: Martin Cermak <mcermak@redhat.com>
|
||||||
|
Date: Thu Jan 20 18:18:00 2022 +0100
|
||||||
|
|
||||||
|
Fix python probing rhbz2027683
|
||||||
|
|
||||||
|
diff --git a/tapset/python.stp b/tapset/python.stp
|
||||||
|
new file mode 100644
|
||||||
|
index 000000000..b5d06fcd9
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/tapset/python.stp
|
||||||
|
@@ -0,0 +1,17 @@
|
||||||
|
+/* Systemtap tapset to make it easier to trace Python */
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ Define python.function.entry/return:
|
||||||
|
+*/
|
||||||
|
+probe python.function.entry = process("python").library("/usr/lib*/libpython*.so*").mark("function__entry")
|
||||||
|
+{
|
||||||
|
+ filename = user_string($arg1);
|
||||||
|
+ funcname = user_string($arg2);
|
||||||
|
+ lineno = $arg3;
|
||||||
|
+}
|
||||||
|
+probe python.function.return = process("python").library("/usr/lib*/libpython*.so*").mark("function__return")
|
||||||
|
+{
|
||||||
|
+ filename = user_string($arg1);
|
||||||
|
+ funcname = user_string($arg2);
|
||||||
|
+ lineno = $arg3;
|
||||||
|
+}
|
@ -118,7 +118,7 @@ m stapdev stapdev
|
|||||||
|
|
||||||
Name: systemtap
|
Name: systemtap
|
||||||
Version: 4.6
|
Version: 4.6
|
||||||
Release: 6%{?release_override}%{?dist}
|
Release: 7%{?release_override}%{?dist}
|
||||||
# for version, see also configure.ac
|
# for version, see also configure.ac
|
||||||
|
|
||||||
|
|
||||||
@ -157,7 +157,8 @@ Source: ftp://sourceware.org/pub/systemtap/releases/systemtap-%{version}.tar.gz
|
|||||||
Patch1: rhbz2025054python3.patch
|
Patch1: rhbz2025054python3.patch
|
||||||
Patch2: rhbz1972798.patch
|
Patch2: rhbz1972798.patch
|
||||||
Patch3: sdt-asm-glibc.patch
|
Patch3: sdt-asm-glibc.patch
|
||||||
Patch4: bz2041526.patch
|
Patch4: rhbz2041526.patch
|
||||||
|
Patch5: rhbz2027683.patch
|
||||||
|
|
||||||
# Build*
|
# Build*
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
@ -583,6 +584,7 @@ systemtap-runtime-virthost machine to execute systemtap scripts.
|
|||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -1279,8 +1281,11 @@ exit 0
|
|||||||
|
|
||||||
# PRERELEASE
|
# PRERELEASE
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 21 2022 Martin Cermak <mcermak@redhat.com> - 4.6-7
|
||||||
|
- rhbz2027683: python tapset regression
|
||||||
|
|
||||||
* Mon Jan 17 2022 Martin Cermak <mcermak@redhat.com> - 4.6-6
|
* Mon Jan 17 2022 Martin Cermak <mcermak@redhat.com> - 4.6-6
|
||||||
- bz2041526/pr28634: move elevator.h to block/
|
- rhbz2041526/pr28634: move elevator.h to block/
|
||||||
|
|
||||||
* Tue Dec 07 2021 Stan Cox <scox@redhat.com> - 4.6.5
|
* Tue Dec 07 2021 Stan Cox <scox@redhat.com> - 4.6.5
|
||||||
- sys/sdt.h remove aarch64 and s390 float constraints
|
- sys/sdt.h remove aarch64 and s390 float constraints
|
||||||
|
Loading…
Reference in New Issue
Block a user