release 2.4
This commit is contained in:
parent
b62998ef3a
commit
8c4cdaf2d9
1
.gitignore
vendored
1
.gitignore
vendored
@ -73,3 +73,4 @@ systemtap-1.3.tar.gz
|
|||||||
/systemtap-2.4-0.173.g2576d05.tar.gz
|
/systemtap-2.4-0.173.g2576d05.tar.gz
|
||||||
/systemtap-2.4-0.186.gc1cb76c.tar.gz
|
/systemtap-2.4-0.186.gc1cb76c.tar.gz
|
||||||
/systemtap-2.4-0.233.g5c0aabb.tar.gz
|
/systemtap-2.4-0.233.g5c0aabb.tar.gz
|
||||||
|
/systemtap-2.4.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
cdd397edbcb44a73328ba7d24fc41090 systemtap-2.4-0.233.g5c0aabb.tar.gz
|
ca39cff33087b3ec549d6fd78c7e8555 systemtap-2.4.tar.gz
|
||||||
|
@ -1,47 +0,0 @@
|
|||||||
commit 83994b86444a4b75488b513362fd23390936e2a4
|
|
||||||
Author: Josh Stone <jistone@redhat.com>
|
|
||||||
Date: Thu Sep 26 10:53:14 2013 -0700
|
|
||||||
|
|
||||||
Revert "SDT: Use %foo for section types rather than "foo""
|
|
||||||
|
|
||||||
This reverts commit a31190f59188830b78dce26f0fbc42084f27c3c1.
|
|
||||||
|
|
||||||
This broke glibc's use of SDT_PROBE_ASM; revert until we figure it out.
|
|
||||||
|
|
||||||
diff --git a/includes/sys/sdt.h b/includes/sys/sdt.h
|
|
||||||
index 8230a5b..ba04c12 100644
|
|
||||||
--- a/includes/sys/sdt.h
|
|
||||||
+++ b/includes/sys/sdt.h
|
|
||||||
@@ -171,22 +171,9 @@ __extension__ extern unsigned long long __sdt_unsp;
|
|
||||||
# define _SDT_ASM_AUTOGROUP ""
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-/* We used to have just "note", but some assemblers don't support that.
|
|
||||||
- * GAS documents that it should be @note, but since ARM uses @ for
|
|
||||||
- * comments, it also supports %note. It appears we can get away with
|
|
||||||
- * the latter everywhere, so long as we escape it depending on mode.
|
|
||||||
- * NB: %progbits apparently doesn't need (and can't have) similar %%
|
|
||||||
- * escaping, since that asm() has no operands. */
|
|
||||||
-#ifdef __ASSEMBLER__
|
|
||||||
-#define _SDT_ASM_NOTE %note
|
|
||||||
-#else
|
|
||||||
-#define _SDT_ASM_NOTE %%note
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
#define _SDT_ASM_BODY(provider, name, pack_args, args) \
|
|
||||||
_SDT_ASM_1(990: _SDT_NOP) \
|
|
||||||
- _SDT_ASM_3( .pushsection .note.stapsdt,_SDT_ASM_AUTOGROUP, \
|
|
||||||
- _SDT_ASM_NOTE) \
|
|
||||||
+ _SDT_ASM_3( .pushsection .note.stapsdt,_SDT_ASM_AUTOGROUP,"note") \
|
|
||||||
_SDT_ASM_1( .balign 4) \
|
|
||||||
_SDT_ASM_3( .4byte 992f-991f, 994f-993f, _SDT_NOTE_TYPE) \
|
|
||||||
_SDT_ASM_1(991: .asciz _SDT_NOTE_NAME) \
|
|
||||||
@@ -202,7 +189,7 @@ __extension__ extern unsigned long long __sdt_unsp;
|
|
||||||
|
|
||||||
#define _SDT_ASM_BASE \
|
|
||||||
_SDT_ASM_1(.ifndef _.stapsdt.base) \
|
|
||||||
- _SDT_ASM_5( .pushsection .stapsdt.base,"aG",%progbits, \
|
|
||||||
+ _SDT_ASM_5( .pushsection .stapsdt.base,"aG","progbits", \
|
|
||||||
.stapsdt.base,comdat) \
|
|
||||||
_SDT_ASM_1( .weak _.stapsdt.base) \
|
|
||||||
_SDT_ASM_1( .hidden _.stapsdt.base) \
|
|
@ -49,7 +49,7 @@
|
|||||||
|
|
||||||
Name: systemtap
|
Name: systemtap
|
||||||
Version: 2.4
|
Version: 2.4
|
||||||
Release: 0.233.g5c0aabb%{?dist}
|
Release: 1%{?dist}
|
||||||
# for version, see also configure.ac
|
# for version, see also configure.ac
|
||||||
|
|
||||||
|
|
||||||
@ -82,7 +82,7 @@ Summary: Programmable system-wide instrumentation system
|
|||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://sourceware.org/systemtap/
|
URL: http://sourceware.org/systemtap/
|
||||||
Source: %{name}-%{version}-0.233.g5c0aabb.tar.gz
|
Source: ftp://sourceware.org/pub/systemtap/releases/systemtap-%{version}.tar.gz
|
||||||
|
|
||||||
# Build*
|
# Build*
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -970,62 +970,13 @@ done
|
|||||||
# http://sourceware.org/systemtap/wiki/SystemTapReleases
|
# http://sourceware.org/systemtap/wiki/SystemTapReleases
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Nov 04 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.233.g5c0aabb
|
* Wed Nov 06 2013 Frank Ch. Eigler <fche@redhat.com> - 2.4-1
|
||||||
- Automated weekly rawhide release
|
- Upstream release.
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Mon Oct 28 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.186.gc1cb76c
|
* Wed Oct 09 2013 Jonathan Lebon <jlebon@redhat.com>
|
||||||
- Automated weekly rawhide release
|
- Added runtime-virthost and runtime-virtguest packages.
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Wed Oct 23 2013 Josh Stone <jistone@redhat.com> - 2.4-0.173.g2576d05.1
|
* Thu Jul 25 2013 Frank Ch. Eigler <fche@redhat.com> - 2.3-1
|
||||||
- BZ1022483: don't ship the sourcedir 'examples' symlink.
|
|
||||||
|
|
||||||
* Mon Oct 21 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.173.g2576d05
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Tue Oct 15 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.137.gbbb71aa
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Mon Oct 07 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.131.g1acfc03
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
|
|
||||||
* Mon Sep 30 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.127.g98df4da
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Thu Sep 26 2013 Josh Stone <jistone@redhat.com> - 2.4-0.109.g217de68.1
|
|
||||||
- The upstream sdt-types change broke glibc; revert for now...
|
|
||||||
|
|
||||||
* Mon Sep 23 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.109.g217de68
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Mon Sep 16 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.93.g892a56b
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Mon Sep 09 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.81.g2b5bbe5
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Mon Aug 26 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.47.g2e9858c
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Mon Aug 19 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.25.g3f873e5
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
|
|
||||||
* Mon Aug 05 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.19.g03207fd
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
|
|
||||||
* Mon Jul 29 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.9.geada930
|
|
||||||
- Automated weekly rawhide release
|
|
||||||
- Applied spec changes from upstream git
|
|
||||||
|
|
||||||
* Thu Jul 25 2013 David Smith <dsmith@redhat.com> - 2.3
|
|
||||||
- Upstream release.
|
- Upstream release.
|
||||||
|
|
||||||
* Thu May 16 2013 Frank Ch. Eigler <fche@redhat.com> - 2.2.1-1
|
* Thu May 16 2013 Frank Ch. Eigler <fche@redhat.com> - 2.2.1-1
|
||||||
|
Loading…
Reference in New Issue
Block a user