upstream release 3.3
This commit is contained in:
parent
c0bbf37078
commit
45296db740
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
||||
/systemtap-3.3-0.20180315gitc2585f2b58cd.tar.gz
|
||||
/systemtap-3.3-0.20180420gitd4a446c.tar.gz
|
||||
/systemtap-3.3-0.20180508git9c6ac6cda49e.tar.gz
|
||||
/systemtap-3.3.tar.gz
|
||||
|
@ -1,49 +0,0 @@
|
||||
commit 9f81f10b0caf6dfc49c4b7ceb7902f45d37b532a (HEAD -> master, origin/master, origin/HEAD)
|
||||
Author: Frank Ch. Eigler <fche@redhat.com>
|
||||
Date: Fri Oct 20 10:01:58 2017 -0400
|
||||
|
||||
rhbz1504009: let dtrace -G -o /dev/null run, as in autoconf
|
||||
|
||||
commit c245153ca193c471a8c broke the ability of dtrace to be tested in
|
||||
autoconf "-G -o /dev/null" usage, because its output file name was too
|
||||
simple a function of the input name, and normal users can't write to
|
||||
/dev/null.dtrace-temp.c . Now we back down to mkstemp, like before,
|
||||
upon a failure of the simple concatenated name.
|
||||
|
||||
diff --git a/dtrace.in b/dtrace.in
|
||||
index 2e2e002a5c56..25efc253b708 100644
|
||||
--- a/dtrace.in
|
||||
+++ b/dtrace.in
|
||||
@@ -410,8 +410,12 @@ from tempfile import mkstemp
|
||||
else:
|
||||
print("header: " + fname)
|
||||
|
||||
- fname = filename + ".dtrace-temp.c"
|
||||
- fdesc = open(fname, mode='w')
|
||||
+ try: # for reproducible-builds purposes, prefer a fixed path name pattern
|
||||
+ fname = filename + ".dtrace-temp.c"
|
||||
+ fdesc = open(fname, mode='w')
|
||||
+ except: # but that doesn't work for -o /dev/null - see rhbz1504009
|
||||
+ (ignore,fname) = mkstemp(suffix=".c")
|
||||
+ fdesc = open(fname, mode='w')
|
||||
providers.semaphore_write(fdesc)
|
||||
fdesc.close()
|
||||
cc1 = os.environ.get("CC", "gcc")
|
||||
diff --git a/testsuite/systemtap.base/dtrace.exp b/testsuite/systemtap.base/dtrace.exp
|
||||
index fa6b3ec3f6d3..7c60f09d70b8 100644
|
||||
--- a/testsuite/systemtap.base/dtrace.exp
|
||||
+++ b/testsuite/systemtap.base/dtrace.exp
|
||||
@@ -83,6 +83,13 @@ if {[file exists /tmp/XXX.o]} then {
|
||||
}
|
||||
exec rm -f /tmp/XXX.o
|
||||
|
||||
+verbose -log "$dtrace -G -s $dpath -o /dev/null"
|
||||
+if [as_non_root "$python $dtrace -G -s $dpath -o /dev/null"] {
|
||||
+ fail "$test -G -o /dev/null"
|
||||
+} else {
|
||||
+ pass "$test -G -o /dev/null"
|
||||
+}
|
||||
+
|
||||
verbose -log "$dtrace -G -s $dpath -o /tmp/XXX"
|
||||
catch {exec $python $dtrace -G -s $dpath -o /tmp/XXX} res
|
||||
if {[file exists /tmp/XXX]} then {
|
@ -1,208 +0,0 @@
|
||||
commit a8e317b60 (HEAD -> master, origin/master, origin/HEAD)
|
||||
Author: Stan Cox <scox@redhat.com>
|
||||
Date: Tue Feb 13 22:38:03 2018 -0500
|
||||
|
||||
Fixes for gcc 8
|
||||
|
||||
* includes/sys/sdt.h (__SDT_COND_SIGNED): Add CT, cast type argument
|
||||
|
||||
Author: Will Cohen <wcohen.redhat.com>
|
||||
|
||||
* stap-serverd.cxx (generate_mok, handleRequest, handle_connection):
|
||||
Catch format overflow
|
||||
|
||||
* translate.cxx (translate_pass): Use ref in catch.
|
||||
|
||||
diff --git a/includes/sys/sdt.h b/includes/sys/sdt.h
|
||||
index 940f74483..c0c5a492c 100644
|
||||
--- a/includes/sys/sdt.h
|
||||
+++ b/includes/sys/sdt.h
|
||||
@@ -119,8 +119,8 @@ struct __sdt_type
|
||||
|
||||
#define __SDT_ALWAYS_SIGNED(T) \
|
||||
template<> struct __sdt_type<T> { static const bool __sdt_signed = true; };
|
||||
-#define __SDT_COND_SIGNED(T) \
|
||||
-template<> struct __sdt_type<T> { static const bool __sdt_signed = ((T)(-1) < 1); };
|
||||
+#define __SDT_COND_SIGNED(T,CT) \
|
||||
+template<> struct __sdt_type<T> { static const bool __sdt_signed = ((CT)(-1) < 1); };
|
||||
__SDT_ALWAYS_SIGNED(signed char)
|
||||
__SDT_ALWAYS_SIGNED(short)
|
||||
__SDT_ALWAYS_SIGNED(int)
|
||||
@@ -141,14 +141,14 @@ __SDT_ALWAYS_SIGNED(const volatile short)
|
||||
__SDT_ALWAYS_SIGNED(const volatile int)
|
||||
__SDT_ALWAYS_SIGNED(const volatile long)
|
||||
__SDT_ALWAYS_SIGNED(const volatile long long)
|
||||
-__SDT_COND_SIGNED(char)
|
||||
-__SDT_COND_SIGNED(wchar_t)
|
||||
-__SDT_COND_SIGNED(volatile char)
|
||||
-__SDT_COND_SIGNED(volatile wchar_t)
|
||||
-__SDT_COND_SIGNED(const char)
|
||||
-__SDT_COND_SIGNED(const wchar_t)
|
||||
-__SDT_COND_SIGNED(const volatile char)
|
||||
-__SDT_COND_SIGNED(const volatile wchar_t)
|
||||
+__SDT_COND_SIGNED(char, char)
|
||||
+__SDT_COND_SIGNED(wchar_t, wchar_t)
|
||||
+__SDT_COND_SIGNED(volatile char, char)
|
||||
+__SDT_COND_SIGNED(volatile wchar_t, wchar_t)
|
||||
+__SDT_COND_SIGNED(const char, char)
|
||||
+__SDT_COND_SIGNED(const wchar_t, wchar_t)
|
||||
+__SDT_COND_SIGNED(const volatile char, char)
|
||||
+__SDT_COND_SIGNED(const volatile wchar_t, wchar_t)
|
||||
#if defined (__GNUC__) && (__GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 4))
|
||||
/* __SDT_COND_SIGNED(char16_t) */
|
||||
/* __SDT_COND_SIGNED(char32_t) */
|
||||
diff --git a/stap-serverd.cxx b/stap-serverd.cxx
|
||||
index b8f70114c..063c3c587 100644
|
||||
--- a/stap-serverd.cxx
|
||||
+++ b/stap-serverd.cxx
|
||||
@@ -1607,6 +1607,7 @@ generate_mok(string &mok_fingerprint)
|
||||
char tmpdir[PATH_MAX] = { '\0' };
|
||||
string public_cert_path, private_cert_path, destdir;
|
||||
mode_t old_umask;
|
||||
+ int retlen;
|
||||
|
||||
mok_fingerprint.clear ();
|
||||
|
||||
@@ -1631,7 +1632,14 @@ generate_mok(string &mok_fingerprint)
|
||||
}
|
||||
|
||||
// Make a temporary directory to store results in.
|
||||
- snprintf (tmpdir, PATH_MAX, "%s/stap-server.XXXXXX", mok_path.c_str ());
|
||||
+ retlen = snprintf (tmpdir, PATH_MAX, "%s/stap-server.XXXXXX", mok_path.c_str ());
|
||||
+ if (retlen < 0 || retlen >= PATH_MAX)
|
||||
+ {
|
||||
+ server_error (_F("Could not create %s name", "temporary directory"));
|
||||
+ tmpdir[0] = '\0';
|
||||
+ goto cleanup;
|
||||
+ }
|
||||
+
|
||||
if (mkdtemp (tmpdir) == NULL)
|
||||
{
|
||||
server_error (_F("Could not create temporary directory %s: %s", tmpdir,
|
||||
@@ -1704,6 +1712,7 @@ handleRequest (const string &requestDirName, const string &responseDirName, stri
|
||||
unsigned u;
|
||||
unsigned i;
|
||||
FILE* f;
|
||||
+ int retlen;
|
||||
|
||||
// Save the server version. Do this early, so the client knows what version of the server
|
||||
// it is dealing with, even if the request is not fully completed.
|
||||
@@ -1782,7 +1791,12 @@ handleRequest (const string &requestDirName, const string &responseDirName, stri
|
||||
struct stat st;
|
||||
char *arg;
|
||||
|
||||
- snprintf (stapargfile, PATH_MAX, "%s/argv%d", requestDirName.c_str (), i);
|
||||
+ retlen = snprintf (stapargfile, PATH_MAX, "%s/argv%d", requestDirName.c_str (), i);
|
||||
+ if (retlen < 0 || retlen >= PATH_MAX)
|
||||
+ {
|
||||
+ server_error (_F("Error creating %s name", "path"));
|
||||
+ return;
|
||||
+ }
|
||||
|
||||
rc = stat(stapargfile, & st);
|
||||
if (rc) break;
|
||||
@@ -1888,7 +1902,15 @@ handleRequest (const string &requestDirName, const string &responseDirName, stri
|
||||
{
|
||||
glob_t globber;
|
||||
char pattern[PATH_MAX];
|
||||
- snprintf (pattern, PATH_MAX, "%s/*.ko", new_staptmpdir.c_str());
|
||||
+ int retlen;
|
||||
+
|
||||
+ retlen = snprintf (pattern, PATH_MAX, "%s/*.ko", new_staptmpdir.c_str());
|
||||
+ if (retlen < 0 || retlen >= PATH_MAX)
|
||||
+ {
|
||||
+ server_error (_F("Error creating %s name", "pattern"));
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
rc = glob (pattern, GLOB_ERR, NULL, &globber);
|
||||
if (rc)
|
||||
server_error (_F("Unable to find a module in %s", new_staptmpdir.c_str()));
|
||||
@@ -2164,6 +2186,7 @@ handle_connection (void *arg)
|
||||
copy for each connection.*/
|
||||
vector<string> argv;
|
||||
PRInt32 bytesRead;
|
||||
+ int retlen;
|
||||
|
||||
/* Detatch to avoid a memory leak */
|
||||
if(max_threads > 0)
|
||||
@@ -2213,7 +2236,13 @@ handle_connection (void *arg)
|
||||
#endif
|
||||
|
||||
secStatus = SECFailure;
|
||||
- snprintf(tmpdir, PATH_MAX, "%s/stap-server.XXXXXX", getenv("TMPDIR") ?: "/tmp");
|
||||
+ retlen = snprintf(tmpdir, PATH_MAX, "%s/stap-server.XXXXXX", getenv("TMPDIR") ?: "/tmp");
|
||||
+ if (retlen < 0 || retlen >= PATH_MAX)
|
||||
+ {
|
||||
+ server_error (_F("Error creating %s name", "temporary directory"));
|
||||
+ tmpdir[0]=0; /* prevent /bin/rm */
|
||||
+ goto cleanup;
|
||||
+ }
|
||||
rc1 = mkdtemp(tmpdir);
|
||||
if (! rc1)
|
||||
{
|
||||
@@ -2223,9 +2252,20 @@ handle_connection (void *arg)
|
||||
}
|
||||
|
||||
/* Create a temporary files names and directories. */
|
||||
- snprintf (requestFileName, PATH_MAX, "%s/request.zip", tmpdir);
|
||||
+ retlen = snprintf (requestFileName, PATH_MAX, "%s/request.zip", tmpdir);
|
||||
+ if (retlen < 0 || retlen >= PATH_MAX)
|
||||
+ {
|
||||
+ server_error (_F("Error creating %s name", "request.zip path"));
|
||||
+ goto cleanup;
|
||||
+ }
|
||||
+
|
||||
+ retlen = snprintf (requestDirName, PATH_MAX, "%s/request", tmpdir);
|
||||
+ if (retlen < 0 || retlen >= PATH_MAX)
|
||||
+ {
|
||||
+ server_error (_F("Error creating %s name", "request directory path"));
|
||||
+ goto cleanup;
|
||||
+ }
|
||||
|
||||
- snprintf (requestDirName, PATH_MAX, "%s/request", tmpdir);
|
||||
rc = mkdir(requestDirName, 0700);
|
||||
if (rc)
|
||||
{
|
||||
@@ -2233,7 +2273,13 @@ handle_connection (void *arg)
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
- snprintf (responseDirName, PATH_MAX, "%s/response", tmpdir);
|
||||
+ retlen = snprintf (responseDirName, PATH_MAX, "%s/response", tmpdir);
|
||||
+ if (retlen < 0 || retlen >= PATH_MAX)
|
||||
+ {
|
||||
+ server_error (_F("Error creating %s name", "response directory path"));
|
||||
+ goto cleanup;
|
||||
+ }
|
||||
+
|
||||
rc = mkdir(responseDirName, 0700);
|
||||
if (rc)
|
||||
{
|
||||
@@ -2243,7 +2289,12 @@ handle_connection (void *arg)
|
||||
// Set this early, since it gets used for errors to be returned to the client.
|
||||
stapstderr = string(responseDirName) + "/stderr";
|
||||
|
||||
- snprintf (responseFileName, PATH_MAX, "%s/response.zip", tmpdir);
|
||||
+ retlen = snprintf (responseFileName, PATH_MAX, "%s/response.zip", tmpdir);
|
||||
+ if (retlen < 0 || retlen >= PATH_MAX)
|
||||
+ {
|
||||
+ server_error (_F("Error creating %s name", "response.zip path"));
|
||||
+ goto cleanup;
|
||||
+ }
|
||||
|
||||
/* Read data from the socket.
|
||||
* If the user is requesting/requiring authentication, authenticate
|
||||
diff --git a/translate.cxx b/translate.cxx
|
||||
index 1240a80ec..4ade06fdd 100644
|
||||
--- a/translate.cxx
|
||||
+++ b/translate.cxx
|
||||
@@ -7860,7 +7860,7 @@ translate_pass (systemtap_session& s)
|
||||
if (versions.size() >= 3 && s.verbose > 1)
|
||||
clog << _F("ignoring extra parts of compat version: %s", s.compatible.c_str()) << endl;
|
||||
}
|
||||
- catch (const runtime_error)
|
||||
+ catch (const runtime_error&)
|
||||
{
|
||||
throw SEMANTIC_ERROR(_F("parse error in compatibility version: %s", s.compatible.c_str()));
|
||||
}
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (systemtap-3.3-0.20180508git9c6ac6cda49e.tar.gz) = eeb254486ce991d2bdbbaed6b350fe28455a921134465b4a74c015c433e059d09bd945ae778da39989f12873365be54a8278e57ef6c12a3f406118b35f7738d8
|
||||
SHA512 (systemtap-3.3.tar.gz) = b75a4591bdc021645c15cb8f2b8991f46fdffb29b1d132745bafe4291aee5e1892ea9a63c8e98f011a4fee68decd99aa4401dc2f70e163e801cd140ad4cd6b6e
|
||||
|
@ -1,5 +1,6 @@
|
||||
%{!?with_sqlite: %global with_sqlite 0%{?fedora} >= 17 || 0%{?rhel} >= 7}
|
||||
%{!?with_docs: %global with_docs 1}
|
||||
# prefer prebuilt docs
|
||||
%{!?with_docs: %global with_docs 0}
|
||||
%{!?with_htmldocs: %global with_htmldocs 0}
|
||||
%{!?with_monitor: %global with_monitor 1}
|
||||
# crash is not available
|
||||
@ -66,18 +67,24 @@
|
||||
%define dracutstap %{_prefix}/share/dracut/modules.d/99stap
|
||||
%endif
|
||||
|
||||
%if 0%{?rhel} >= 6
|
||||
%if 0%{?rhel} == 6 || 0%{?rhel} == 7
|
||||
%define dracutbindir /sbin
|
||||
%else
|
||||
%define dracutbindir %{_bindir}
|
||||
%endif
|
||||
|
||||
%if 0%{?rhel} == 6
|
||||
%{!?_rpmmacrodir: %define _rpmmacrodir /etc/rpm/}
|
||||
%else
|
||||
%{!?_rpmmacrodir: %define _rpmmacrodir %{_rpmconfigdir}/macros.d}
|
||||
%endif
|
||||
|
||||
# To avoid testsuite/*/*.stp has shebang which doesn't start with '/'
|
||||
%undefine __brp_mangle_shebangs
|
||||
|
||||
Name: systemtap
|
||||
Version: 3.3
|
||||
Release: 0.20180508git9c6ac6cda49e%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# for version, see also configure.ac
|
||||
|
||||
|
||||
@ -112,7 +119,7 @@ Summary: Programmable system-wide instrumentation system
|
||||
Group: Development/System
|
||||
License: GPLv2+
|
||||
URL: http://sourceware.org/systemtap/
|
||||
Source: %{name}-%{version}-0.20180508git9c6ac6cda49e.tar.gz
|
||||
Source: ftp://sourceware.org/pub/systemtap/releases/systemtap-%{version}.tar.gz
|
||||
|
||||
# Build*
|
||||
BuildRequires: gcc-c++
|
||||
@ -400,7 +407,7 @@ License: GPLv2+
|
||||
URL: http://sourceware.org/systemtap/
|
||||
Requires: systemtap-runtime = %{version}-%{release}
|
||||
Requires: byteman > 2.0
|
||||
Requires: net-tools
|
||||
Requires: iproute
|
||||
|
||||
%description runtime-java
|
||||
This package includes support files needed to run systemtap scripts
|
||||
@ -543,7 +550,7 @@ cd ..
|
||||
%global docs_config --enable-docs --disable-htmldocs
|
||||
%endif
|
||||
%else
|
||||
%global docs_config --disable-docs
|
||||
%global docs_config --enable-docs=prebuilt
|
||||
%endif
|
||||
|
||||
# Enable pie as configure defaults to disabling it
|
||||
@ -634,19 +641,21 @@ install -c -m 755 stap-prep $RPM_BUILD_ROOT%{_bindir}/stap-prep
|
||||
# Copy over the testsuite
|
||||
cp -rp testsuite $RPM_BUILD_ROOT%{_datadir}/systemtap
|
||||
|
||||
%if %{with_docs}
|
||||
# We want the manuals in the special doc dir, not the generic doc install dir.
|
||||
# We build it in place and then move it away so it doesn't get installed
|
||||
# twice. rpm can specify itself where the (versioned) docs go with the
|
||||
# %doc directive.
|
||||
mkdir docs.installed
|
||||
mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/*.pdf docs.installed/
|
||||
%if %{with_docs}
|
||||
%if %{with_htmldocs}
|
||||
mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/tapsets docs.installed/
|
||||
mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/SystemTap_Beginners_Guide docs.installed/
|
||||
%endif
|
||||
%endif
|
||||
|
||||
install -D -m 644 macros.systemtap $RPM_BUILD_ROOT%{_rpmmacrodir}/macros.systemtap
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server
|
||||
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/stap-server
|
||||
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/stap-server/.systemtap
|
||||
@ -1071,8 +1080,8 @@ done
|
||||
%{_datadir}/systemtap/examples
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%if %{with_docs}
|
||||
%doc docs.installed/*.pdf
|
||||
%if %{with_docs}
|
||||
%if %{with_htmldocs}
|
||||
%doc docs.installed/tapsets/*.html
|
||||
%doc docs.installed/SystemTap_Beginners_Guide
|
||||
@ -1117,6 +1126,7 @@ done
|
||||
%{_includedir}/sys/sdt.h
|
||||
%{_includedir}/sys/sdt-config.h
|
||||
%{_mandir}/man1/dtrace.1*
|
||||
%{_rpmmacrodir}/macros.systemtap
|
||||
%doc README AUTHORS NEWS
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
@ -1176,32 +1186,8 @@ done
|
||||
|
||||
# PRERELEASE
|
||||
%changelog
|
||||
* Tue May 08 2018 Frank Ch. Eigler <fche@redhat.com> - 3.3-0.20180508git9c6ac6cda49e
|
||||
- Automated weekly rawhide release
|
||||
- Applied spec changes from upstream git
|
||||
|
||||
* Fri Apr 20 2018 Mark Wielaard <mark@klomp.org> - 3.3-0.20180420gitd4a446c
|
||||
- Automated weekly rawhide release
|
||||
- Applied spec changes from upstream git
|
||||
|
||||
* Fri Apr 20 2018 Mark Wielaard <mark@klomp.org> - 3.3-0.20180420gitd4a446c
|
||||
- Automated weekly rawhide release
|
||||
- Applied spec changes from upstream git
|
||||
|
||||
* Thu Mar 15 2018 Frank Ch. Eigler <fche@redhat.com> - 3.3-0.20180315gitc2585f2b58cd
|
||||
- Automated weekly rawhide release
|
||||
- Applied spec changes from upstream git
|
||||
|
||||
* Thu Mar 15 2018 Frank Ch. Eigler <fche@redhat.com> - 3.3-0.20180315gitc2585f2b58cd
|
||||
- Automated weekly rawhide release
|
||||
- Applied spec changes from upstream git
|
||||
|
||||
* Tue Mar 06 2018 Björn Esser <besser82@fedoraproject.org> - 3.3-0.20180223git5ef0c24456e3
|
||||
- Rebuilt for libjson-c.so.4 (json-c v0.13.1)
|
||||
|
||||
* Thu Feb 22 2018 Frank Ch. Eigler <fche@redhat.com> - 3.3-0.20180222git5ef0c24456e3
|
||||
- Automated weekly rawhide release
|
||||
- Applied spec changes from upstream git
|
||||
* Thu Jun 07 2018 Frank Ch. Eigler <fche@redhat.com> - 3.3-1
|
||||
- Upstream release.
|
||||
|
||||
* Wed Oct 18 2017 Frank Ch. Eigler <fche@redhat.com> - 3.2-1
|
||||
- Upstream release.
|
||||
|
Loading…
Reference in New Issue
Block a user