upstream release 3.2

This commit is contained in:
Frank Ch. Eigler 2017-10-18 14:14:42 -04:00
parent cf55dd95b8
commit 3de19523e9
4 changed files with 14 additions and 69 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
/systemtap-3.2-0.20170406git83d186dc7f5c.tar.gz
/systemtap-3.2-0.20170410gitcbf2583808d6.tar.gz
/systemtap-3.2-0.20170512gitc67d8f274b21.tar.gz
/systemtap-3.2.tar.gz

View File

@ -1 +1 @@
SHA512 (systemtap-3.2-0.20170512gitc67d8f274b21.tar.gz) = 1fb2b892692958a63fd2ad0bf2a780ff1a9262686c0c4245f753b485acb63e19bf2fcfcd8aaba63c1dd0365d59dd62e718f0d31081f339f6c79a294847543756
SHA512 (systemtap-3.2.tar.gz) = 6036ed1b5189fd3fcfdeeaa526a3539ac632d0b687a063b5e3424e8f613bfc2c8d079742b0262b547128e97e30e4beb61898b23761657aee519e61346ac92e94

View File

@ -1,33 +0,0 @@
diff -up systemtap-3.2/rpm_finder.cxx.newrpm systemtap-3.2/rpm_finder.cxx
--- systemtap-3.2/rpm_finder.cxx.newrpm 2017-08-10 22:13:10.283393224 +0300
+++ systemtap-3.2/rpm_finder.cxx 2017-08-10 22:13:28.320385642 +0300
@@ -22,7 +22,6 @@ using namespace std;
extern "C" {
-#define _RPM_4_4_COMPAT
#include <string.h>
#include <rpm/rpmlib.h>
#include <rpm/rpmts.h>
@@ -100,8 +99,7 @@ missing_rpm_enlist (systemtap_session& s
break;
/* Verify the kernel file is not already installed. */
- rpminfo = headerSprintf(h, header,
- rpmTagTable, rpmHeaderFormats, &err);
+ rpminfo = headerFormat(h, header, &err);
if (!rpminfo)
{
@@ -154,9 +152,8 @@ missing_rpm_enlist (systemtap_session& s
/* The allocated memory gets utilized below for MISSING_RPM_HASH. */
if(strcmp(rpm_type,"-debuginfo")==0){
xfree(rpminfo);
- rpminfo = headerSprintf(h,
- "%{name}-%{version}-%{release}.%{arch}",
- rpmTagTable, rpmHeaderFormats, &err);
+ rpminfo = headerFormat(h,
+ "%{name}-%{version}-%{release}.%{arch}", &err);
}
if (!rpminfo)
{

View File

@ -18,6 +18,7 @@
%else
%{!?with_dyninst: %global with_dyninst 0}
%endif
%{!?with_bpf: %global with_bpf 0%{?fedora} >= 22 || 0%{?rhel} >= 8}
%{!?with_systemd: %global with_systemd 0%{?fedora} >= 19 || 0%{?rhel} >= 7}
%{!?with_emacsvim: %global with_emacsvim 0%{?fedora} >= 19 || 0%{?rhel} >= 7}
%{!?with_java: %global with_java 0%{?fedora} >= 19 || 0%{?rhel} >= 7}
@ -73,7 +74,7 @@
Name: systemtap
Version: 3.2
Release: 0.20170516gitc67d8f274b21%{?dist}
Release: 1%{?dist}
# for version, see also configure.ac
@ -108,7 +109,7 @@ Summary: Programmable system-wide instrumentation system
Group: Development/System
License: GPLv2+
URL: http://sourceware.org/systemtap/
Source: %{name}-%{version}-0.20170512gitc67d8f274b21.tar.gz
Source: ftp://sourceware.org/pub/systemtap/releases/systemtap-%{version}.tar.gz
# Build*
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -121,7 +122,7 @@ BuildRequires: dyninst-devel >= 8.0
BuildRequires: pkgconfig(libselinux)
%endif
%if %{with_sqlite}
BuildRequires: sqlite-devel
BuildRequires: sqlite-devel > 3.7
%endif
%if %{with_monitor}
BuildRequires: pkgconfig(json-c)
@ -153,7 +154,6 @@ BuildRequires: /usr/bin/latex /usr/bin/dvips /usr/bin/ps2pdf
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
BuildRequires: tex(fullpage.sty) tex(fancybox.sty) tex(bchr7t.tfm) tex(graphicx.sty)
%endif
Patch2: systemtap-3.2-modern-rpm-api.patch
# For the html.sty mentioned in the .tex files, even though latex2html is
# not run during the build, only during manual scripts/update-docs runs:
BuildRequires: latex2html
@ -478,7 +478,6 @@ sleep 1
find . \( -name configure -o -name config.h.in \) -print | xargs touch
cd ..
%endif
%patch2 -p1
%build
@ -1021,6 +1020,9 @@ done
%if %{with_dyninst}
%{_bindir}/stapdyn
%endif
%if %{with_bpf}
%{_bindir}/stapbpf
%endif
%dir %{_libexecdir}/systemtap
%{_libexecdir}/systemtap/stapio
%{_libexecdir}/systemtap/stap-authorize-cert
@ -1037,6 +1039,9 @@ done
%if %{with_dyninst}
%{_mandir}/man8/stapdyn.8*
%endif
%if %{with_bpf}
%{_mandir}/man8/stapbpf.8*
%endif
%doc README README.security AUTHORS NEWS
%{!?_licensedir:%global license %%doc}
%license COPYING
@ -1153,36 +1158,8 @@ done
# PRERELEASE
%changelog
* Fri Aug 11 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.2-0.20170516gitc67d8f274b21
- Rebuilt after RPM update (№ 3)
* Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.2-0.20170515gitc67d8f274b21
- Rebuilt for RPM soname bump
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2-0.20170514gitc67d8f274b21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2-0.20170513gitc67d8f274b21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri May 12 2017 Frank Ch. Eigler <fche@redhat.com> - 3.2-0.20170512gitc67d8f274b21
- Automated weekly rawhide release
- Applied spec changes from upstream git
* Mon Apr 10 2017 Frank Ch. Eigler <fche@redhat.com> - 3.2-0.20170410gitcbf2583808d6
- Automated weekly rawhide release
- Applied spec changes from upstream git
* Thu Apr 06 2017 Frank Ch. Eigler <fche@redhat.com> - 3.2-0.20170406git83d186dc7f5c
- Automated weekly rawhide release
- Applied spec changes from upstream git
* Tue Mar 21 2017 Frank Ch. Eigler <fche@redhat.com> - 3.2-0.20170321git272146660f54
- Automated weekly rawhide release
- Applied spec changes from upstream git
* Fri Mar 10 2017 Stan Cox <scox@redhat.com> - 3.1-2
- Rebuild for dyninst 9.3
* Wed Oct 18 2017 Frank Ch. Eigler <fche@redhat.com> - 3.2-1
- Upstream release.
* Fri Feb 17 2017 Frank Ch. Eigler <fche@redhat.com> - 3.1-1
- Upstream release.