Fix the default output path of dtrace

This commit is contained in:
Josh Stone 2009-09-04 23:31:57 +00:00
parent 02c9a3a0b0
commit 2cfedfc356
2 changed files with 28 additions and 1 deletions

View File

@ -0,0 +1,20 @@
commit 1b8fc7c8a443c0a8982133da6cc22a0c986a4ad4
Author: Stan Cox <scox@redhat.com>
Date: Fri Aug 28 17:16:00 2009 -0400
Have dtrace use [wd] as the default dir when -o isn't given.
* dtrace.in: Generate the output file from basename of input filename.
diff --git a/dtrace.in b/dtrace.in
index 168bfb1..5365c31 100755
--- a/dtrace.in
+++ b/dtrace.in
@@ -162,6 +162,7 @@ if (build_header == False and build_source == False):
if (filename == ""):
if (s_filename != ""):
(filename,ext) = os.path.splitext(s_filename)
+ filename = os.path.basename(filename)
else:
usage
sys.exit(1)

View File

@ -9,7 +9,7 @@
Name: systemtap
Version: 0.9.9
Release: 3%{?dist}
Release: 4%{?dist}
# for version, see also configure.ac
Summary: Instrumentation System
Group: Development/System
@ -49,6 +49,8 @@ BuildRequires: elfutils-devel >= %{elfutils_version}
Requires: crash
%endif
Patch2: dtrace-default-output-path.patch
%if %{with_docs}
BuildRequires: /usr/bin/latex /usr/bin/dvips /usr/bin/ps2pdf latex2html
# On F10, xmlto's pdf support was broken off into a sub-package,
@ -161,6 +163,8 @@ find . \( -name configure -o -name config.h.in \) -print | xargs touch
cd ..
%endif
%patch2 -p1
%build
%if %{with_bundled_elfutils}
@ -381,6 +385,9 @@ exit 0
%changelog
* Fri Sep 4 2009 Josh Stone <jistone@redhat.com> - 0.9.9-4
- Fix the default output path of dtrace (upstream commit 3a45db13)
* Wed Aug 12 2009 Josh Stone <jistone@redhat.com> - 0.9.9-3
- Fix uprobes error suppression in %post and %preun (#515870)
(upstream commit 70f2bd1fc3db8e2b555234d45e6bc3856d8afee5)