The upstream sdt-types change broke glibc; revert for now...
This commit is contained in:
parent
1a86220924
commit
0aca06f0eb
47
systemtap-snapshot-revert-sdt-section.patch
Normal file
47
systemtap-snapshot-revert-sdt-section.patch
Normal file
@ -0,0 +1,47 @@
|
|||||||
|
commit 83994b86444a4b75488b513362fd23390936e2a4
|
||||||
|
Author: Josh Stone <jistone@redhat.com>
|
||||||
|
Date: Thu Sep 26 10:53:14 2013 -0700
|
||||||
|
|
||||||
|
Revert "SDT: Use %foo for section types rather than "foo""
|
||||||
|
|
||||||
|
This reverts commit a31190f59188830b78dce26f0fbc42084f27c3c1.
|
||||||
|
|
||||||
|
This broke glibc's use of SDT_PROBE_ASM; revert until we figure it out.
|
||||||
|
|
||||||
|
diff --git a/includes/sys/sdt.h b/includes/sys/sdt.h
|
||||||
|
index 8230a5b..ba04c12 100644
|
||||||
|
--- a/includes/sys/sdt.h
|
||||||
|
+++ b/includes/sys/sdt.h
|
||||||
|
@@ -171,22 +171,9 @@ __extension__ extern unsigned long long __sdt_unsp;
|
||||||
|
# define _SDT_ASM_AUTOGROUP ""
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-/* We used to have just "note", but some assemblers don't support that.
|
||||||
|
- * GAS documents that it should be @note, but since ARM uses @ for
|
||||||
|
- * comments, it also supports %note. It appears we can get away with
|
||||||
|
- * the latter everywhere, so long as we escape it depending on mode.
|
||||||
|
- * NB: %progbits apparently doesn't need (and can't have) similar %%
|
||||||
|
- * escaping, since that asm() has no operands. */
|
||||||
|
-#ifdef __ASSEMBLER__
|
||||||
|
-#define _SDT_ASM_NOTE %note
|
||||||
|
-#else
|
||||||
|
-#define _SDT_ASM_NOTE %%note
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
|
#define _SDT_ASM_BODY(provider, name, pack_args, args) \
|
||||||
|
_SDT_ASM_1(990: _SDT_NOP) \
|
||||||
|
- _SDT_ASM_3( .pushsection .note.stapsdt,_SDT_ASM_AUTOGROUP, \
|
||||||
|
- _SDT_ASM_NOTE) \
|
||||||
|
+ _SDT_ASM_3( .pushsection .note.stapsdt,_SDT_ASM_AUTOGROUP,"note") \
|
||||||
|
_SDT_ASM_1( .balign 4) \
|
||||||
|
_SDT_ASM_3( .4byte 992f-991f, 994f-993f, _SDT_NOTE_TYPE) \
|
||||||
|
_SDT_ASM_1(991: .asciz _SDT_NOTE_NAME) \
|
||||||
|
@@ -202,7 +189,7 @@ __extension__ extern unsigned long long __sdt_unsp;
|
||||||
|
|
||||||
|
#define _SDT_ASM_BASE \
|
||||||
|
_SDT_ASM_1(.ifndef _.stapsdt.base) \
|
||||||
|
- _SDT_ASM_5( .pushsection .stapsdt.base,"aG",%progbits, \
|
||||||
|
+ _SDT_ASM_5( .pushsection .stapsdt.base,"aG","progbits", \
|
||||||
|
.stapsdt.base,comdat) \
|
||||||
|
_SDT_ASM_1( .weak _.stapsdt.base) \
|
||||||
|
_SDT_ASM_1( .hidden _.stapsdt.base) \
|
@ -32,7 +32,7 @@
|
|||||||
|
|
||||||
Name: systemtap
|
Name: systemtap
|
||||||
Version: 2.4
|
Version: 2.4
|
||||||
Release: 0.109.g217de68%{?dist}
|
Release: 0.109.g217de68.1%{?dist}
|
||||||
# for version, see also configure.ac
|
# for version, see also configure.ac
|
||||||
|
|
||||||
|
|
||||||
@ -65,6 +65,8 @@ License: GPLv2+
|
|||||||
URL: http://sourceware.org/systemtap/
|
URL: http://sourceware.org/systemtap/
|
||||||
Source: %{name}-%{version}-0.109.g217de68.tar.gz
|
Source: %{name}-%{version}-0.109.g217de68.tar.gz
|
||||||
|
|
||||||
|
Patch2: systemtap-snapshot-revert-sdt-section.patch
|
||||||
|
|
||||||
# Build*
|
# Build*
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -299,6 +301,8 @@ runtimes using Byteman.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q %{?setup_elfutils}
|
%setup -q %{?setup_elfutils}
|
||||||
|
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%if %{with_bundled_elfutils}
|
%if %{with_bundled_elfutils}
|
||||||
cd elfutils-%{elfutils_version}
|
cd elfutils-%{elfutils_version}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
@ -827,9 +831,13 @@ done
|
|||||||
# http://sourceware.org/systemtap/wiki/SystemTapReleases
|
# http://sourceware.org/systemtap/wiki/SystemTapReleases
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 26 2013 Josh Stone <jistone@redhat.com> - 2.4-0.109.g217de68.1
|
||||||
|
- The upstream sdt-types change broke glibc; revert for now...
|
||||||
|
|
||||||
* Mon Sep 23 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.109.g217de68
|
* Mon Sep 23 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.109.g217de68
|
||||||
- Automated weekly rawhide release
|
- Automated weekly rawhide release
|
||||||
- Applied spec changes from upstream git
|
- Applied spec changes from upstream git
|
||||||
|
|
||||||
* Mon Sep 16 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.93.g892a56b
|
* Mon Sep 16 2013 Lukas Berk <lberk@redhat.com> - 2.4-0.93.g892a56b
|
||||||
- Automated weekly rawhide release
|
- Automated weekly rawhide release
|
||||||
- Applied spec changes from upstream git
|
- Applied spec changes from upstream git
|
||||||
|
Loading…
Reference in New Issue
Block a user