63 lines
2.8 KiB
Diff
63 lines
2.8 KiB
Diff
From 177b7aae44151ee1ce2ac87883318d8edd81bbe4 Mon Sep 17 00:00:00 2001
|
|
From: Daan De Meyer <daan.j.demeyer@gmail.com>
|
|
Date: Mon, 6 Jan 2025 13:44:03 +0100
|
|
Subject: [PATCH] packit: Simplify configuration
|
|
|
|
(cherry picked from commit 86a6d7cc5a4798e614c50ed02c751e71f74637f9)
|
|
---
|
|
.packit.yml | 29 ++++++-----------------------
|
|
1 file changed, 6 insertions(+), 23 deletions(-)
|
|
|
|
diff --git a/.packit.yml b/.packit.yml
|
|
index eef6e48fcf..697defd3e7 100644
|
|
--- a/.packit.yml
|
|
+++ b/.packit.yml
|
|
@@ -1,6 +1,5 @@
|
|
---
|
|
-# vi:ts=2 sw=2 et:
|
|
-#
|
|
+# SPDX-License-Identifier: LGPL-2.1-or-later
|
|
# Docs: https://packit.dev/docs/
|
|
|
|
specfile_path: .packit_rpm/systemd.spec
|
|
@@ -8,8 +7,6 @@ files_to_sync:
|
|
- .packit.yml
|
|
- src: .packit_rpm/systemd.spec
|
|
dest: systemd.spec
|
|
-upstream_package_name: systemd
|
|
-downstream_package_name: systemd
|
|
# `git describe` returns in systemd's case 'v245-xxx' which breaks RPM version
|
|
# detection (that expects 245-xxxx'). Let's tweak the version string accordingly
|
|
upstream_tag_template: "v{version}"
|
|
@@ -25,25 +22,11 @@ actions:
|
|
|
|
post-upstream-clone:
|
|
# Use the Fedora Rawhide specfile
|
|
- - "git clone https://src.fedoraproject.org/rpms/systemd .packit_rpm --depth=1"
|
|
- # Drop the "sources" file so rebase-helper doesn't think we're a dist-git
|
|
- - "rm -fv .packit_rpm/sources"
|
|
- # Drop backported patches from the specfile, but keep the downstream-only ones
|
|
- # - Patch(0000-0499): backported patches from upstream
|
|
- # - Patch0500-9999: downstream-only patches
|
|
- - "sed -ri '/^Patch(0[0-4]?[0-9]{0,2})?\\:.+\\.patch/d' .packit_rpm/systemd.spec"
|
|
- # Build the RPM with --werror. Even though --werror doesn't work in all
|
|
- # cases (see [0]), we can't use -Dc_args=/-Dcpp_args= here because of the
|
|
- # RPM hardening macros, that use $CFLAGS/$CPPFLAGS (see [1]).
|
|
- #
|
|
- # [0] https://github.com/mesonbuild/meson/issues/7360
|
|
- # [1] https://github.com/systemd/systemd/pull/18908#issuecomment-792250110
|
|
- - 'sed -i "/^CONFIGURE_OPTS=(/a--werror" .packit_rpm/systemd.spec'
|
|
- # Ignore unpackaged standalone binaries
|
|
- - "sed -i 's/assert False,.*/pass/' .packit_rpm/split-files.py"
|
|
- # Temporarily add libarchive-devel build dep and libarchive runtime dep
|
|
- # until the change propagates to Rawhide's specfile
|
|
- - "sed -ri '0,/^BuildRequires: .+$/s//&\\nBuildRequires: libarchive-devel\\nRequires: libarchive/' .packit_rpm/systemd.spec"
|
|
+ - git clone https://src.fedoraproject.org/rpms/systemd .packit_rpm --depth=1
|
|
+ - bash -c 'echo "%bcond upstream 1" > .packit_rpm/systemd.spec.new'
|
|
+ - bash -c 'echo "%define meson_extra_configure_options --werror" >> .packit_rpm/systemd.spec.new'
|
|
+ - bash -c 'cat .packit_rpm/systemd.spec >> .packit_rpm/systemd.spec.new'
|
|
+ - mv .packit_rpm/systemd.spec.new .packit_rpm/systemd.spec
|
|
|
|
jobs:
|
|
- job: copr_build
|