6ee4abe797
Remove resolved scriptlets Don't install tests Resolves: RHEL-46277,RHEL-46576,RHEL-46280
28 lines
1.1 KiB
Diff
28 lines
1.1 KiB
Diff
From 7d65709901cb3fc746639398776cfdb7cb750a03 Mon Sep 17 00:00:00 2001
|
|
From: Luca Boccassi <bluca@debian.org>
|
|
Date: Mon, 17 Jun 2024 15:37:43 +0100
|
|
Subject: [PATCH] test: use 'auto' instead of 'uefi' for automated fallback
|
|
|
|
mkosi will prefer UEFI if the architecture supports it, but fallback
|
|
to 'linux' if it doesn't.
|
|
|
|
(cherry picked from commit 80468db8fa21ffd07dc2f28c656eeaf8f0292367)
|
|
---
|
|
test/TEST-06-SELINUX/meson.build | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/test/TEST-06-SELINUX/meson.build b/test/TEST-06-SELINUX/meson.build
|
|
index 7a850beb81..9261a49c49 100644
|
|
--- a/test/TEST-06-SELINUX/meson.build
|
|
+++ b/test/TEST-06-SELINUX/meson.build
|
|
@@ -5,7 +5,8 @@ integration_tests += [
|
|
'name' : fs.name(meson.current_source_dir()),
|
|
'cmdline' : integration_test_template['cmdline'] + ['selinux=1', 'lsm=selinux'],
|
|
# FIXME; Figure out why reboot sometimes hangs with 'linux' firmware.
|
|
- 'firmware' : 'uefi',
|
|
+ # Use 'auto' to automatically fallback on non-uefi architectures.
|
|
+ 'firmware' : 'auto',
|
|
'vm' : true,
|
|
},
|
|
]
|