95 lines
3.5 KiB
Diff
95 lines
3.5 KiB
Diff
From 7cea77bd5712260277e451d34908f01f14c467c4 Mon Sep 17 00:00:00 2001
|
|
From: Michal Sekletar <msekleta@redhat.com>
|
|
Date: Mon, 30 Aug 2021 18:38:09 +0200
|
|
Subject: [PATCH] boot: don't build bootctl when -Dgnu-efi=false is set
|
|
|
|
(cherry picked from commit fbe3a414e1d8f7b05dccf3d24d4fa475eb9c6bc9)
|
|
|
|
Resolves: #1972223
|
|
---
|
|
meson.build | 8 +++++---
|
|
shell-completion/bash/meson.build | 2 +-
|
|
shell-completion/zsh/meson.build | 2 +-
|
|
units/meson.build | 2 +-
|
|
4 files changed, 8 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 738879eb21..d28f04607a 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1608,6 +1608,10 @@ else
|
|
endif
|
|
conf.set10('ENABLE_EFI', have)
|
|
|
|
+subdir('src/fundamental')
|
|
+subdir('src/boot/efi')
|
|
+conf.set10('HAVE_GNU_EFI', have_gnu_efi)
|
|
+
|
|
############################################################
|
|
|
|
build_bpf_skel_py = find_program('tools/build-bpf-skel.py')
|
|
@@ -1660,7 +1664,6 @@ includes = [libsystemd_includes, include_directories('src/shared')]
|
|
|
|
subdir('po')
|
|
subdir('catalog')
|
|
-subdir('src/fundamental')
|
|
subdir('src/basic')
|
|
subdir('src/libsystemd')
|
|
subdir('src/shared')
|
|
@@ -1751,7 +1754,6 @@ subdir('src/journal')
|
|
subdir('src/libsystemd-network')
|
|
|
|
subdir('src/analyze')
|
|
-subdir('src/boot/efi')
|
|
subdir('src/busctl')
|
|
subdir('src/coredump')
|
|
subdir('src/cryptenroll')
|
|
@@ -2145,7 +2147,7 @@ if conf.get('HAVE_PAM') == 1
|
|
install_dir : rootlibexecdir)
|
|
endif
|
|
|
|
-if conf.get('ENABLE_EFI') == 1 and conf.get('HAVE_BLKID') == 1
|
|
+if conf.get('HAVE_BLKID') == 1 and conf.get('HAVE_GNU_EFI') == 1
|
|
public_programs += executable(
|
|
'bootctl',
|
|
'src/boot/bootctl.c',
|
|
diff --git a/shell-completion/bash/meson.build b/shell-completion/bash/meson.build
|
|
index c26b413d92..bfdd2b01f0 100644
|
|
--- a/shell-completion/bash/meson.build
|
|
+++ b/shell-completion/bash/meson.build
|
|
@@ -33,7 +33,7 @@ items = [['busctl', ''],
|
|
['systemd-run', ''],
|
|
['udevadm', ''],
|
|
['kernel-install', ''],
|
|
- ['bootctl', 'ENABLE_EFI'],
|
|
+ ['bootctl', 'HAVE_GNU_EFI'],
|
|
['coredumpctl', 'ENABLE_COREDUMP'],
|
|
['homectl', 'ENABLE_HOMED'],
|
|
['hostnamectl', 'ENABLE_HOSTNAMED'],
|
|
diff --git a/shell-completion/zsh/meson.build b/shell-completion/zsh/meson.build
|
|
index f5f9b0f993..3a92f303b8 100644
|
|
--- a/shell-completion/zsh/meson.build
|
|
+++ b/shell-completion/zsh/meson.build
|
|
@@ -28,7 +28,7 @@ items = [['_busctl', ''],
|
|
['_sd_outputmodes', ''],
|
|
['_sd_unit_files', ''],
|
|
['_sd_machines', ''],
|
|
- ['_bootctl', 'ENABLE_EFI'],
|
|
+ ['_bootctl', 'HAVE_GNU_EFI'],
|
|
['_coredumpctl', 'ENABLE_COREDUMP'],
|
|
['_hostnamectl', 'ENABLE_HOSTNAMED'],
|
|
['_localectl', 'ENABLE_LOCALED'],
|
|
diff --git a/units/meson.build b/units/meson.build
|
|
index 68be8d0108..27a2b60137 100644
|
|
--- a/units/meson.build
|
|
+++ b/units/meson.build
|
|
@@ -102,7 +102,7 @@ units = [
|
|
['systemd-ask-password-wall.path', '',
|
|
'multi-user.target.wants/'],
|
|
['systemd-ask-password-wall.service', ''],
|
|
- ['systemd-boot-system-token.service', 'ENABLE_EFI',
|
|
+ ['systemd-boot-system-token.service', 'HAVE_GNU_EFI',
|
|
'sysinit.target.wants/'],
|
|
['systemd-coredump.socket', 'ENABLE_COREDUMP',
|
|
'sockets.target.wants/'],
|