79350f79d8
Resolves: #2137584,#2138081,#2141979
44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
From d63a1edb6bef959e8d6a481464a809badcc3a2eb Mon Sep 17 00:00:00 2001
|
||
From: Torsten Hilbrich <torsten.hilbrich@secunet.com>
|
||
Date: Mon, 7 Nov 2022 08:38:58 +0100
|
||
Subject: [PATCH] test: compile test-utmp.c only if UTMP is enabled
|
||
MIME-Version: 1.0
|
||
Content-Type: text/plain; charset=UTF-8
|
||
Content-Transfer-Encoding: 8bit
|
||
|
||
When compiling with -D utmp=false the compilation fails with:
|
||
|
||
../../git/systemd/src/test/test-utmp.c: In function ‘test_dump_run_utmp’:
|
||
../../git/systemd/src/test/test-utmp.c:21:9: error: cleanup argument not a function
|
||
21 | _unused_ _cleanup_(utxent_cleanup) bool utmpx = false;
|
||
| ^~~~~~~~
|
||
../../git/systemd/src/test/test-utmp.c:23:17: error: implicit declaration of function ‘utxent_start’ [-Werror=implicit-function-declaration]
|
||
23 | utmpx = utxent_start();
|
||
| ^~~~~~~~~~~~
|
||
|
||
any many other errors
|
||
|
||
Add a conditional to compile test-utmp.c only if ENABLE_UTMP is true.
|
||
|
||
(cherry picked from commit 41cac2a8b98fc5faebe942c697b17e109822342d)
|
||
|
||
Related: #2138081
|
||
---
|
||
src/test/meson.build | 3 ++-
|
||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||
|
||
diff --git a/src/test/meson.build b/src/test/meson.build
|
||
index 86fc1d4fc0..2a4dfe26db 100644
|
||
--- a/src/test/meson.build
|
||
+++ b/src/test/meson.build
|
||
@@ -622,7 +622,8 @@ tests += [
|
||
|
||
[files('test-journal-importer.c')],
|
||
|
||
- [files('test-utmp.c')],
|
||
+ [files('test-utmp.c'),
|
||
+ [], [], [], 'ENABLE_UTMP'],
|
||
|
||
[files('test-udev.c'),
|
||
[libudevd_core,
|