42cbfa381f
Resolves: RHEL-40924,RHEL-22621,RHEL-678,RHEL-40360,RHEL-36636
99 lines
2.4 KiB
Diff
99 lines
2.4 KiB
Diff
From 67ff61b054e8d4d4d3923c3b81586b2d4e286d6b Mon Sep 17 00:00:00 2001
|
|
From: Jan Macku <jamacku@redhat.com>
|
|
Date: Thu, 16 May 2024 14:24:38 +0200
|
|
Subject: [PATCH] ci: update workflows to run on source-git setup
|
|
|
|
rhel-only: ci
|
|
|
|
Related: RHEL-36636
|
|
---
|
|
.github/workflows/cflite_pr.yml | 3 ---
|
|
.github/workflows/codeql.yml | 6 ------
|
|
.github/workflows/differential-shellcheck.yml | 4 ----
|
|
.github/workflows/linter.yml | 3 ---
|
|
.github/workflows/unit_tests.yml | 3 ---
|
|
5 files changed, 19 deletions(-)
|
|
|
|
diff --git a/.github/workflows/cflite_pr.yml b/.github/workflows/cflite_pr.yml
|
|
index f0d321794a..87dcd3c478 100644
|
|
--- a/.github/workflows/cflite_pr.yml
|
|
+++ b/.github/workflows/cflite_pr.yml
|
|
@@ -5,9 +5,6 @@
|
|
name: ClusterFuzzLite PR fuzzing
|
|
on:
|
|
pull_request:
|
|
- branches:
|
|
- - main
|
|
- - v[0-9]+-stable
|
|
|
|
permissions: read-all
|
|
|
|
diff --git a/.github/workflows/codeql.yml b/.github/workflows/codeql.yml
|
|
index 0d284f75f1..daf34486d2 100644
|
|
--- a/.github/workflows/codeql.yml
|
|
+++ b/.github/workflows/codeql.yml
|
|
@@ -6,9 +6,6 @@ name: "CodeQL"
|
|
|
|
on:
|
|
pull_request:
|
|
- branches:
|
|
- - main
|
|
- - v[0-9]+-stable
|
|
paths:
|
|
- '**/meson.build'
|
|
- '.github/**/codeql*'
|
|
@@ -16,9 +13,6 @@ on:
|
|
- 'test/**'
|
|
- 'tools/**'
|
|
push:
|
|
- branches:
|
|
- - main
|
|
- - v[0-9]+-stable
|
|
|
|
permissions:
|
|
contents: read
|
|
diff --git a/.github/workflows/differential-shellcheck.yml b/.github/workflows/differential-shellcheck.yml
|
|
index 244f5d503b..403b5cfc58 100644
|
|
--- a/.github/workflows/differential-shellcheck.yml
|
|
+++ b/.github/workflows/differential-shellcheck.yml
|
|
@@ -4,11 +4,7 @@
|
|
name: Differential ShellCheck
|
|
on:
|
|
push:
|
|
- branches:
|
|
- - main
|
|
pull_request:
|
|
- branches:
|
|
- - main
|
|
|
|
permissions:
|
|
contents: read
|
|
diff --git a/.github/workflows/linter.yml b/.github/workflows/linter.yml
|
|
index cf0bc09453..e7fb70f2f5 100644
|
|
--- a/.github/workflows/linter.yml
|
|
+++ b/.github/workflows/linter.yml
|
|
@@ -6,9 +6,6 @@ name: Lint Code Base
|
|
|
|
on:
|
|
pull_request:
|
|
- branches:
|
|
- - main
|
|
- - v[0-9]+-stable
|
|
|
|
permissions:
|
|
contents: read
|
|
diff --git a/.github/workflows/unit_tests.yml b/.github/workflows/unit_tests.yml
|
|
index 895068c2a2..bf6c820092 100644
|
|
--- a/.github/workflows/unit_tests.yml
|
|
+++ b/.github/workflows/unit_tests.yml
|
|
@@ -5,9 +5,6 @@
|
|
name: Unit tests
|
|
on:
|
|
pull_request:
|
|
- branches:
|
|
- - main
|
|
- - v[0-9]+-stable
|
|
|
|
permissions:
|
|
contents: read
|