113 lines
3.1 KiB
Diff
113 lines
3.1 KiB
Diff
From 7586bc7e5006fd7df55199283de4766b2775f60f Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
Date: Sun, 18 Jun 2017 15:53:15 -0400
|
|
Subject: [PATCH] test-resolved-packet: add a simple test for our allocation
|
|
functions
|
|
|
|
(cherry picked from commit 751ca3f1de316ca79b60001334dbdf54077e1d01)
|
|
---
|
|
.gitignore | 1 +
|
|
Makefile.am | 14 ++++++++++++
|
|
src/resolve/test-resolved-packet.c | 45 ++++++++++++++++++++++++++++++++++++++
|
|
3 files changed, 60 insertions(+)
|
|
create mode 100644 src/resolve/test-resolved-packet.c
|
|
|
|
diff --git a/.gitignore b/.gitignore
|
|
index 01cb6e7db7..25b976a0e3 100644
|
|
--- a/.gitignore
|
|
+++ b/.gitignore
|
|
@@ -269,6 +269,7 @@
|
|
/test-replace-var
|
|
/test-resolve
|
|
/test-resolve-tables
|
|
+/test-resolved-packet
|
|
/test-ring
|
|
/test-rlimit-util
|
|
/test-sched-prio
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index a767a5aa0d..e97a66e0fa 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -5663,6 +5663,7 @@ dist_zshcompletion_data += \
|
|
tests += \
|
|
test-dns-packet \
|
|
test-resolve-tables \
|
|
+ test-resolved-packet \
|
|
test-dnssec
|
|
|
|
manual_tests += \
|
|
@@ -5684,6 +5685,19 @@ test_resolve_tables_LDADD = \
|
|
$(GCRYPT_LIBS) \
|
|
-lm
|
|
|
|
+test_resolved_packet_SOURCES = \
|
|
+ src/resolve/test-resolved-packet.c \
|
|
+ $(basic_dns_sources)
|
|
+
|
|
+test_resolved_packet_CFLAGS = \
|
|
+ $(AM_CFLAGS) \
|
|
+ $(GCRYPT_CFLAGS)
|
|
+
|
|
+test_resolved_packet_LDADD = \
|
|
+ libsystemd-shared.la \
|
|
+ $(GCRYPT_LIBS) \
|
|
+ -lm
|
|
+
|
|
test_dns_packet_SOURCES = \
|
|
src/resolve/test-dns-packet.c \
|
|
$(basic_dns_sources)
|
|
diff --git a/src/resolve/test-resolved-packet.c b/src/resolve/test-resolved-packet.c
|
|
new file mode 100644
|
|
index 0000000000..8b7da1408d
|
|
--- /dev/null
|
|
+++ b/src/resolve/test-resolved-packet.c
|
|
@@ -0,0 +1,45 @@
|
|
+/***
|
|
+ This file is part of systemd
|
|
+
|
|
+ Copyright 2017 Zbigniew Jędrzejewski-Szmek
|
|
+
|
|
+ systemd is free software; you can redistribute it and/or modify it
|
|
+ under the terms of the GNU Lesser General Public License as published by
|
|
+ the Free Software Foundation; either version 2.1 of the License, or
|
|
+ (at your option) any later version.
|
|
+
|
|
+ systemd is distributed in the hope that it will be useful, but
|
|
+ WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public License
|
|
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
|
|
+***/
|
|
+
|
|
+#include "log.h"
|
|
+#include "resolved-dns-packet.h"
|
|
+
|
|
+static void test_dns_packet_new(void) {
|
|
+ size_t i;
|
|
+
|
|
+ for (i = 0; i < DNS_PACKET_SIZE_MAX + 2; i++) {
|
|
+ _cleanup_(dns_packet_unrefp) DnsPacket *p = NULL;
|
|
+
|
|
+ assert_se(dns_packet_new(&p, DNS_PROTOCOL_DNS, i) == 0);
|
|
+
|
|
+ log_debug("dns_packet_new: %zu → %zu", i, p->allocated);
|
|
+ assert_se(p->allocated >= MIN(DNS_PACKET_SIZE_MAX, i));
|
|
+ }
|
|
+}
|
|
+
|
|
+int main(int argc, char **argv) {
|
|
+
|
|
+ log_set_max_level(LOG_DEBUG);
|
|
+ log_parse_environment();
|
|
+ log_open();
|
|
+
|
|
+ test_dns_packet_new();
|
|
+
|
|
+ return 0;
|
|
+}
|
|
--
|
|
2.13.0
|
|
|