87 lines
2.9 KiB
Diff
87 lines
2.9 KiB
Diff
From 8523c2a84f3d8a8b163a17aad5c55cb0234ebff2 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Hindoe Paaboel Andersen <phomes@gmail.com>
|
|
Date: Sat, 1 Mar 2014 23:08:38 +0100
|
|
Subject: [PATCH] add bash completion for systemd-cgls
|
|
|
|
(cherry picked from commit abdab4f602745952030a37b1521cd0374d51d3ea)
|
|
---
|
|
Makefile.am | 1 +
|
|
shell-completion/bash/systemd-cgls | 56 ++++++++++++++++++++++++++++++++++++++
|
|
2 files changed, 57 insertions(+)
|
|
create mode 100644 shell-completion/bash/systemd-cgls
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 8e6c392..0b83823 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -352,6 +352,7 @@ dist_bashcompletion_DATA = \
|
|
shell-completion/bash/journalctl \
|
|
shell-completion/bash/systemctl \
|
|
shell-completion/bash/systemd-analyze \
|
|
+ shell-completion/bash/systemd-cgls \
|
|
shell-completion/bash/systemd-delta \
|
|
shell-completion/bash/systemd-nspawn \
|
|
shell-completion/bash/systemd-run \
|
|
diff --git a/shell-completion/bash/systemd-cgls b/shell-completion/bash/systemd-cgls
|
|
new file mode 100644
|
|
index 0000000..0570438
|
|
--- /dev/null
|
|
+++ b/shell-completion/bash/systemd-cgls
|
|
@@ -0,0 +1,56 @@
|
|
+# systemd-cgls(1) completion -*- shell-script -*-
|
|
+#
|
|
+# This file is part of systemd.
|
|
+#
|
|
+# Copyright 2014 Thomas H.P. Andersen
|
|
+#
|
|
+# systemd is free software; you can redistribute it and/or modify it
|
|
+# under the terms of the GNU Lesser General Public License as published by
|
|
+# the Free Software Foundation; either version 2.1 of the License, or
|
|
+# (at your option) any later version.
|
|
+#
|
|
+# systemd is distributed in the hope that it will be useful, but
|
|
+# WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+# General Public License for more details.
|
|
+#
|
|
+# You should have received a copy of the GNU Lesser General Public License
|
|
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
|
|
+
|
|
+__contains_word() {
|
|
+ local w word=$1; shift
|
|
+ for w in "$@"; do
|
|
+ [[ $w = "$word" ]] && return
|
|
+ done
|
|
+}
|
|
+
|
|
+__get_machines() {
|
|
+ local a b
|
|
+ machinectl list --no-legend --no-pager | { while read a b; do echo " $a"; done; };
|
|
+}
|
|
+
|
|
+_systemd_cgls() {
|
|
+ local cur=${COMP_WORDS[COMP_CWORD]} prev=${COMP_WORDS[COMP_CWORD-1]}
|
|
+ local i verb comps
|
|
+
|
|
+ local -A OPTS=(
|
|
+ [STANDALONE]='-h --help --version --all -l --full -k --no-pager'
|
|
+ [ARG]='-M --machine'
|
|
+ )
|
|
+
|
|
+ _init_completion || return
|
|
+
|
|
+ if __contains_word "$prev" ${OPTS[ARG]}; then
|
|
+ case $prev in
|
|
+ --machine|-M)
|
|
+ comps=$( __get_machines )
|
|
+ ;;
|
|
+ esac
|
|
+ COMPREPLY=( $(compgen -W '$comps' -- "$cur") )
|
|
+ return 0
|
|
+ fi
|
|
+
|
|
+ COMPREPLY=( $(compgen -W '${OPTS[*]}' -- "$cur") )
|
|
+}
|
|
+
|
|
+complete -F _systemd_cgls systemd-cgls
|