71 lines
2.5 KiB
Diff
71 lines
2.5 KiB
Diff
From 191479e0e4fb43f667ce743e82aac8bcccfbd6e1 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Hindoe Paaboel Andersen <phomes@gmail.com>
|
|
Date: Mon, 3 Mar 2014 22:16:04 +0100
|
|
Subject: [PATCH] add bash completion for systemd-detect-virt
|
|
|
|
(cherry picked from commit 3bfe58cbd4a9b1d2520f425f95de718f3a583d39)
|
|
---
|
|
Makefile.am | 1 +
|
|
shell-completion/bash/systemd-detect-virt | 40 +++++++++++++++++++++++++++++++
|
|
2 files changed, 41 insertions(+)
|
|
create mode 100644 shell-completion/bash/systemd-detect-virt
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index bc5e719..834ed6f 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -355,6 +355,7 @@ dist_bashcompletion_DATA = \
|
|
shell-completion/bash/systemd-cgls \
|
|
shell-completion/bash/systemd-cgtop \
|
|
shell-completion/bash/systemd-delta \
|
|
+ shell-completion/bash/systemd-detect-virt \
|
|
shell-completion/bash/systemd-nspawn \
|
|
shell-completion/bash/systemd-run \
|
|
shell-completion/bash/udevadm \
|
|
diff --git a/shell-completion/bash/systemd-detect-virt b/shell-completion/bash/systemd-detect-virt
|
|
new file mode 100644
|
|
index 0000000..df06c29
|
|
--- /dev/null
|
|
+++ b/shell-completion/bash/systemd-detect-virt
|
|
@@ -0,0 +1,40 @@
|
|
+# systemd-detect-virt(1) completion -*- shell-script -*-
|
|
+#
|
|
+# This file is part of systemd.
|
|
+#
|
|
+# Copyright 2014 Thomas H.P. Andersen
|
|
+#
|
|
+# systemd is free software; you can redistribute it and/or modify it
|
|
+# under the terms of the GNU Lesser General Public License as published by
|
|
+# the Free Software Foundation; either version 2.1 of the License, or
|
|
+# (at your option) any later version.
|
|
+#
|
|
+# systemd is distributed in the hope that it will be useful, but
|
|
+# WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+# General Public License for more details.
|
|
+#
|
|
+# You should have received a copy of the GNU Lesser General Public License
|
|
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
|
|
+
|
|
+__contains_word() {
|
|
+ local w word=$1; shift
|
|
+ for w in "$@"; do
|
|
+ [[ $w = "$word" ]] && return
|
|
+ done
|
|
+}
|
|
+
|
|
+_systemd_detect_virt() {
|
|
+ local cur=${COMP_WORDS[COMP_CWORD]} prev=${COMP_WORDS[COMP_CWORD-1]}
|
|
+ local i verb comps
|
|
+
|
|
+ local -A OPTS=(
|
|
+ [STANDALONE]='-h --help --version -c --container -v --vm -q --quiet'
|
|
+ )
|
|
+
|
|
+ _init_completion || return
|
|
+
|
|
+ COMPREPLY=( $(compgen -W '${OPTS[*]}' -- "$cur") )
|
|
+}
|
|
+
|
|
+complete -F _systemd_detect_virt systemd-detect-virt
|