systemd/0817-meson-use-ternary-op-for-brevity.patch
Jan Macku 4f97ea019f systemd-252-38
Resolves: RHEL-30372
2024-06-19 12:59:17 +02:00

30 lines
894 B
Diff

From 70de0ee05d6680e81b6e1b163902c45a2ff7aa63 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
Date: Wed, 15 Nov 2023 14:47:17 +0100
Subject: [PATCH] meson: use ternary op for brevity
(cherry picked from commit 3e0cf732435faba34aa16f315d8a47e924734589)
Related: RHEL-30372
---
test/fuzz/meson.build | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/test/fuzz/meson.build b/test/fuzz/meson.build
index 8637c66458..cb00006ff2 100644
--- a/test/fuzz/meson.build
+++ b/test/fuzz/meson.build
@@ -33,11 +33,7 @@ endforeach
fuzz_c_args = get_option('c_args')
-if cxx_cmd != ''
- fuzz_cpp_args = get_option('cpp_args')
-else
- fuzz_cpp_args = []
-endif
+fuzz_cpp_args = cxx_cmd != '' ? get_option('cpp_args') : []
sanitize_address_undefined = custom_target(
'sanitize-address-undefined-fuzzers',