35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
From deb09b3bd826571149f6b018f3a3ff8a33cd104b Mon Sep 17 00:00:00 2001
|
|
From: Yu Watanabe <watanabe.yu+github@gmail.com>
|
|
Date: Thu, 28 Jun 2018 16:09:04 +0900
|
|
Subject: [PATCH] meson: do not compare objects of different types
|
|
|
|
This fixes the following warning:
|
|
```
|
|
meson.build:1140: WARNING: Trying to compare values of different types (DependencyHolder, list) using !=.
|
|
The result of this is undefined and will become a hard error in a future Meson release.
|
|
```
|
|
|
|
Follow-up for f02582f69fe1e7663a87ba80bd4f90d5d23ee75f(#9410).
|
|
|
|
(cherry picked from commit 48f5da19b6e8f0d05f5217bc9856093d354ce5d0)
|
|
|
|
Related: #2122499
|
|
---
|
|
meson.build | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 6729a9ea5e..af4cf331da 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1165,7 +1165,8 @@ substs.set('DEFAULT_DNSSEC_MODE', default_dnssec)
|
|
|
|
dns_over_tls = get_option('dns-over-tls')
|
|
if dns_over_tls != 'false'
|
|
- have = libgnutls != [] and libgnutls.version().version_compare('>=3.5.3')
|
|
+ have = (conf.get('HAVE_GNUTLS') == 1 and
|
|
+ libgnutls.version().version_compare('>=3.5.3'))
|
|
if dns_over_tls == 'true' and not have
|
|
error('DNS-over-TLS support was requested, but dependencies are not available')
|
|
endif
|