76 lines
2.7 KiB
Diff
76 lines
2.7 KiB
Diff
From 09c96d5ef3f2b0bc4e5f1cf69e9b66248e325509 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
Date: Mon, 29 Oct 2018 18:32:51 +0100
|
|
Subject: [PATCH] Drop support for lz4 < 1.3.0
|
|
|
|
lz4-r130 was released on May 29th, 2015. Let's drop the work-around for older
|
|
versions. In particular, we won't test any new code against those ancient
|
|
releases, so we shouldn't pretend they are supported.
|
|
|
|
(cherry picked from commit e0a1d4b049e6991919a0eacd5d96f7f39dc6ddd1)
|
|
Resolves: #1843871
|
|
---
|
|
README | 2 +-
|
|
meson.build | 1 +
|
|
src/journal/compress.c | 4 ----
|
|
src/journal/test-compress.c | 4 ----
|
|
4 files changed, 2 insertions(+), 9 deletions(-)
|
|
|
|
diff --git a/README b/README
|
|
index 7d06e04800..859152fbde 100644
|
|
--- a/README
|
|
+++ b/README
|
|
@@ -148,7 +148,7 @@ REQUIREMENTS:
|
|
libacl (optional)
|
|
libselinux (optional)
|
|
liblzma (optional)
|
|
- liblz4 >= 119 (optional)
|
|
+ liblz4 >= 1.3.0 / 130 (optional)
|
|
libgcrypt (optional)
|
|
libqrencode (optional)
|
|
libmicrohttpd (optional)
|
|
diff --git a/meson.build b/meson.build
|
|
index 70811c29cf..c8ae1e15bd 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1076,6 +1076,7 @@ conf.set10('HAVE_XZ', have)
|
|
want_lz4 = get_option('lz4')
|
|
if want_lz4 != 'false' and not fuzzer_build
|
|
liblz4 = dependency('liblz4',
|
|
+ version : '>= 1.3.0',
|
|
required : want_lz4 == 'true')
|
|
have = liblz4.found()
|
|
else
|
|
diff --git a/src/journal/compress.c b/src/journal/compress.c
|
|
index 6baf15c8ff..a4a5e63840 100644
|
|
--- a/src/journal/compress.c
|
|
+++ b/src/journal/compress.c
|
|
@@ -95,11 +95,7 @@ int compress_blob_lz4(const void *src, uint64_t src_size,
|
|
if (src_size < 9)
|
|
return -ENOBUFS;
|
|
|
|
-#if LZ4_VERSION_NUMBER >= 10700
|
|
r = LZ4_compress_default(src, (char*)dst + 8, src_size, (int) dst_alloc_size - 8);
|
|
-#else
|
|
- r = LZ4_compress_limitedOutput(src, (char*)dst + 8, src_size, (int) dst_alloc_size - 8);
|
|
-#endif
|
|
if (r <= 0)
|
|
return -ENOBUFS;
|
|
|
|
diff --git a/src/journal/test-compress.c b/src/journal/test-compress.c
|
|
index 791c6fdffb..eb3dc3eb6b 100644
|
|
--- a/src/journal/test-compress.c
|
|
+++ b/src/journal/test-compress.c
|
|
@@ -207,11 +207,7 @@ static void test_lz4_decompress_partial(void) {
|
|
memset(huge, 'x', HUGE_SIZE);
|
|
memcpy(huge, "HUGE=", 5);
|
|
|
|
-#if LZ4_VERSION_NUMBER >= 10700
|
|
r = LZ4_compress_default(huge, buf, HUGE_SIZE, buf_size);
|
|
-#else
|
|
- r = LZ4_compress_limitedOutput(huge, buf, HUGE_SIZE, buf_size);
|
|
-#endif
|
|
assert_se(r >= 0);
|
|
compressed = r;
|
|
log_info("Compressed %i → %zu", HUGE_SIZE, compressed);
|