44 lines
1.6 KiB
Diff
44 lines
1.6 KiB
Diff
From 8f6b442a78d0b485f044742ad90b2e8271b4e68e Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
Date: Sun, 19 Aug 2018 19:11:30 +0200
|
|
Subject: [PATCH] meson: rename -Ddebug to -Ddebug-extra
|
|
|
|
Meson added -Doptimization and -Ddebug options, which obviously causes
|
|
a conflict with our -Ddebug options. Let's rename it.
|
|
|
|
Fixes #9883.
|
|
---
|
|
meson.build | 2 +-
|
|
meson_options.txt | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index f79ac4b12..2209c935a 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -763,7 +763,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
|
|
|
|
enable_debug_hashmap = false
|
|
enable_debug_mmap_cache = false
|
|
-foreach name : get_option('debug')
|
|
+foreach name : get_option('debug-extra')
|
|
if name == 'hashmap'
|
|
enable_debug_hashmap = true
|
|
elif name == 'mmap-cache'
|
|
diff --git a/meson_options.txt b/meson_options.txt
|
|
index e3140c8c1..7b1f61bf4 100644
|
|
--- a/meson_options.txt
|
|
+++ b/meson_options.txt
|
|
@@ -45,7 +45,7 @@ option('debug-shell', type : 'string', value : '/bin/sh',
|
|
description : 'path to debug shell binary')
|
|
option('debug-tty', type : 'string', value : '/dev/tty9',
|
|
description : 'specify the tty device for debug shell')
|
|
-option('debug', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
|
|
+option('debug-extra', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
|
|
description : 'enable extra debugging')
|
|
option('memory-accounting-default', type : 'boolean',
|
|
description : 'enable MemoryAccounting= by default')
|
|
--
|
|
2.14.4
|
|
|