49 lines
1.5 KiB
Diff
49 lines
1.5 KiB
Diff
From 5a263a734350a1f2de6b3e6ac8813b51280a9794 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
Date: Wed, 16 Jul 2014 16:44:45 -0400
|
|
Subject: [PATCH] missing.h: add IFLA_MACVLAN_FLAGS
|
|
|
|
Now we are getting into kernel < 3.4 territory...
|
|
|
|
https://bugs.freedesktop.org/show_bug.cgi?id=80095
|
|
(cherry picked from commit 75616a1332aff00d27db713cda3bd93c508a5b59)
|
|
---
|
|
configure.ac | 3 ++-
|
|
src/shared/missing.h | 9 +++++++++
|
|
2 files changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index ae88382e21..df6b3571d1 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -310,7 +310,8 @@ AC_CHECK_DECLS([gettid, pivot_root, name_to_handle_at, setns, LO_FLAGS_PARTSCAN]
|
|
#include <linux/loop.h>
|
|
]])
|
|
|
|
-AC_CHECK_DECLS([IFLA_PHYS_PORT_ID,
|
|
+AC_CHECK_DECLS([IFLA_MACVLAN_FLAGS,
|
|
+ IFLA_PHYS_PORT_ID,
|
|
IFLA_BOND_AD_INFO,
|
|
IFLA_VLAN_PROTOCOL,
|
|
IFLA_VXLAN_LOCAL6,
|
|
diff --git a/src/shared/missing.h b/src/shared/missing.h
|
|
index f129f0b2d3..818d704f92 100644
|
|
--- a/src/shared/missing.h
|
|
+++ b/src/shared/missing.h
|
|
@@ -371,6 +371,15 @@ static inline int setns(int fd, int nstype) {
|
|
#define LOOP_CTL_GET_FREE 0x4C82
|
|
#endif
|
|
|
|
+#if !HAVE_DECL_IFLA_MACVLAN_FLAGS
|
|
+#define IFLA_MACVLAN_UNSPEC 0
|
|
+#define IFLA_MACVLAN_MODE 1
|
|
+#define IFLA_MACVLAN_FLAGS 2
|
|
+#define __IFLA_MACVLAN_MAX 3
|
|
+
|
|
+#define IFLA_MACVLAN_MAX (__IFLA_MACVLAN_MAX - 1)
|
|
+#endif
|
|
+
|
|
#if !HAVE_DECL_IFLA_PHYS_PORT_ID
|
|
#undef IFLA_PROMISCUITY
|
|
#define IFLA_PROMISCUITY 30
|