42cbfa381f
Resolves: RHEL-40924,RHEL-22621,RHEL-678,RHEL-40360,RHEL-36636
62 lines
2.3 KiB
Diff
62 lines
2.3 KiB
Diff
From 970ac707323ce1b50c6f45184df4373d651e669c Mon Sep 17 00:00:00 2001
|
|
From: Jan Macku <jamacku@redhat.com>
|
|
Date: Fri, 17 May 2024 13:55:40 +0200
|
|
Subject: [PATCH] ci: reconfigure Packit for RHEL 10
|
|
|
|
rhel-only: ci
|
|
|
|
Related: RHEL-36636
|
|
---
|
|
.packit.yml | 28 +++++++++-------------------
|
|
1 file changed, 9 insertions(+), 19 deletions(-)
|
|
|
|
diff --git a/.packit.yml b/.packit.yml
|
|
index 2dcc9e86ca..340c6992ec 100644
|
|
--- a/.packit.yml
|
|
+++ b/.packit.yml
|
|
@@ -24,14 +24,12 @@ actions:
|
|
- "bash -ec 'git describe --tags --abbrev=0 | cut -b 2-'"
|
|
|
|
post-upstream-clone:
|
|
- # Use the Fedora Rawhide specfile
|
|
- - "git clone https://src.fedoraproject.org/rpms/systemd .packit_rpm --depth=1"
|
|
+ # Use the CentOS Stream 10 specfile
|
|
+ - "git clone -b c10s https://gitlab.com/redhat/centos-stream/rpms/systemd.git .packit_rpm --depth=1"
|
|
# Drop the "sources" file so rebase-helper doesn't think we're a dist-git
|
|
- "rm -fv .packit_rpm/sources"
|
|
- # Drop backported patches from the specfile, but keep the downstream-only ones
|
|
- # - Patch(0000-0499): backported patches from upstream
|
|
- # - Patch0500-9999: downstream-only patches
|
|
- - "sed -ri '/^Patch(0[0-4]?[0-9]{0,2})?\\:.+\\.patch/d' .packit_rpm/systemd.spec"
|
|
+ # Drop all patches, since they're already included in the tarball
|
|
+ - "sed -ri '/^Patch[0-9]+:/d' .packit_rpm/systemd.spec"
|
|
# Build the RPM with --werror. Even though --werror doesn't work in all
|
|
# cases (see [0]), we can't use -Dc_args=/-Dcpp_args= here because of the
|
|
# RPM hardening macros, that use $CFLAGS/$CPPFLAGS (see [1]).
|
|
@@ -45,20 +43,12 @@ actions:
|
|
# until the change propagates to Rawhide's specfile
|
|
- "sed -ri '0,/^BuildRequires: .+$/s//&\\nBuildRequires: libarchive-devel\\nRequires: libarchive/' .packit_rpm/systemd.spec"
|
|
|
|
+# Available targets can be listed via `copr-cli list-chroots`
|
|
jobs:
|
|
- job: copr_build
|
|
trigger: pull_request
|
|
targets:
|
|
- - fedora-rawhide-aarch64
|
|
- - fedora-rawhide-i386
|
|
- - fedora-rawhide-ppc64le
|
|
- - fedora-rawhide-s390x
|
|
- - fedora-rawhide-x86_64
|
|
-
|
|
-- job: tests
|
|
- trigger: pull_request
|
|
- fmf_url: https://src.fedoraproject.org/tests/systemd
|
|
- fmf_ref: main
|
|
- tmt_plan: ci
|
|
- targets:
|
|
- - fedora-rawhide-x86_64
|
|
+ - centos-stream-10-aarch64
|
|
+ - centos-stream-10-ppc64le
|
|
+ - centos-stream-10-s390x
|
|
+ - centos-stream-10-x86_64
|