c895351950
Resolves: #2017035
78 lines
3.0 KiB
Diff
78 lines
3.0 KiB
Diff
From a6c93d3200c0fd0eeee3a725b428cee94108cf48 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
Date: Thu, 23 Dec 2021 13:05:01 +0100
|
|
Subject: [PATCH] meson: move efi summary() section to src/boot/efi
|
|
|
|
This way we can add the entries more naturally in the same place where
|
|
they are defined.
|
|
|
|
(cherry picked from commit 3f871f120520aa2d11218735b0741bacc0309b4d)
|
|
|
|
Related: #2017035
|
|
---
|
|
meson.build | 16 ++++------------
|
|
src/boot/efi/meson.build | 9 +++++++++
|
|
2 files changed, 13 insertions(+), 12 deletions(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index e07875a054..f040eeab99 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -43,6 +43,10 @@ endif
|
|
skip_deps = want_ossfuzz or want_libfuzzer
|
|
fuzzer_build = want_ossfuzz or want_libfuzzer
|
|
|
|
+# Create a title-less summary section early, so it ends up first in the output.
|
|
+# More items are added later after they have been detected.
|
|
+summary({'build mode' : get_option('mode')})
|
|
+
|
|
#####################################################################
|
|
|
|
# Try to install the git pre-commit hook
|
|
@@ -3902,7 +3906,6 @@ alt_time_epoch = run_command('date', '-Is', '-u', '-d', '@@0@'.format(time_epoch
|
|
check : true).stdout().strip()
|
|
|
|
summary({
|
|
- 'build mode' : get_option('mode'),
|
|
'split /usr' : split_usr,
|
|
'split bin-sbin' : split_bin,
|
|
'prefix directory' : prefixdir,
|
|
@@ -3960,17 +3963,6 @@ summary({
|
|
# CPPFLAGS: ${OUR_CPPFLAGS} ${CPPFLAGS}
|
|
# LDFLAGS: ${OUR_LDFLAGS} ${LDFLAGS}
|
|
|
|
-if conf.get('ENABLE_EFI') == 1 and conf.get('HAVE_GNU_EFI') == 1
|
|
- summary({
|
|
- 'EFI machine type' : efi_arch[0],
|
|
- 'EFI CC' : '@0@'.format(' '.join(efi_cc)),
|
|
- 'EFI LD' : efi_ld,
|
|
- 'EFI lds' : efi_lds,
|
|
- 'EFI crt0' : efi_crt0,
|
|
- 'EFI include directory' : efi_incdir},
|
|
- section : 'Extensible Firmware Interface')
|
|
-endif
|
|
-
|
|
found = []
|
|
missing = []
|
|
|
|
diff --git a/src/boot/efi/meson.build b/src/boot/efi/meson.build
|
|
index 1125c64ea3..dd318079fc 100644
|
|
--- a/src/boot/efi/meson.build
|
|
+++ b/src/boot/efi/meson.build
|
|
@@ -279,6 +279,15 @@ if efi_cc_version.contains('clang') and efi_cc_version.split('.')[0].split(' ')[
|
|
efi_ldflags += ['-Wl,-T,' + efi_lds, '-Wno-unused-command-line-argument']
|
|
endif
|
|
|
|
+summary({
|
|
+ 'EFI machine type' : efi_arch[0],
|
|
+ 'EFI CC' : '@0@'.format(' '.join(efi_cc)),
|
|
+ 'EFI LD' : efi_ld,
|
|
+ 'EFI lds' : efi_lds,
|
|
+ 'EFI crt0' : efi_crt0,
|
|
+ 'EFI include directory' : efi_incdir},
|
|
+ section : 'Extensible Firmware Interface')
|
|
+
|
|
############################################################
|
|
|
|
efi_headers = files(
|