b650a930d3
Resolves: #2047768,#2017035
62 lines
2.3 KiB
Diff
62 lines
2.3 KiB
Diff
From d931821a263e34805f825cf12a0a0fcde9beda99 Mon Sep 17 00:00:00 2001
|
|
From: Frantisek Sumsal <frantisek@sumsal.cz>
|
|
Date: Wed, 9 Jun 2021 15:23:59 +0200
|
|
Subject: [PATCH] ci: reconfigure Packit for RHEL 9
|
|
|
|
Resolves: #1960703
|
|
rhel-only
|
|
---
|
|
.packit.yml | 28 ++++++++++++++++++----------
|
|
1 file changed, 18 insertions(+), 10 deletions(-)
|
|
|
|
diff --git a/.packit.yml b/.packit.yml
|
|
index 962c77913e..3461bccbc5 100644
|
|
--- a/.packit.yml
|
|
+++ b/.packit.yml
|
|
@@ -16,14 +16,12 @@ upstream_tag_template: "v{version}"
|
|
|
|
actions:
|
|
post-upstream-clone:
|
|
- # Use the Fedora Rawhide specfile
|
|
- - "git clone https://src.fedoraproject.org/rpms/systemd .packit_rpm --depth=1"
|
|
+ # Use the CentOS Stream specfile
|
|
+ - "git clone https://gitlab.com/redhat/centos-stream/rpms/systemd.git .packit_rpm --depth=1"
|
|
# Drop the "sources" file so rebase-helper doesn't think we're a dist-git
|
|
- "rm -fv .packit_rpm/sources"
|
|
- # Drop backported patches from the specfile, but keep the downstream-only ones
|
|
- # - Patch0000-0499: backported patches from upstream
|
|
- # - Patch0500-9999: downstream-only patches
|
|
- - "sed -ri '/^Patch0[0-4]?[0-9]{0,2}\\:.+\\.patch/d' .packit_rpm/systemd.spec"
|
|
+ # Drop all patches, since they're already included in the tarball
|
|
+ - "sed -ri '/^Patch[0-9]+:/d' .packit_rpm/systemd.spec"
|
|
# Build the RPM with --werror. Even though --werror doesn't work in all
|
|
# cases (see [0]), we can't use -Dc_args=/-Dcpp_args= here because of the
|
|
# RPM hardening macros, that use $CFLAGS/$CPPFLAGS (see [1]).
|
|
@@ -32,12 +30,22 @@ actions:
|
|
# [1] https://github.com/systemd/systemd/pull/18908#issuecomment-792250110
|
|
- 'sed -i "/^CONFIGURE_OPTS=(/a--werror" .packit_rpm/systemd.spec'
|
|
|
|
+# Available targets can be listed via `copr-cli list-chroots`
|
|
jobs:
|
|
+# Build test
|
|
- job: copr_build
|
|
trigger: pull_request
|
|
metadata:
|
|
targets:
|
|
- - fedora-rawhide-aarch64
|
|
- - fedora-rawhide-i386
|
|
- - fedora-rawhide-ppc64le
|
|
- - fedora-rawhide-x86_64
|
|
+ # FIXME: change to CentOS 9 once it's available
|
|
+ - fedora-34-x86_64
|
|
+ - fedora-34-aarch64
|
|
+
|
|
+# TODO: can't use TFT yet due to https://pagure.io/fedora-ci/general/issue/184
|
|
+# Run tests (via testing farm)
|
|
+#- job: tests
|
|
+# trigger: pull_request
|
|
+# metadata:
|
|
+# targets:
|
|
+# # FIXME: change to CentOS 9 once it's available
|
|
+# - fedora-34-x86_64
|