71 lines
2.0 KiB
Diff
71 lines
2.0 KiB
Diff
From e1deb661ba31023c77aaac6656da514654df3393 Mon Sep 17 00:00:00 2001
|
|
From: Michael Olbrich <m.olbrich@pengutronix.de>
|
|
Date: Mon, 9 Mar 2015 12:27:25 +0100
|
|
Subject: [PATCH] missing.h: add NDA_*
|
|
|
|
This is necessary to build with older kernel headers. NDA_VLAN was
|
|
introduced in v3.9 and NDA_PORT, NDA_VNI and NDA_IFINDEX in v3.10
|
|
|
|
(cherry picked from commit cf1755bac0426132c21fdca519a336ce7d920277)
|
|
---
|
|
configure.ac | 4 +++-
|
|
src/shared/missing.h | 16 ++++++++++++++++
|
|
2 files changed, 19 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 6bc347423b..14a7736a9e 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -333,7 +333,8 @@ AC_CHECK_DECLS([IFLA_INET6_ADDR_GEN_MODE,
|
|
IFLA_VXLAN_LOCAL6,
|
|
IFLA_IPTUN_6RD_RELAY_PREFIXLEN,
|
|
IFLA_BRIDGE_VLAN_INFO,
|
|
- IFLA_BRPORT_UNICAST_FLOOD],
|
|
+ IFLA_BRPORT_UNICAST_FLOOD,
|
|
+ NDA_IFINDEX],
|
|
[], [], [[
|
|
#include <inttypes.h>
|
|
#include <netinet/in.h>
|
|
@@ -344,6 +345,7 @@ AC_CHECK_DECLS([IFLA_INET6_ADDR_GEN_MODE,
|
|
#include <linux/if_tunnel.h>
|
|
#include <linux/if_link.h>
|
|
#include <linux/if_bridge.h>
|
|
+#include <linux/neighbour.h>
|
|
]])
|
|
|
|
# This makes sure pkg.m4 is available.
|
|
diff --git a/src/shared/missing.h b/src/shared/missing.h
|
|
index e72631e130..802b4957e0 100644
|
|
--- a/src/shared/missing.h
|
|
+++ b/src/shared/missing.h
|
|
@@ -35,6 +35,7 @@
|
|
#include <linux/loop.h>
|
|
#include <linux/audit.h>
|
|
#include <linux/capability.h>
|
|
+#include <linux/neighbour.h>
|
|
|
|
#ifdef HAVE_AUDIT
|
|
#include <libaudit.h>
|
|
@@ -623,6 +624,21 @@ static inline int setns(int fd, int nstype) {
|
|
#define IFLA_BRPORT_MAX (__IFLA_BRPORT_MAX - 1)
|
|
#endif
|
|
|
|
+#if !HAVE_DECL_NDA_IFINDEX
|
|
+#define NDA_UNSPEC 0
|
|
+#define NDA_DST 1
|
|
+#define NDA_LLADDR 2
|
|
+#define NDA_CACHEINFO 3
|
|
+#define NDA_PROBES 4
|
|
+#define NDA_VLAN 5
|
|
+#define NDA_PORT 6
|
|
+#define NDA_VNI 7
|
|
+#define NDA_IFINDEX 8
|
|
+#define __NDA_MAX 9
|
|
+
|
|
+#define NDA_MAX (__NDA_MAX - 1)
|
|
+#endif
|
|
+
|
|
#ifndef IPV6_UNICAST_IF
|
|
#define IPV6_UNICAST_IF 76
|
|
#endif
|