79350f79d8
Resolves: #2137584,#2138081,#2141979
45 lines
1.8 KiB
Diff
45 lines
1.8 KiB
Diff
From 16f2d0c4a25a717a9a0b49903a55db1263156055 Mon Sep 17 00:00:00 2001
|
|
From: Frantisek Sumsal <frantisek@sumsal.cz>
|
|
Date: Wed, 9 Jun 2021 15:23:59 +0200
|
|
Subject: [PATCH] ci: reconfigure Packit for RHEL 9
|
|
|
|
Related: #2138081
|
|
rhel-only
|
|
---
|
|
.packit.yml | 12 ++++++------
|
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/.packit.yml b/.packit.yml
|
|
index a7502b25b4..d0eebab181 100644
|
|
--- a/.packit.yml
|
|
+++ b/.packit.yml
|
|
@@ -17,14 +17,12 @@ srpm_build_deps: []
|
|
|
|
actions:
|
|
post-upstream-clone:
|
|
- # Use the Fedora Rawhide specfile
|
|
- - "git clone https://src.fedoraproject.org/rpms/systemd .packit_rpm --depth=1"
|
|
+ # Use the CentOS Stream specfile
|
|
+ - "git clone https://gitlab.com/redhat/centos-stream/rpms/systemd.git .packit_rpm --depth=1"
|
|
# Drop the "sources" file so rebase-helper doesn't think we're a dist-git
|
|
- "rm -fv .packit_rpm/sources"
|
|
- # Drop backported patches from the specfile, but keep the downstream-only ones
|
|
- # - Patch(0000-0499): backported patches from upstream
|
|
- # - Patch0500-9999: downstream-only patches
|
|
- - "sed -ri '/^Patch(0[0-4]?[0-9]{0,2})?\\:.+\\.patch/d' .packit_rpm/systemd.spec"
|
|
+ # Drop all patches, since they're already included in the tarball
|
|
+ - "sed -ri '/^Patch[0-9]+:/d' .packit_rpm/systemd.spec"
|
|
# Build the RPM with --werror. Even though --werror doesn't work in all
|
|
# cases (see [0]), we can't use -Dc_args=/-Dcpp_args= here because of the
|
|
# RPM hardening macros, that use $CFLAGS/$CPPFLAGS (see [1]).
|
|
@@ -33,7 +31,9 @@ actions:
|
|
# [1] https://github.com/systemd/systemd/pull/18908#issuecomment-792250110
|
|
- 'sed -i "/^CONFIGURE_OPTS=(/a--werror" .packit_rpm/systemd.spec'
|
|
|
|
+# Available targets can be listed via `copr-cli list-chroots`
|
|
jobs:
|
|
+# Build test
|
|
- job: copr_build
|
|
trigger: pull_request
|
|
metadata:
|