81 lines
2.9 KiB
Diff
81 lines
2.9 KiB
Diff
From 6b5b5fefcb68cb53427747be4984531bdeddcf7e Mon Sep 17 00:00:00 2001
|
|
From: David Tardon <dtardon@redhat.com>
|
|
Date: Fri, 2 Jul 2021 13:25:51 +0200
|
|
Subject: [PATCH] Copy 40-redhat.rules from RHEL-8
|
|
|
|
RHEL-only
|
|
|
|
Related: #2138081
|
|
---
|
|
rules.d/40-redhat.rules | 46 +++++++++++++++++++++++++++++++++++++++++
|
|
rules.d/meson.build | 3 ++-
|
|
2 files changed, 48 insertions(+), 1 deletion(-)
|
|
create mode 100644 rules.d/40-redhat.rules
|
|
|
|
diff --git a/rules.d/40-redhat.rules b/rules.d/40-redhat.rules
|
|
new file mode 100644
|
|
index 0000000000..3c95cd2df0
|
|
--- /dev/null
|
|
+++ b/rules.d/40-redhat.rules
|
|
@@ -0,0 +1,46 @@
|
|
+# do not edit this file, it will be overwritten on update
|
|
+
|
|
+# CPU hotadd request
|
|
+SUBSYSTEM=="cpu", ACTION=="add", TEST=="online", ATTR{online}=="0", ATTR{online}="1"
|
|
+
|
|
+# Memory hotadd request
|
|
+SUBSYSTEM!="memory", GOTO="memory_hotplug_end"
|
|
+ACTION!="add", GOTO="memory_hotplug_end"
|
|
+CONST{arch}=="s390*", GOTO="memory_hotplug_end"
|
|
+CONST{arch}=="ppc64*", GOTO="memory_hotplug_end"
|
|
+
|
|
+ENV{.state}="online"
|
|
+CONST{virt}=="none", ENV{.state}="online_movable"
|
|
+ATTR{state}=="offline", ATTR{state}="$env{.state}"
|
|
+
|
|
+LABEL="memory_hotplug_end"
|
|
+
|
|
+# reload sysctl.conf / sysctl.conf.d settings when the bridge module is loaded
|
|
+ACTION=="add", SUBSYSTEM=="module", KERNEL=="bridge", RUN+="/usr/lib/systemd/systemd-sysctl --prefix=/proc/sys/net/bridge"
|
|
+
|
|
+# load SCSI generic (sg) driver
|
|
+SUBSYSTEM=="scsi", ENV{DEVTYPE}=="scsi_device", TEST!="[module/sg]", RUN+="/sbin/modprobe -bv sg"
|
|
+SUBSYSTEM=="scsi", ENV{DEVTYPE}=="scsi_target", TEST!="[module/sg]", RUN+="/sbin/modprobe -bv sg"
|
|
+
|
|
+# Rule for prandom character device node permissions
|
|
+KERNEL=="prandom", MODE="0644"
|
|
+
|
|
+# Rules for creating the ID_PATH for SCSI devices based on the CCW bus
|
|
+# using the form: ccw-<BUS_ID>-zfcp-<WWPN>:<LUN>
|
|
+#
|
|
+ACTION=="remove", GOTO="zfcp_scsi_device_end"
|
|
+
|
|
+#
|
|
+# Set environment variable "ID_ZFCP_BUS" to "1" if the devices
|
|
+# (both disk and partition) are SCSI devices based on FCP devices
|
|
+#
|
|
+KERNEL=="sd*", SUBSYSTEMS=="ccw", DRIVERS=="zfcp", ENV{.ID_ZFCP_BUS}="1"
|
|
+
|
|
+# For SCSI disks
|
|
+KERNEL=="sd*[!0-9]", SUBSYSTEMS=="scsi", ENV{.ID_ZFCP_BUS}=="1", ENV{DEVTYPE}=="disk", SYMLINK+="disk/by-path/ccw-$attr{hba_id}-zfcp-$attr{wwpn}:$attr{fcp_lun}"
|
|
+
|
|
+
|
|
+# For partitions on a SCSI disk
|
|
+KERNEL=="sd*[0-9]", SUBSYSTEMS=="scsi", ENV{.ID_ZFCP_BUS}=="1", ENV{DEVTYPE}=="partition", SYMLINK+="disk/by-path/ccw-$attr{hba_id}-zfcp-$attr{wwpn}:$attr{fcp_lun}-part%n"
|
|
+
|
|
+LABEL="zfcp_scsi_device_end"
|
|
diff --git a/rules.d/meson.build b/rules.d/meson.build
|
|
index 8d2878a36d..70f48e877b 100644
|
|
--- a/rules.d/meson.build
|
|
+++ b/rules.d/meson.build
|
|
@@ -5,7 +5,8 @@ install_data(
|
|
install_dir : udevrulesdir)
|
|
|
|
rules = [
|
|
- [files('60-autosuspend.rules',
|
|
+ [files('40-redhat.rules',
|
|
+ '60-autosuspend.rules',
|
|
'60-block.rules',
|
|
'60-cdrom_id.rules',
|
|
'60-drm.rules',
|