Renumber patches properly

This commit is contained in:
Zbigniew Jędrzejewski-Szmek 2013-10-21 23:59:59 -04:00
parent 9e747a1649
commit e106c41c2a
12 changed files with 10 additions and 123 deletions

View File

@ -1,4 +1,4 @@
From 7bd470024862982a74c3850686c99ccb29989fae Mon Sep 17 00:00:00 2001
From cd1338b7abe6d300ce66051f3490f35c8b4d1443 Mon Sep 17 00:00:00 2001
From: Igor Zhbanov <i.zhbanov@samsung.com>
Date: Tue, 15 Oct 2013 14:35:13 +0400
Subject: [PATCH] Fix for SIGSEGV in systemd-bootchart on short-living

View File

@ -1,70 +0,0 @@
From 90144377494d06804b55b915e1321a2e85a957fe Mon Sep 17 00:00:00 2001
From: Kay Sievers <kay@vrfy.org>
Date: Tue, 15 Oct 2013 02:11:56 +0200
Subject: [PATCH] build-sys: libudev - get rid of the needless selinux linking
(again)
---
Makefile.am | 6 +-----
src/libudev/libudev.pc.in | 1 -
2 files changed, 1 insertion(+), 6 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 8d9c587..94d3358 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2141,9 +2141,7 @@ libudev_la_LDFLAGS = \
libudev_la_LIBADD = \
libsystemd-shared.la \
- libsystemd-label.la \
libsystemd-daemon-internal.la \
- $(RT_LIBS) \
libsystemd-id128-internal.la
pkgconfiglib_DATA += \
@@ -2315,7 +2313,6 @@ libudev_core_la_LIBADD = \
libudev-private.la \
libsystemd-label.la \
libsystemd-daemon-internal.la \
- $(RT_LIBS) \
libsystemd-shared.la \
$(BLKID_LIBS) \
$(KMOD_LIBS)
@@ -2377,6 +2374,7 @@ udevadm_SOURCES = \
udevadm_LDADD = \
libudev-core.la \
+ libsystemd-label.la \
libsystemd-shared.la
# Update hwdb on installation. Do not bother if installing
@@ -2704,7 +2702,6 @@ libsystemd_id128_la_LDFLAGS = \
libsystemd_id128_la_LIBADD = \
libsystemd-shared.la \
- libsystemd-label.la \
libsystemd-daemon-internal.la \
$(RT_LIBS)
@@ -2956,7 +2953,6 @@ libsystemd_journal_internal_la_CFLAGS = \
$(AM_CFLAGS)
libsystemd_journal_internal_la_LIBADD = \
- libsystemd-label.la \
libsystemd-audit.la \
libsystemd-daemon.la \
libudev.la \
diff --git a/src/libudev/libudev.pc.in b/src/libudev/libudev.pc.in
index 2b183e9..a0f3f52 100644
--- a/src/libudev/libudev.pc.in
+++ b/src/libudev/libudev.pc.in
@@ -14,5 +14,4 @@ Name: libudev
Description: Library to access udev device information
Version: @VERSION@
Libs: -L${libdir} -ludev
-Libs.private: -lrt
Cflags: -I${includedir}
--
1.8.4.652.g0d6e0ce

View File

@ -1,43 +0,0 @@
From c028fc20a15e274f1bfa0febbc21d5ac5ea84be4 Mon Sep 17 00:00:00 2001
From: Kay Sievers <kay@vrfy.org>
Date: Tue, 15 Oct 2013 02:26:37 +0200
Subject: [PATCH] build-sys: libsystemd-id128 - get rid of the needless selinux
linking (again)
$ ldd libsystemd-id128.so
linux-vdso.so.1 => (0x00007fffce377000)
libselinux.so.1 => /lib64/libselinux.so.1 (0x00007f4de1fc1000)
librt.so.1 => /lib64/librt.so.1 (0x00007f4de1db9000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f4de1bb4000)
libc.so.6 => /lib64/libc.so.6 (0x00007f4de17f5000)
/lib64/ld-linux-x86-64.so.2 (0x00007f4de2406000)
libpcre.so.1 => /lib64/libpcre.so.1 (0x00007f4de158f000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f4de1371000)
$ ldd libsystemd-id128.so
linux-vdso.so.1 => (0x00007fff25187000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f41a3964000)
libc.so.6 => /lib64/libc.so.6 (0x00007f41a35a5000)
/lib64/ld-linux-x86-64.so.2 (0x00007f41a3d89000)
---
Makefile.am | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 94d3358..5382547 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2701,9 +2701,7 @@ libsystemd_id128_la_LDFLAGS = \
-Wl,--version-script=$(top_srcdir)/src/libsystemd-id128/libsystemd-id128.sym
libsystemd_id128_la_LIBADD = \
- libsystemd-shared.la \
- libsystemd-daemon-internal.la \
- $(RT_LIBS)
+ libsystemd-shared.la
libsystemd_id128_internal_la_SOURCES = \
$(libsystemd_id128_la_SOURCES)
--
1.8.4.652.g0d6e0ce

View File

@ -1,4 +1,4 @@
From e31ed70d82d55fd8ed17fee4efe010575ed2ab2e Mon Sep 17 00:00:00 2001
From 3dca881397af86883639ab25f27dfb605acc2a2c Mon Sep 17 00:00:00 2001
From: Jan Engelhardt <jengelh@inai.de>
Date: Tue, 15 Oct 2013 08:58:50 +0200
Subject: [PATCH] man: document the -b special boot option

View File

@ -1,4 +1,4 @@
From 8345f2e25909cc24628d99eee6674e8ab7ebdb20 Mon Sep 17 00:00:00 2001
From 6d3e661d97dd6157381ca1dd52b839e2049b86b5 Mon Sep 17 00:00:00 2001
From: David Herrmann <dh.herrmann@gmail.com>
Date: Tue, 15 Oct 2013 21:13:39 +0200
Subject: [PATCH] logind: allow unprivileged session-device access

View File

@ -1,4 +1,4 @@
From 0316e2ae1224abc57cffe8ec54326b4b55b0372e Mon Sep 17 00:00:00 2001
From 78846d19d3569cf637d2e37c10e75395ebcf9d06 Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Wed, 16 Oct 2013 02:49:54 +0200
Subject: [PATCH] rules: expose loop block devices to systemd

View File

@ -1,4 +1,4 @@
From 6e921d55d1a568bc8d6bf59907e673f7f56b9751 Mon Sep 17 00:00:00 2001
From 9a3296571683a6a3eaee44d18db91ca113841da6 Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Wed, 16 Oct 2013 02:51:24 +0200
Subject: [PATCH] rules: don't limit some of the rules to the "add" action

View File

@ -1,4 +1,4 @@
From 41d174a74c7c7ebcc5b00fe92ef4647f47551e96 Mon Sep 17 00:00:00 2001
From bc3ae365890fa52f9beca1a67744a0fcbdcb5f82 Mon Sep 17 00:00:00 2001
From: Kay Sievers <kay@vrfy.org>
Date: Thu, 17 Oct 2013 03:20:46 +0200
Subject: [PATCH] tmpfiles: log unaccessible FUSE mount points only as debug

View File

@ -1,4 +1,4 @@
From a697938328b686626abe0b8ac1878954a4705672 Mon Sep 17 00:00:00 2001
From d7490751d3036a2b01ac74cdf4b632803f0b9ea9 Mon Sep 17 00:00:00 2001
From: Kay Sievers <kay@vrfy.org>
Date: Sun, 20 Oct 2013 01:12:29 +0200
Subject: [PATCH] hwdb: update

View File

@ -1,4 +1,4 @@
From 831f4f7266961f481f48da3461b332974c15e9f1 Mon Sep 17 00:00:00 2001
From 431e477b8e66ddbaba28a9f59fb8ae2e16d59cb5 Mon Sep 17 00:00:00 2001
From: Kay Sievers <kay@vrfy.org>
Date: Mon, 21 Oct 2013 03:49:03 +0200
Subject: [PATCH] rules: remove pointless MODE= settings

View File

@ -1,4 +1,4 @@
From 5c56656c5f135dbb6549bd9d662bbb7d238638e2 Mon Sep 17 00:00:00 2001
From ff86c42c8614828be77810a50202e1f771b35ff3 Mon Sep 17 00:00:00 2001
From: Thomas Hindoe Paaboel Andersen <phomes@gmail.com>
Date: Mon, 21 Oct 2013 21:29:23 +0200
Subject: [PATCH] analyze: set white backgound

View File

@ -1,4 +1,4 @@
From b8cc2a94ad07cf529258ef0dde4002d8e1166f25 Mon Sep 17 00:00:00 2001
From 8ee1b98e2f4d4d36d9fccc776aa3fb124d05ac9b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
Date: Mon, 21 Oct 2013 18:53:57 -0400
Subject: [PATCH] shell-completion: dump has moved to systemd-analyze