Update to v243.4
This commit is contained in:
parent
5abc564f03
commit
da9dae21d7
104
13792.patch
104
13792.patch
@ -1,104 +0,0 @@
|
|||||||
From 8af4c8abfb59ab66f1f5a34f0eac1342e6f0c7e5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
||||||
Date: Thu, 17 Oct 2019 12:37:12 +0200
|
|
||||||
Subject: [PATCH] udev: tag any display devices as master-of-seat when
|
|
||||||
nomodeset is used
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Fixes #13773. See also https://bugzilla.redhat.com/show_bug.cgi?id=1728240,
|
|
||||||
https://github.com/sddm/sddm/issues/1204.
|
|
||||||
|
|
||||||
When nomodeset is used on the kernel command line, there is no graphics
|
|
||||||
device that the kernel knows, so we don't tag anything as master-of-seat,
|
|
||||||
and seat0 has CanGraphical=no.
|
|
||||||
|
|
||||||
$ loginctl seat-status seat0 ; loginctl show-seat seat0
|
|
||||||
seat0
|
|
||||||
Devices:
|
|
||||||
├─/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
|
|
||||||
│ input:input0 "Power Button"
|
|
||||||
├─/sys/devices/pci0000:00/0000:00:02.1/0000:02:00.0/usb1
|
|
||||||
│ usb:usb1
|
|
||||||
│ └─/sys/devices/pci0000:00/0000:00:02.1/0000:02:00.0/usb1/1-1/1-1:1.0/0003:0627:0001.0001/input/input4
|
|
||||||
│ input:input4 "QEMU QEMU USB Tablet"
|
|
||||||
├─/sys/devices/pci0000:00/0000:00:02.1/0000:02:00.0/usb2
|
|
||||||
│ usb:usb2
|
|
||||||
├─/sys/devices/pci0000:00/0000:00:1b.0/sound/card0
|
|
||||||
│ sound:card0 "Intel"
|
|
||||||
├─/sys/devices/platform/i8042/serio0/input/input1
|
|
||||||
│ input:input1 "AT Translated Set 2 keyboard"
|
|
||||||
│ ├─/sys/devices/platform/i8042/serio0/input/input1/input1::capslock
|
|
||||||
│ │ leds:input1::capslock
|
|
||||||
│ ├─/sys/devices/platform/i8042/serio0/input/input1/input1::numlock
|
|
||||||
│ │ leds:input1::numlock
|
|
||||||
│ └─/sys/devices/platform/i8042/serio0/input/input1/input1::scrolllock
|
|
||||||
│ leds:input1::scrolllock
|
|
||||||
└─/sys/devices/platform/i8042/serio1/input/input3
|
|
||||||
input:input3 "ImExPS/2 Generic Explorer Mouse"
|
|
||||||
Id=seat0
|
|
||||||
CanMultiSession=yes
|
|
||||||
CanTTY=yes
|
|
||||||
CanGraphical=no
|
|
||||||
Sessions=
|
|
||||||
IdleHint=yes
|
|
||||||
IdleSinceHint=0
|
|
||||||
IdleSinceHintMonotonic=0
|
|
||||||
|
|
||||||
Let's tag the PCI device with "master-of-seat", so we get CanGraphical=yes, and "seat",
|
|
||||||
so it is show as part of the seat:
|
|
||||||
|
|
||||||
[fedora@f31-bios ~]$ loginctl seat-status seat0 ; loginctl show-seat seat0
|
|
||||||
seat0
|
|
||||||
Devices:
|
|
||||||
├─/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
|
|
||||||
│ input:input0 "Power Button"
|
|
||||||
├─/sys/devices/pci0000:00/0000:00:01.0
|
|
||||||
│ [MASTER] pci:0000:00:01.0
|
|
||||||
├─/sys/devices/pci0000:00/0000:00:02.1/0000:02:00.0/usb1
|
|
||||||
│ usb:usb1
|
|
||||||
│ └─/sys/devices/pci0000:00/0000:00:02.1/0000:02:00.0/usb1/1-1/1-1:1.0/0003:0627:0001.0001/input/input4
|
|
||||||
│ input:input4 "QEMU QEMU USB Tablet"
|
|
||||||
├─/sys/devices/pci0000:00/0000:00:02.1/0000:02:00.0/usb2
|
|
||||||
│ usb:usb2
|
|
||||||
├─/sys/devices/pci0000:00/0000:00:1b.0/sound/card0
|
|
||||||
│ sound:card0 "Intel"
|
|
||||||
├─/sys/devices/platform/i8042/serio0/input/input1
|
|
||||||
│ input:input1 "AT Translated Set 2 keyboard"
|
|
||||||
│ ├─/sys/devices/platform/i8042/serio0/input/input1/input1::capslock
|
|
||||||
│ │ leds:input1::capslock
|
|
||||||
│ ├─/sys/devices/platform/i8042/serio0/input/input1/input1::numlock
|
|
||||||
│ │ leds:input1::numlock
|
|
||||||
│ └─/sys/devices/platform/i8042/serio0/input/input1/input1::scrolllock
|
|
||||||
│ leds:input1::scrolllock
|
|
||||||
└─/sys/devices/platform/i8042/serio1/input/input3
|
|
||||||
input:input3 "ImExPS/2 Generic Explorer Mouse"
|
|
||||||
Id=seat0
|
|
||||||
CanMultiSession=yes
|
|
||||||
CanTTY=yes
|
|
||||||
CanGraphical=yes
|
|
||||||
Sessions=
|
|
||||||
IdleHint=yes
|
|
||||||
IdleSinceHint=0
|
|
||||||
IdleSinceHintMonotonic=0
|
|
||||||
---
|
|
||||||
src/login/71-seat.rules.in | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/login/71-seat.rules.in b/src/login/71-seat.rules.in
|
|
||||||
index 6010f048aef..2bbd18363e6 100644
|
|
||||||
--- a/src/login/71-seat.rules.in
|
|
||||||
+++ b/src/login/71-seat.rules.in
|
|
||||||
@@ -24,6 +24,11 @@ SUBSYSTEM=="graphics", KERNEL=="fb[0-9]", DRIVERS=="hyperv_fb", TAG+="master-of-
|
|
||||||
# Allow efifb / uvesafb to be a master if KMS is disabled
|
|
||||||
SUBSYSTEM=="graphics", KERNEL=="fb[0-9]", IMPORT{cmdline}="nomodeset", TAG+="master-of-seat"
|
|
||||||
|
|
||||||
+# Allow any PCI graphics device to be a master and synthesize a seat if KMS
|
|
||||||
+# is disabled and the kernel doesn't have a driver that would work with this device.
|
|
||||||
+SUBSYSTEM=="pci", ENV{ID_PCI_CLASS_FROM_DATABASE}=="Display controller", \
|
|
||||||
+ ENV{DRIVER}=="", IMPORT{cmdline}="nomodeset", TAG+="seat", TAG+="master-of-seat"
|
|
||||||
+
|
|
||||||
SUBSYSTEM=="drm", KERNEL=="card[0-9]*", TAG+="seat", TAG+="master-of-seat"
|
|
||||||
SUBSYSTEM=="usb", ATTR{bDeviceClass}=="09", TAG+="seat"
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (systemd-ef67743.tar.gz) = 9e905ef4f310f5cbd739f15d51e8c500b0e6ce2fbd2ad33b6568e06212ecfb5bba1347754c00b37d30a5b65cd2432d99aef87ebbafa1a94b4185d773f4ce4987
|
SHA512 (systemd-243.4.tar.gz) = f121e4ea0c65050e3cd2dcbb3d3e8aa24f728548976ba72d6da26c61fb80c4352f1ba259be4310081acde901c13b1e812cf7df4d84d6cd2bd3c4f8acf72300fb
|
||||||
|
24
systemd.spec
24
systemd.spec
@ -1,4 +1,4 @@
|
|||||||
%global commit ef677436aa203c24816021dd698b57f219f0ff64
|
#global commit ef677436aa203c24816021dd698b57f219f0ff64
|
||||||
%{?commit:%global shortcommit %(c=%{commit}; echo ${c:0:7})}
|
%{?commit:%global shortcommit %(c=%{commit}; echo ${c:0:7})}
|
||||||
|
|
||||||
%global stable 1
|
%global stable 1
|
||||||
@ -14,8 +14,8 @@
|
|||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Url: https://www.freedesktop.org/wiki/Software/systemd
|
Url: https://www.freedesktop.org/wiki/Software/systemd
|
||||||
Version: 243
|
Version: 243.4
|
||||||
Release: 4%{?commit:.git%{shortcommit}}%{?dist}
|
Release: 1%{?commit:.git%{shortcommit}}%{?dist}
|
||||||
# For a breakdown of the licensing, see README
|
# For a breakdown of the licensing, see README
|
||||||
License: LGPLv2+ and MIT and GPLv2+
|
License: LGPLv2+ and MIT and GPLv2+
|
||||||
Summary: System and Service Manager
|
Summary: System and Service Manager
|
||||||
@ -26,8 +26,12 @@ Summary: System and Service Manager
|
|||||||
%if %{defined commit}
|
%if %{defined commit}
|
||||||
Source0: https://github.com/systemd/systemd%{?stable:-stable}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
Source0: https://github.com/systemd/systemd%{?stable:-stable}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
||||||
%else
|
%else
|
||||||
|
%if 0%{stable}
|
||||||
|
Source0: https://github.com/systemd/systemd-stable/archive/v%{github_version}/%{name}-%{github_version}.tar.gz
|
||||||
|
%else
|
||||||
Source0: https://github.com/systemd/systemd/archive/v%{github_version}/%{name}-%{github_version}.tar.gz
|
Source0: https://github.com/systemd/systemd/archive/v%{github_version}/%{name}-%{github_version}.tar.gz
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
# This file must be available before %%prep.
|
# This file must be available before %%prep.
|
||||||
# It is generated during systemd build and can be found in build/src/core/.
|
# It is generated during systemd build and can be found in build/src/core/.
|
||||||
Source1: triggers.systemd
|
Source1: triggers.systemd
|
||||||
@ -57,11 +61,6 @@ Patch0001: https://github.com/keszybz/systemd/commit/464a73411c13596a130a7a
|
|||||||
|
|
||||||
Patch0002: 0002-Revert-units-set-NoNewPrivileges-for-all-long-runnin.patch
|
Patch0002: 0002-Revert-units-set-NoNewPrivileges-for-all-long-runnin.patch
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1728240
|
|
||||||
# https://github.com/systemd/systemd/issues/13773
|
|
||||||
# https://github.com/systemd/systemd/pull/13792
|
|
||||||
Patch0003: 13792.patch
|
|
||||||
|
|
||||||
Patch0998: 0998-resolved-create-etc-resolv.conf-symlink-at-runtime.patch
|
Patch0998: 0998-resolved-create-etc-resolv.conf-symlink-at-runtime.patch
|
||||||
|
|
||||||
%ifarch %{ix86} x86_64 aarch64
|
%ifarch %{ix86} x86_64 aarch64
|
||||||
@ -707,6 +706,15 @@ fi
|
|||||||
%files tests -f .file-list-tests
|
%files tests -f .file-list-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 19 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 243.4
|
||||||
|
- Latest bugfix release. Systemd-stable snapshots will now be numbered.
|
||||||
|
- Fix broken PrivateDevices filter on big-endian, s390x in particular (#1769148)
|
||||||
|
- systemd-modules-load.service should only warn, not fail, on error (#1254340)
|
||||||
|
- Fix incorrect certificate validation with DNS over TLS (#1771725, #1771726,
|
||||||
|
CVE-2018-21029)
|
||||||
|
- Fix regression with crypttab keys with colons
|
||||||
|
- Various memleaks and minor memory access issues, warning adjustments
|
||||||
|
|
||||||
* Fri Oct 18 2019 Adam Williamson <awilliam@redhat.com> - 243-4.gitef67743
|
* Fri Oct 18 2019 Adam Williamson <awilliam@redhat.com> - 243-4.gitef67743
|
||||||
- Backport PR #13792 to fix nomodeset+BIOS CanGraphical bug (#1728240)
|
- Backport PR #13792 to fix nomodeset+BIOS CanGraphical bug (#1728240)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user